1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Seite ohne Inhalt

Dieses Thema im Forum "Allgemeines" wurde erstellt von Keyes, 26. Juli 2010.

Schlagworte:
  1. Keyes

    Keyes Member

    Registriert seit:
    26. Juli 2010
    Beiträge:
    7
    Zustimmungen:
    0
    Hola!

    ich arbeite schon etwas länger mit wordpress, und bin gerade dabei eine seite für meinen kleinen betrieb aufzubauen. also habe ich mir ein design mit photoshop gebastelt, das ganze in html und css gecoded und mit den original-dateien des kubrick-themes zusammengeworfen. hat auch soweit super funktioniert, nur seit neustem wird auf den seiten (pages.php) und auf den einzelnen beitrags-übersicht (single.php) nurnoch der titel der news/seite angezeigt - zeitlich gesehen kommt das ungefähr mit meinem update auf 3.0 hin. wenn man sich die seite im quelltext-browser anschaut, gibt die funktion "the_content" offenbar auch garkeinen inhalt aus (habs auch schon mit einer if-abfrage getestet, da kommt garnichts rüber!), wenn ich allerdings zum standart-template wechsle läuft alles. auch das löschen/deaktivieren sämtlicher plugins hat nichts geholfen, und so langsam bin ich wirklich ratlos...

    bitte um hilfe!

    Link zur Seite: http://k0re.de/page

    mfg
     
  2. Money4all

    Money4all Active Member

    Registriert seit:
    22. Juli 2010
    Beiträge:
    39
    Zustimmungen:
    0
    Hast du in der page.php noch min. folgendes drin?

    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
     
  3. Keyes

    Keyes Member

    Registriert seit:
    26. Juli 2010
    Beiträge:
    7
    Zustimmungen:
    0
    sieht etwas anders aus, aber alles wichtige noch da:

    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    es hat ja auch mit der "alten" 2.9.x funktioniert, es scheint erst seit dem update nicht mehr zu gehen
     
    #3 Keyes, 26. Juli 2010
    Zuletzt bearbeitet: 26. Juli 2010
  4. Keyes

    Keyes Member

    Registriert seit:
    26. Juli 2010
    Beiträge:
    7
    Zustimmungen:
    0
    hab das problem jetzt einkreisen bzw. lösen können:

    the_content() gibt tatsächlich absolut keinen inhalt aus. (war ja bekannt)
    allerdings funktioniert "<?php echo $post->post_content; ?>", nur hat eben keine formatierung...

    letztendlich konnte ich das problem etwas unsauber mit folgendem code lösen:

    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    wird alles richtig dargestellt, nur eigendlich ist der code ja für was ganz anderes gedacht...

    das problem scheint es auch schon "öfters" gegeben zu haben:
    http://wordpress.org/support/topic/309768

    ich würds mal nicht als "gelöst" bezeichnen, eher als "workaround", mach mich nachher mal ran die funktion the_content() etwas genauer zu untersuchen
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden