1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Seite wird mit "noindex" getaggt mit Yoast SEO

Dieses Thema im Forum "Plugins und Widgets" wurde erstellt von Franky2207, 12. Oktober 2020.

Schlagworte:
  1. Franky2207

    Franky2207 New Member

    Registriert seit:
    7. September 2018
    Beiträge:
    4
    Zustimmungen:
    0
    Hallo zusammen, ich arbeite erst seit kurzem mit Yoast SEO, habe mir aber soweit die meisten Tutorials und alle relevanten Infos durchgelesen. Mein Problem dabei weiter bestehen: Nachdem ich überall "visible for search engines" etc. angekreuzt habe (in Yoast SEO selbst, unter den Artikeln sowie auch in den generellen Settings bei Wordpress), zeigt mir die Google Seach Console weiterhin an, dass meine ARtikel den "noindex" tag aufweisen und nicht indiziert werden können.
    Ich weiß nun wirklich nicht, was ich da noch einstellen soll (bin alles nochmal mehrmals durchgegangen) und Yoast SEO selbst zeigt mir in Wordpress alles als "korrekt" an und "keine Problem" - demnach sollte es also laufen, tut es aber nicht.
    Ich frage mich nun, woran das liegt? Mein erster Gedanke war: Brauche ich Yoast Premium dafür? Und sonst klappt es nicht oder es gibt noch eine versteckte Einstellung dafür?
    Mein Blog ist: https://www.nachhilfe-team.net/lernen-leicht-gemacht/
    Ein Artikel, der eigentlich korrekt eingestellt sein sollte, aber nicht indiziert wird, ist: https://www.nachhilfe-team.net/lernen-leicht-gemacht/lerntypen/

    Ich bin sehr, sehr dankbar für Hilfe, um dieses Problem endlich lösen zu können :<.

    Schönen Tag euch allen!
     
  2. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    7.762
    Zustimmungen:
    820
    Der Artikel ist erreichbar für Suchmaschinen, was zeigt "Live-URL" testen in der Google Search Console?
     
  3. Henk1060

    Henk1060 Well-Known Member

    Registriert seit:
    4. September 2014
    Beiträge:
    3.224
    Zustimmungen:
    224
    kann es sein das der google bot schon länger nicht auf deiner seite war.
    Und daher noch nicht im index war?
     
  4. Franky2207

    Franky2207 New Member

    Registriert seit:
    7. September 2018
    Beiträge:
    4
    Zustimmungen:
    0
    Hi,
    danke erst mal für eure Mühe und den Support!

    Ich glaube, dass das Ganze leider etwas komplizierter ist... Die Haupt-Website (www.nachhilfe-team.net) ist per Hand programmiert (ohne WP oder Yoast SEO) und nur der Blog (www.nachhilfe-team.net/lernen-leicht-gemacht/) ist dann mit WordPress (und Yoast SEO) hinzugekommen (und verlinkt auf der Hauptseite im Footer). Leider scheint das Google etwas zu verwirren und ich erhalte zum Beispiel in der Search Console die Rückmeldung (als Fehler):

    Folgende Website hat den "noindex"-Tag
    -> https://www.nachhilfe-team.net/lernen-leicht-gemacht/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nachhilfe-team.net%2Flernen-leicht-gemacht%2Fgedichtanalyse%2F&format=xml

    Und ich verstehe dabei eigentlich gar nicht, warum die URL so vermurkst aussieht, da eigentlich überall (bei permalink, bei yoast seo settings etc. etc.) die "normale" URL eingestellt ist, also:
    -> https://www.nachhilfe-team.net/lernen-leicht-gemacht/gedichtanalyse

    UND dann wird eben angezeigt, dass die Artikel den "noindex" Tag enthalten. Weiterhin kommt nun hinzu - wie ich erfahren habe - dass Yoast SEO eine eigene Sitemap erstellt hat und es damit zwei gibt, die von der Haupt-Website (unter www.nachhilfe-team.net/sitemap.xml) und die von Yoast SEO. In der Haupt-Sitemap sind bereits die Artikel natürlich alle mit drin...

    Ich danke euch für jegliche Hilfe und Unterstützung!
     
  5. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    7.762
    Zustimmungen:
    820
    Der noindex ist hier auch völlig korrekt. Hast Du diesen Link mal aufgerufen? Einen Embed-Auszug im XML Format will man nicht im Ergebnis Index haben. Aus irgendwelchen Gründen steht dieser und weitere ähnliche Links in Deiner /sitemap.xml, da gehören die natürlich nicht rein. Bereinige diese Sitemap.
    Der Artikel ist erreichbar für Suchmaschinen, was zeigt "Live-URL testen" mit dieser URL in der Google Search Console?
     
    #5 b3317133, 13. Oktober 2020
    Zuletzt bearbeitet: 13. Oktober 2020
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden