1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Seo Yoast - Medien in die Sitemapexxl oder nicht

Dieses Thema im Forum "Plugins und Widgets" wurde erstellt von Persephone, 17. Mai 2017.

  1. Persephone

    Persephone Well-Known Member

    Registriert seit:
    21. Februar 2016
    Beiträge:
    249
    Zustimmungen:
    1
    Hallo,
    vor einiger Zeit ist mir aufgefallen, dass die Bilder zu meinen Beiträgen mit upload URL im Netz stehen. Zumindest in meinem Fall indiziert Google häufig die zugehörigen Anhang-Seiten noch vor dem eigentlichen Beitrag, gibt sie bei Suchanfragen mit passenden Keyword an einer höheren Position aus, als meinen Beitrag. Das ist ein ziemliches Chaos in meinen Augen und bestimmt nicht gut für meine Website. Im Netz finde ich nur langatmige Texte, die entweder das Plugin Seo Yoast bewerben oder unterschiedliche Angaben über Bilder und wie sie ranken machen.
    Jemand schrieb, man solle die Medien auf noindex setzen aber dann müssen die Medien doch auch aus der Sitemape, oder nicht?
    Wie habt ihr das Problem gelöst oder ist es euch egal (kann ich mir aber nicht vorstellen)?
    Egal was ich bisher optimiert habe, es ist durch nichts besser geworden, eher schlechter.
    Zum blocken komme ich kaum noch, weil ich 24/7 mit so etwas beschäftigt bin. Bei Seobility erreicht meine Seite 83%, wp content chache autoptimize macht auch noch Probleme. Jetzt aber erst die Bilder!

    Danke für eure Bemühungen und einen schönen Mittwoch
     
  2. Kristof

    Kristof New Member

    Registriert seit:
    17. Mai 2017
    Beiträge:
    2
    Zustimmungen:
    0
    Hallo Persephone

    Ich habe das Problem umgegangen, indem ich die Anhangsseiten der Fotos einfach per 301-Redirect auf den eigentlich Artikel weiterleiten lassen. Löst das dein Problem?
     
  3. Persephone

    Persephone Well-Known Member

    Registriert seit:
    21. Februar 2016
    Beiträge:
    249
    Zustimmungen:
    1
    Hallo Kristof,
    danke für deine Antwort. Wie lange hast du denn dafür gebraucht und macht das viele Umleiten von den vielen Bilder nicht unsäglich langsam?
     
  4. Persephone

    Persephone Well-Known Member

    Registriert seit:
    21. Februar 2016
    Beiträge:
    249
    Zustimmungen:
    1
    Sonst echt keiner ne Idee? Wer nutzt denn überhaupt von euch Seo Yoast?

    Danke
     
  5. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    6.371
    Zustimmungen:
    572
    Hast Du die Medien-Seiten in der Sitemap aufgeführt? Dann wird Google sie auch erfassen. URL zur Sitemap?
     
  6. Persephone

    Persephone Well-Known Member

    Registriert seit:
    21. Februar 2016
    Beiträge:
    249
    Zustimmungen:
    1
    Danke für deine Antwort.
    Die Bilder ranken mit eigenem Permalink, das war schon vor der Erstellung der Sitemape so. Ich habe die Sitemape noch nicht so lange, vor ca. 5 Wochen erst erstellt.
     
  7. FloRet

    FloRet Well-Known Member

    Registriert seit:
    20. September 2016
    Beiträge:
    1.194
    Zustimmungen:
    90
    Hallo,

    gut rankende Bilder (inkl. Permalink) , sind per se keine schlechte Grundlage für SEO und auch der Traffic-Flut auf Deine Seite.

    Wieso und weshalb, Google Deine Bilder "schneller" als die Artikel indexiert kann Dir nur Google mitteilen. Hierzu hat keine SEO-Agentur, oder Person welche sich mit SEO beschäftigt Zugang. Wieso möchtest Du die Bilder deindexieren? Bilder verschaffen unter anderem auch einiges an Traffic auf Deine Seite.
    Es hängt hier sehr an der Qualität der Beiträge bzw. Themen an, ob und wie Google Deine Seite einstuft und indexieren wird. Es ist ein Irrglaube, dass ein SEO-Plugin eine garantierte TOP-Platzierung erzielen lässt. Ich habe schon erlebt, dass Firmen-Logos höher ranken als die Seite tatsächlich. Hier heißt es ruhig Blut bewahren.

    Weiterleitungen, sind standardmäßig auch nicht lähmend für Deine Seite. Sicherlich ist eine Weiterleitung eine kleine Bremse, aber max. 200ms sollten reichen, damit die Weiterleitung greift und der Besucher auf die zielführende Seite weitergeleitet wird. Hier hängt es sehr vom Hoster bzw. Von der Optimierung eines Root-Servers ab! Bei welchen Hoster bist Du?

    Wieso macht Autoptimize Probleme?

    LG
     
  8. Persephone

    Persephone Well-Known Member

    Registriert seit:
    21. Februar 2016
    Beiträge:
    249
    Zustimmungen:
    1
    Danke für deine Antwort.
    Wenn mir jemand sagt und zeigt, dass das so seine Richtigkeit hat, dann bin ich schon zufrieden. Ich glaube nicht daran, dass durch das Plugin Topplätze errungen werden sondern, dass es etwas mit den Bildern zu tun hat. Google nimmt alle möglichen Bezeichnungen für ein Bild; Mal ist es der Upload Title, mal die Beschreibung, dann wieder das Altattribut. Dazu werden die deaktivierten b.z.w. gelöschten Tags (Einstellung Seo Yoast) von Google mit 404 Seiten (Nicht gefunden) quittiert. Bezüglich Autoptimizie, macht immer noch ein CSS (autoptimize/content/cache/php) Probleme. Da habe ich auch schon verschiedenes ausprobiert, hat aber alles keine Lösung gebracht, eher im Gegenteil.
     
  9. Persephone

    Persephone Well-Known Member

    Registriert seit:
    21. Februar 2016
    Beiträge:
    249
    Zustimmungen:
    1
    Es gibt den Punkt Artikeltypen zwei Mal in den Einstellungen.
    Einmal unter:
    Titel & Metas - Yoast SEO
    dort habe ich die Medien auf Index gesetzt.
    Das andere Mal unter
    XML-Sitemaps - Yoast SEO
    Medien (attachment)
    die habe ich jetzt auf:
    Nicht in der Sitemap gesetzt.

    Ob das die Lösung ist, liebe Leser, werden wir sehen.
     
  10. Persephone

    Persephone Well-Known Member

    Registriert seit:
    21. Februar 2016
    Beiträge:
    249
    Zustimmungen:
    1
    Die zuletzt beschriebene Einstellungsänderung brachte leider nicht das gewünschte Ergebnis, also habe ich weiter gesucht.
    Mittlerweile habe ich endlich die Lösung gefunden, der Fehler besteht nun nicht mehr.
    Da ich wohl als einzige das Problem hatte oder sich keiner dafür interessiert, spare ich mir den Rest.
     
  11. TKalwass

    TKalwass Member

    Registriert seit:
    10. April 2017
    Beiträge:
    16
    Zustimmungen:
    0
    Nur so:
    - Ja (jede Menge) 301er können sich negativ auf die Performance auswirken.
    - 'Ne Sitemap ist für Seiten unter 10.000 Seiten vollkommen unnötig, siehe auch: https://www.youtube.com/watch?v=NW3vxnlu3QQ. Mehr Selbstbeschäftigung als echte Verbesserung. Also nicht davon stressen lassen.
     
  12. Persephone

    Persephone Well-Known Member

    Registriert seit:
    21. Februar 2016
    Beiträge:
    249
    Zustimmungen:
    1
    Danke, die Sitemaps macht mir keinen Stress. ;)
    Was die 301 redirect betrifft, sagen die einen so und die anderen so, genaues weiß man nicht. :roll:
     
    #12 Persephone, 22. Juni 2017
    Zuletzt bearbeitet: 22. Juni 2017
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden