1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

smilies...

Dieses Thema im Forum "Allgemeines" wurde erstellt von spacefrog, 26. Mai 2005.

  1. spacefrog

    spacefrog Well-Known Member

    Registriert seit:
    10. Mai 2005
    Beiträge:
    228
    Zustimmungen:
    0
    hallo.
    da ich neue smilies verwenden wollte, und ich nicht einfach die bilddateien überschreiben konnte, weil es mehr sind als die alten, und teilweise andere entsprechungen haben, usw., habe ich mich mal an die vars.php gemacht.
    hier mal der geänderte code:

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    leider funktioniert das so nicht.
    was ist daran falsch?
    danke schonmal,
    spacefrog
     
  2. peti

    peti Well-Known Member

    Registriert seit:
    26. März 2005
    Beiträge:
    1.550
    Zustimmungen:
    0
    Groß- und Kleinschreibung beachtet?
    Sind sie im richtigen Verzeichnis? (/wp-images/smilies/ - sofern nicht geändert)
    Häckchen bei Options -> Schreiben gesetzt, dass WordPress Smilies konvertieren soll?

    Hab das einfach mal probiert. Den Dateinamen in der vars.php geändert, das Smilie im o.g. Ordner hochgeladen und probiert. Ging mit allen gängigen Bildformaten. Letztendlich hats dann bei der Groß- und Kleinschreibung nicht funktionieren wollen.
     
  3. spacefrog

    spacefrog Well-Known Member

    Registriert seit:
    10. Mai 2005
    Beiträge:
    228
    Zustimmungen:
    0
    ja, gross-und kleinschreibung müsste stimmen, auch wenn ich nicht wirklich drauf geachtet hatte, da ich dachte das wäre egal. ich schau nochmal nach. einstellungen müssten stimmen, da mit den standard-smilies alles geht. kann man der vars.php überhaupt noch weitere smilie-codes hinzufügen? sollte ja eigentlich kein problem sein, oder?

    spacefrog
     
  4. peti

    peti Well-Known Member

    Registriert seit:
    26. März 2005
    Beiträge:
    1.550
    Zustimmungen:
    0
    Das Hinzufügen dürfte gehen.
    Habe zum Spaß die Zeile hinzugefügt und es zeigte mir meinen tollen Test-Smilie.

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
     
  5. spacefrog

    spacefrog Well-Known Member

    Registriert seit:
    10. Mai 2005
    Beiträge:
    228
    Zustimmungen:
    0
    hab's nochmal probiert.
    alles klein geschrieben --> smilies auch klein geschrieben...nix geht. bekomme im admin panel dazu auch noch folgende meldung:

    Parse error: parse error, expecting `')'' in /home/w/webspace-sharing.de/public_html/trojansky/wp-includes/vars.php on line 114

    Warning: Cannot modify header information - headers already sent by (output started at /home/w/webspace-sharing.de/public_html/trojansky/wp-includes/vars.php:114) in /home/w/webspace-sharing.de/public_html/trojansky/wp-admin/admin.php on line 10

    Warning: Cannot modify header information - headers already sent by (output started at /home/w/webspace-sharing.de/public_html/trojansky/wp-includes/vars.php:114) in /home/w/webspace-sharing.de/public_html/trojansky/wp-admin/admin.php on line 11

    Warning: Cannot modify header information - headers already sent by (output started at /home/w/webspace-sharing.de/public_html/trojansky/wp-includes/vars.php:114) in /home/w/webspace-sharing.de/public_html/trojansky/wp-admin/admin.php on line 12

    Warning: Cannot modify header information - headers already sent by (output started at /home/w/webspace-sharing.de/public_html/trojansky/wp-includes/vars.php:114) in /home/w/webspace-sharing.de/public_html/trojansky/wp-admin/admin.php on line 13
     
  6. peti

    peti Well-Known Member

    Registriert seit:
    26. März 2005
    Beiträge:
    1.550
    Zustimmungen:
    0
    Was steht denn in Zeile 114?
     
  7. spacefrog

    spacefrog Well-Known Member

    Registriert seit:
    10. Mai 2005
    Beiträge:
    228
    Zustimmungen:
    0
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
     
  8. spacefrog

    spacefrog Well-Known Member

    Registriert seit:
    10. Mai 2005
    Beiträge:
    228
    Zustimmungen:
    0
    hm, wenn ich diese zeilen auskommentiere klappts:

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    warum hat er damit probleme???
     
  9. peti

    peti Well-Known Member

    Registriert seit:
    26. März 2005
    Beiträge:
    1.550
    Zustimmungen:
    0
    Vielleicht liegt das an dem Slash. Lass die zur Not einfach raus.
     
  10. spacefrog

    spacefrog Well-Known Member

    Registriert seit:
    10. Mai 2005
    Beiträge:
    228
    Zustimmungen:
    0
    ok, hab den code jetzt so gesetzt, dass dieser smilie durch :maybe: angezeigt wird...danke für deine hilfe, wäre gar nicht auf die idee gekommen mal in zeile 114 nachzuschauen :) .

    spacefrog
     
  11. ratterobert

    ratterobert Well-Known Member
    Ehrenmitglied

    Registriert seit:
    1. Januar 2005
    Beiträge:
    1.237
    Zustimmungen:
    0
    hast du die slashes mal escaped?

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
     
  12. spacefrog

    spacefrog Well-Known Member

    Registriert seit:
    10. Mai 2005
    Beiträge:
    228
    Zustimmungen:
    0
    was heisst escaped?
    aber es kappt ja jetzt...

    spacefrog
     
  13. ratterobert

    ratterobert Well-Known Member
    Ehrenmitglied

    Registriert seit:
    1. Januar 2005
    Beiträge:
    1.237
    Zustimmungen:
    0
    so wie ich es nochmal geschrieben hab (den code). vor jedem sonderzeichen ein backslash.
     
  14. peti

    peti Well-Known Member

    Registriert seit:
    26. März 2005
    Beiträge:
    1.550
    Zustimmungen:
    0
    Ah. *bing* Auch ne Möglichkeit, genau.
     
  15. spacefrog

    spacefrog Well-Known Member

    Registriert seit:
    10. Mai 2005
    Beiträge:
    228
    Zustimmungen:
    0
    ok, danke für den tipp, es klappt!
    ist natürlich noch besser :)

    edit: ich merke grade dass es doch nicht klappt...jetzt kommt zwar keine fehlermeldung, aber die smilies
    :confused:
    :/
    :-\
    :\

    funktionieren trotzdem nicht...
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden