1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

SMTP macht Ärger

Dieses Thema im Forum "Plugins und Widgets" wurde erstellt von heinetz, 27. September 2016.

  1. heinetz

    heinetz Well-Known Member

    Registriert seit:
    8. Oktober 2007
    Beiträge:
    75
    Zustimmungen:
    0
    Hallo Forum,

    ich habe gerade ein WP-Projekt für einen Kunden realisiert. Nun stellt sich heraus, dass mein Kunde die
    von der Website über Formulare (Contact Form 7) verschickten Mails nicht erhält. Wenn ich als Empfänger
    meine eigene Email-Adresse eintrage funktioniert alles reibungslos.

    Deshalb ging ich davon aus, dass der Mailserver eines Kunden die Mail ablehnt. Deshalb war meine Idee,
    die Mails per SMTP zu verschicken und ich habe mir das entsprechende Plugin WP Mail SMTP installiert.
    Dann habe ich auf meinem VServer ein neues Email-Konto angelegt, dass ich nur für diesen Zweck nutzen
    wollte. Dieses Email-Konto habe ich in meinem Mail-Client eingerichtet und es funktioniert. Dann habe ich
    die Einstellungen aus meinem Email-Client für das Konto in die Settings von WP Mail SMTP übernommen
    und siehe da, auch das funktioniert. Die Testmail wird über meinen SMTP-Server verschickt. Das funktioniert
    in meiner Installation der Website auf meinem localhost, es funktioniert auf meinem Testserver bei Hosteurope
    aber auf dem Server meines Kunden bei all-inkl nicht ;(

    Konkret äussert sich das so, dass mit dem Absenden der Testmail, die Antwortseite läd und läd und läd und ….
    … statt einen Fehler auszugeben.

    Ich frage mich, was da wohl im Weg ist. Naheliegend finde ich, dass es mein SMTP-Server ist, der die Verbindung
    nicht zulässt, aber ich habe keine Idee warum.


    Ich hoffe, das ist kein aussergewöhnliches Problem!

    gruss,.
    heinetz
     
  2. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.965
    Zustimmungen:
    8
    Poste mal den entsprechenden Eintrag in der mail.log bzw mail.err
     
  3. heinetz

    heinetz Well-Known Member

    Registriert seit:
    8. Oktober 2007
    Beiträge:
    75
    Zustimmungen:
    0
    Wo finde ich die?
     
  4. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.965
    Zustimmungen:
    8
    Das sollte ein Server Admin aber wissen ;). Je nach Distribution schau mal unter /var/log
     
  5. heinetz

    heinetz Well-Known Member

    Registriert seit:
    8. Oktober 2007
    Beiträge:
    75
    Zustimmungen:
    0
    Ich bin ja garkein richtiger Server-Admin ;)

    Ich hatte vorhin schonmal in /usr/local/psa/var/log/maillog geschaut und dort nach der Email-Adresse
    gesucht mit:

    grep swisscomply@digitale.mehrwerte.net /usr/local/psa/var/log/maillog


    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Da finde ich nur die zwei erfolgreich versandten Mails.Einmal die von meinem lokalen System und einmal die von meinem Testserver.


    Allerdings …

    … habe ich jetzt offenbar genug Geduld gehabt, gewartet und es wird doch ein Fehler ausgegeben:

    … das muss ich jetzt mal in Ruhe lesen ...


    gruss,
    heinetz
     
  6. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.965
    Zustimmungen:
    8
    Dann solltest du auch keine VServer administrieren ;)

    Das Problem liegt hier

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Was hast denn als SMTP-Server angegeben?
     
  7. heinetz

    heinetz Well-Known Member

    Registriert seit:
    8. Oktober 2007
    Beiträge:
    75
    Zustimmungen:
    0
    Will ich ja auch garnicht ;)

    Steht da doch:

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!

    … Port 25, keine Verschlüsselung und Authetifizierung, das Passwort habe ich durch XXXXX ersetzt. ;)

    Was ich daran eigenartig finde, ist das die Connection zu meinem SMTP-Server nicht nur von meinem
    lokalen Email-Client, sondern auch von der selben WP-Installation auf zwei unterschiedlichen Servern
    funktioniert. Es muss also an dem Server liegen, auf dem WP installiert ist, dass die Connection nicht
    zustande kommt, oder ?

    gruss,
    heinetz
     
  8. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.965
    Zustimmungen:
    8
    Also erst mal erfolgt über Port 25 keine SMTP Authentifizierung. Wenn dann über Port 587 bzw per SMTPS 465. Ich habe mal ein Port Scan auf diese Port gemacht

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Alle Ports sind geschlossen. Wie soll da ein Mailversand stattfinden? Nur zur Info, die Domain mehrwerte.net läuft auf 87.230.85.137 ;)
     
    #8 Hille, 27. September 2016
    Zuletzt bearbeitet: 27. September 2016
  9. mensmaximus

    mensmaximus Well-Known Member

    Registriert seit:
    24. Juli 2014
    Beiträge:
    8.813
    Zustimmungen:
    423
    Bitte einmal ins KAS bei All Inkl. schaun, da stehen die richtigen Daten drin. Niemals eine IP als Host angeben, das geht mächtig daneben, wenn der Provider am DNS schraubt.
     
  10. heinetz

    heinetz Well-Known Member

    Registriert seit:
    8. Oktober 2007
    Beiträge:
    75
    Zustimmungen:
    0
    Der SMTP ist ja garnicht bei All Inkl sondern auf meine Server bei Hosteurope.
     
  11. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.965
    Zustimmungen:
    8
    also doch Admin :|. Du hast den Fehler aber erkannt?
     
  12. mensmaximus

    mensmaximus Well-Known Member

    Registriert seit:
    24. Juli 2014
    Beiträge:
    8.813
    Zustimmungen:
    423
    Und warum nimmst Du nicht den SMTP Server bei All Inkl, wenn doch der Kunde bei All Inkl liegt? Das ist die saubere Lösung.
     
  13. heinetz

    heinetz Well-Known Member

    Registriert seit:
    8. Oktober 2007
    Beiträge:
    75
    Zustimmungen:
    0


    Ja, das mit der falschen IP ist mir bewusst. Das hat folgenden Hintergrund:

    Bei meinem ersten Versuch, die Testmail über das Plugin zu versenden, kam ja garkeine (Fehler-)Ausgabe. Daraufhin habe ich die IP verändert, um zu sehen, ob dann was kommt aber auch da gab's ja erstmal keine Ausgabe. Irgendwann kam die Ausgabe und die habe ich hier gepostet. Danach ist mir aufgefallen, dass ja noch die falsche IP drin steht. Die habe ich dann geändert aber die Mail wurde ja von vornherein, also auch schon mit der richtigen IP nicht versandt. Ich habe die beiden Ausgaben mit DIFF verglichen und da sie sich wirklich nicht, ausser eben durch die IP und die Zeit, unterschieden, habe ich das mal für mich behalten. Jetzt hast du die Ports von der falschen IP gescannt. Das war umsonst und das tut mir auch echt leid!

    Trotzdem stellt sich mir die Frage, wieso ein Mailversand auf einem anderen Server mit den selben Einstellungen läuft. Die Ausgabe musste ich anhängen, weil das Posting sonst zu lang geworden wäre.

    gruss,
    heinetz
     

    Anhänge:

  14. heinetz

    heinetz Well-Known Member

    Registriert seit:
    8. Oktober 2007
    Beiträge:
    75
    Zustimmungen:
    0
    Ich hatte mir ja zuerst mal garkeine Gedanken gemacht und die Mails aus dem Contact Form 7 wurden von php:mail() verschickt. ich hatte eine Email-Adresse in FROM eingetragen, die es bis zu dem Zeitpunkt garnicht gab: noreply@kunde.org und die Mails erstmal an meine Email-Adresse geschickt. Das funktionierte alles und ich habe den Empfänger dann gegen die Email-Adresse meines Kunden ausgetauscht. Dort, also bei info@kunde.de, kamen sie dann aber nicht mehr an.
    Daraufhin habe ich gedacht, es ist sicher besser, die Mails per SMTP zu verschicken zumal ich das mehrfach gelesen hatte. Daraufhin das SMTP-Plugin in WP installiert, die Zugangsdaten, die ich in meinem OS X Mail verwende dort eingeben und ausprobiert. Das funktionierte … in meiner Installation auf localhost, in meiner Installation auf meinem Testserver bei Hosteurope aber eben nicht auf dem Kundenserver bei All Inkl. Den SMTP-Server bei All Inkl habe ich deshalb nicht benutzt, weil der Kunde seinen Mailserver garnicht bei All Inkl hat, sondern nur die Website. Dass ich im Moment meinen SMTP-Server dort eingetragen habe, liegt nur daran, dass der Kunde die Email-Adresse noreply@kunde.org erst noch einrichten und mir Zugangsdaten zu seinem SMTP-Server mitteilen muss. Der wird aber auch nicht bei All Inkl sein.

    Ich weiss nun auch bald nicht mehr, was das sinnvollste ist aber ich habe das mit dem Versand über den SMTP-Server so verstanden:

    Wenn ich mit meinem lokalen Mail-Client Mails verschicke, werden die von einem entfernten SMPT-Server versandt. Eben dem, den ich in meinem
    Mail-Client hinterlegt habe. Wenn ich auf dem Webserver die selben Zugangsdaten hinterlege, werden die Mails nicht mehr vom Webserver selbst,
    sondern von dem hinterlegten SMTP-Server versandt. Und so spielt es keine Rolle, ob sich nun der Mail Client auf meinem Laptop oder der Webserver
    mit dem SMTP-Server verbindet.

    gruss,
    heinetz
     
  15. heinetz

    heinetz Well-Known Member

    Registriert seit:
    8. Oktober 2007
    Beiträge:
    75
    Zustimmungen:
    0
    Nein, was ist der Fehler?
     
  16. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.965
    Zustimmungen:
    8
    Du versuchst über Port 25 zu versenden. Jetzt trägst du mal folgendes ein

    Host: lvps87-230-85-137.dedicated.hosteurope.de
    Port: 465

    Benutzername und Passwort sind dir ja bekannt. Sollte das nicht funktionieren, kann ich mir das Problem gerne auch selber mal anschauen.
     
  17. heinetz

    heinetz Well-Known Member

    Registriert seit:
    8. Oktober 2007
    Beiträge:
    75
    Zustimmungen:
    0
    Was von localhost und lvps87-230-85-137.dedicated.hosteurope.de problemlos funktioniert.

    Gerne, die Fehlermeldung (anbei) ist etwas umfangreicher.
     

    Anhänge:

  18. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.965
    Zustimmungen:
    8
    Kann es sein, das dein Mailserver noch gar nicht konfiguriert wurde?? Über Port 465 ist nicht möglich

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Auf Port 587 lauscht dein Mailserver nicht. Was nun ;)?
     
  19. heinetz

    heinetz Well-Known Member

    Registriert seit:
    8. Oktober 2007
    Beiträge:
    75
    Zustimmungen:
    0
    Nochmal: Die Verbindung zu meinem SMTP-Server unter 87.230.85.137 resp. lvps87-230-85-137.dedicated.hosteurope.de und der Versand von Mails funktioniert von localhost und von meinem Testserver swisscomply.ch.digitale.mehrwerte.net aus mit den Plugin-Settings entspr. Anhang.

    Da WP den PHPMailer nutzt, um Mails zu verschicken, habe ich den mal unabhängig von WP auf alle 3 Server geladen um zu damit zu testen. Der PHPMailer enthält einige Beispiele. Unter Anderem smtp.phps. Die habe ich dupliziert und in dem Duplikat (nur) folgende Zeilen angepasst:

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Die liegt jetzt hier:
    http://test.digitale.mehrwerte.net/_php/PHPMailer/examples/my_001_example.smtp.php

    … und verschickt beim Aufruf eine Mail über den SMTP-Server an mich. Die selbe Datei
    funktioniert a.d. Kundenserver nicht mehr.


    Da das mit den Settings überall funktioniert ausser a.d. Server bei All Inkl gehe ich mittlerweile
    davon aus, dass All Inkl die Verbindung blockt, wie hier beschrieben.

    gruss,
    heinetz
     

    Anhänge:

  20. mensmaximus

    mensmaximus Well-Known Member

    Registriert seit:
    24. Juli 2014
    Beiträge:
    8.813
    Zustimmungen:
    423
    Und wenn Du meinem Rat bzw. meiner Frage gefolgt wärst, den All Inkl Mailserver zu verwenden, hättest Du Dir viel Zeit gespart.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden