1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Sonderzeichenchaos nach Datenbankimport

Dieses Thema im Forum "Konfiguration" wurde erstellt von dirk nolte, 11. Oktober 2006.

  1. dirk nolte

    dirk nolte Member

    Registriert seit:
    11. April 2006
    Beiträge:
    7
    Zustimmungen:
    0
    Hallo zusammen,

    nach dem Import meines italienischen Wordpress-Blogs auf einen deutschen Server krieg ich es einfach nicht hin, dass die italienischen Sonderzeichen korrekt dargestellt werden.

    Habe so einiges versucht, und vor dem Export des Originalblogs unter Operations/Collations diverse Einstellungen ausprobiert, doch statt der Sonderzeichen sehe ich weiterhin ein ziemliches durcheinander.

    Kann jemand weiterhelfen?

    Danke, Güße aus Rom
    Dirk Nolte
    http://www.2loud.eu
     
  2. StephanZ

    StephanZ Well-Known Member

    Registriert seit:
    6. September 2006
    Beiträge:
    186
    Zustimmungen:
    0
    Vielleicht den Zechensatz der Datenbank als solches umstellen, vermutlich auf den alten italenischen oder auf den des momentanen Blogs.

    GS
     
  3. mastermind

    mastermind Well-Known Member

    Registriert seit:
    13. Dezember 2005
    Beiträge:
    2.076
    Zustimmungen:
    0
    Wenn Du den Import über einen MySQL-Dump geführt hast, könnte es an den Zeichensätzen in der Datenbank liegen.

    Welchen Zeichensatz hat der ursprüngliche Blog? Welchen Zeichensatz nutzt der MySQL-Server auf Deinem Host standardmäßig?
     
  4. dirk nolte

    dirk nolte Member

    Registriert seit:
    11. April 2006
    Beiträge:
    7
    Zustimmungen:
    0
    Danke für die schnellen Antworten,

    während ich auf dem italienischen Server zahlreiche Gelegenheiten finde, den Zeichsatz des Ursprungsblogs einzustellen (phpMyAdmin 2.6.2-Debian-3sarge1 ___ MySQL 4.1.11-Debian_4sarge7) finde ich auf dem Zielserver (phpMyAdmin - 2.8.0.2 ___ MySQL client version: 5.0.18.) auch nach 1 Std. Klickerei nichts vergleichbares, womit ich experimentieren könnte. Hat da auch noch jemand einen Tip? Ich bin - wie man sieht - nur sehr oberflächlich vertraut mit den Zusammenhängen.

    Danke
    Dirk Nolte
    http://www.2loud.eu/
     
  5. mastermind

    mastermind Well-Known Member

    Registriert seit:
    13. Dezember 2005
    Beiträge:
    2.076
    Zustimmungen:
    0
    Hast Du geschaut, ob die Einstellungen unter Options -> Reading identisch sind?

    Ansonsten muss ich sagen, es ist schwierig, bei Datenbankproblemen über eine Forumsdiskussion zu helfen. Vielleicht könntest Du Dich an Deinen Hoster wenden, wenn es um Zeichensatzprobleme mit der DB geht?
     
  6. jowra

    jowra Well-Known Member

    Registriert seit:
    25. Februar 2005
    Beiträge:
    684
    Zustimmungen:
    0
    Schnapp Dir mal Deine Theme-Dateien, öffne sie jeweils in einem Text-Editor der im UTF-8-Format speichern kann (unter Windows XP z.B. Notepad) und sichere die Dateien in UTF-8 Kodierung (kannst Du im "Speichern unter..." Dialog ganz unten einstellen.).

    Dann wieder uploaden die Teile.

    Für den Anfang kannst Du es ja erst mal nur mit der index.php testen.
     
    #6 jowra, 11. Oktober 2006
    Zuletzt bearbeitet: 11. Oktober 2006
  7. dirk nolte

    dirk nolte Member

    Registriert seit:
    11. April 2006
    Beiträge:
    7
    Zustimmungen:
    0
    Vielen Dank, Optinons/Reading-Einstellungen stimmen überein und auch das abspeichern der einzelnen Theme-Dateien als UTF-8 hat leider nicht weitergeholfen, sieht also so aus, als müsste ich die Artikel von Hand korrigieren.

    Falls ich doch noch eine Lösung finde, fass ich hier zusammen.

    Grüße
    Dirk Nolte
    http://www.2loud.eu/
     
  8. dirk nolte

    dirk nolte Member

    Registriert seit:
    11. April 2006
    Beiträge:
    7
    Zustimmungen:
    0
    Problem gelöst

    Die Lösung war am Ende ziemlich einfach:

    Die Datenbank musste in die MySQL-Version 4 konvertiert werden.
    In dieser Version kann man, im Gegensatz zu Version 3, den Zeichensatz
    der Datenbank ändern.

    Danke für die Antworten

    Dirk Nolte
    http://www.2loud.eu/
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden