1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Sortierreihenfolge der Beiträge plötzlich vertauscht

Dieses Thema im Forum "Konfiguration" wurde erstellt von fritz, 9. Januar 2008.

  1. fritz

    fritz New Member

    Registriert seit:
    9. Januar 2008
    Beiträge:
    3
    Zustimmungen:
    0
    Hallo,

    habe seite 1 1/2 Jahre ein WP Blog (Version 2.0.4 ) am Start, gehostet by 1&1 -> Interview Blog

    Läuft alles geschmiert, bis gestern : Ohne Änderungen am Softwarestand seit vielen Monaten hat sich auf einmal die Sortierreihenfolge der Beiträge umgedreht. In der Listenansicht stehen stets die ältesten Beiträge ganz oben (in Kategorien und auch ohne Kategorieeinschränkung).

    Kann mir jemand auf die Sprünge helfen was passiert sein könnte und wie ich das ganze wieder in die gewünschte chronologisch absteigende Sortierung kriege?

    Fritz
     
  2. Syntronica

    Syntronica Well-Known Member

    Registriert seit:
    11. März 2006
    Beiträge:
    1.051
    Zustimmungen:
    0
    2.0.4. ? Du bist wirklich mutig! :mrgreen:
     
  3. fritz

    fritz New Member

    Registriert seit:
    9. Januar 2008
    Beiträge:
    3
    Zustimmungen:
    0
    Ja, zuviele projektspezifische Änderungen in 2006 als das ich noch updatefähig bin :oops: .
     
  4. fressnet

    fressnet Active Member

    Registriert seit:
    6. Dezember 2006
    Beiträge:
    38
    Zustimmungen:
    0
    Sortierreihenfolge

    Die Lösung für Fritz' Problem soll wohl ein Update sein?
    Ich gestehe, seit eben das gleiche Problem zu haben, auchmit einer alten Version.
     
  5. welfenpoker

    welfenpoker New Member

    Registriert seit:
    10. Januar 2008
    Beiträge:
    1
    Zustimmungen:
    0
    habe das gleiche problem...

    seit heute morgen ist die sortierung der beiträge falsch... :confused:
    obwohl in den optionen steht, dass die aktuellsten 10 einträge angezeigt werden sollen...
    Hinweis: Hosted by strato

    Danke für evtl. Hilfe!

    Gruß
    Axel
     
  6. Ammaletu

    Ammaletu Well-Known Member
    Ehrenmitglied

    Registriert seit:
    14. Juli 2007
    Beiträge:
    4.694
    Zustimmungen:
    0
    Probleme wie dieses wurden in den Wochen vor Weihnachten mehrmals berichtet, leider ohne eine Lösung soweit ich mich erinnere. Das ist schon komisch, würde mich wirklich interessieren, woran das liegt...
     
  7. fritz

    fritz New Member

    Registriert seit:
    9. Januar 2008
    Beiträge:
    3
    Zustimmungen:
    0
    Order by ... DESC vs Order by ... ASC

    Auch der Versuch die Reihenfolge durch manuelles Übersteuern des entsprechenden SQL-Statements zu verändern, macht keinen Unterschied . Absteigende und aufsteigende Sortierung der der Ergebnisse zeigt keine Auswirkung . Bin echt ratlos.

    Die Ansicht ist nicht mehr ganz so übel, wenn man in den WP-Einstellungen einstellt auf "die letzten X Tage anzeigen", dann sind jeweils nur innerhalb einer Ergebnisseite die Beiträge vertauscht.

    Ist also keine Lösung, sondern schadensbegrenzung.

    Möglicherweise hats beim Hoster eine Änderung an der MySQL-Datenbank gegeben? Das würde erklären warum anscheinend nicht alle Blogs mit entsprechend alten Versionen betroffen sind.

    Gruß,
    Friedrich
     
  8. menhir

    menhir Well-Known Member

    Registriert seit:
    5. Januar 2008
    Beiträge:
    49
    Zustimmungen:
    0
    ...auch in der neuesten Version!

    Seit wenigen Tagen läuft meine Seite mit V 2.3.2. Bis heute Morgen waren die Menus der statischen Seiten ok. Nun sind sie auch plötzlich in anderer Reihenfolge. Trotz sauberer Nummerierung! :confused:

    Die Hauptmenus sind alphabetisch!!!
     
    #8 menhir, 10. Januar 2008
    Zuletzt bearbeitet: 10. Januar 2008
  9. computeritis

    computeritis Well-Known Member

    Registriert seit:
    22. Juni 2007
    Beiträge:
    60
    Zustimmungen:
    0
    Habe das Problem auch mit einem Strato-Blog.

    Hat schon jmd. eine Lösung?
     
  10. menhir

    menhir Well-Known Member

    Registriert seit:
    5. Januar 2008
    Beiträge:
    49
    Zustimmungen:
    0
    ...jetzt wirds interessant!

    Habe die genau gleiche Website mit den gleichen Menus bei zwei verschiedenen Hostern installiert.

    Fazit:
    Im einen Fall korrekte Darstellung wie programmiert,
    im andern Fall alphabetische Darstellung der Menus.

    Bin grad mit dem Hoster am Abklären, woran das liegen könnte.

    Hoffentlich bis bald...
     
  11. computeritis

    computeritis Well-Known Member

    Registriert seit:
    22. Juni 2007
    Beiträge:
    60
    Zustimmungen:
    0
    Dann halt uns auf den Laufenden.
     
  12. Doc

    Doc Well-Known Member

    Registriert seit:
    27. Juni 2007
    Beiträge:
    251
    Zustimmungen:
    0
    Ich habe das gleiche Problem seit gestern.

    Strato hat bereits eine Anfrage von mir erhalten:

    Mal sehen, was die dazu sagen.
     
  13. SPONDUUN.TV

    SPONDUUN.TV Active Member

    Registriert seit:
    16. November 2006
    Beiträge:
    42
    Zustimmungen:
    0
    Gleiches Problem bei mir

    Wollte mich hier nur mal anmelden, weil´s vielleicht bei den Hostern ernster genommen wird, je mehr sich hier melden

    Bin ja mal gespannt

    Update hab ich noch nicht gemacht, weil ja nur ein User sagte, dass das was gebracht habe
     
  14. Kurbjuhn

    Kurbjuhn Member

    Registriert seit:
    19. September 2006
    Beiträge:
    6
    Zustimmungen:
    0
    Bei mir trat das Problem gestern ebenfalls auf. Morgens früh war noch alles in Ordnung, gegen 11 Uhr vormittags war dann die Sortierreihenfolge vertauscht. Bin ebenfalls bei Strato, ein Telefonat mit der Hotline brachte keinen Erkenntnisgewinn. Habe dann upgedatet, das hat das Problem gelöst.
    Gruß
    Chris
     
  15. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.955
    Zustimmungen:
    47
    Es scheint etwas mit dem Update der MySQL-Version auf 5.0.51 zu tun zu haben. Hier wird offensichlich das "ORDER BY" vom "GROUP BY" überstimmt, was sie Sortierung anbelangt. Diese ist dann aufsteigend nach ID. Eine normale Abfrage für die Homepage sieht z.B. bei WP 2.0.x etwa so aus:
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Das "GROUP BY wp20_posts.ID" ist eigentlich sinnfrei, da die ID eindeutig ist und es somit nichts zu gruppieren gibt, sie wird aber verwendet, um das Zusammensetzen der SQL-Abfrage zu vereinfachen. Bei neueren WP-Version gibt es das nicht mehr, hier wird nur ein "GROUP BY" eingefügt, wenn es wirklich benötigt wird.
    Das erklärt auch, warum es bei manchen ausreichte, auf die neuste WP-Version upzudaten.

    Bei MySQL vor Version 5.0.51 war es noch so, das "ORDER BY" Vorrang hatte, so das mit älteren DB-Versionen das Problem auch nicht auftritt.

    Was man da auf die Schnelle machen kann, weiß ich auch nicht. Ich gehe jetzt schlafen, gute Nacht :)

    Nachtrag: Man könnte sich mit add_filter( 'posts_groupby', ... ) einklinken und falls hier ID steht, stattdessen POST_DATE zurückgeben. Dann stimmt es wieder.
    Nachtrag 2: Es dürfte mit diesem Bug zu tun haben, der laut Release-Infos ab 5.0.51 beseitigt wurde.

    Gruß
    Ingo
     
    #15 Putzlowitsch, 11. Januar 2008
    Zuletzt bearbeitet: 12. Januar 2008
  16. Landscaper

    Landscaper New Member

    Registriert seit:
    12. Januar 2008
    Beiträge:
    4
    Zustimmungen:
    0
    ...da bin ich aber froh, das ich nicht der Einzige bin. Auch bei geht es seit heute andersrum. Ich verwende WP 2.0 und bin mit meiner Domain bei Strato. Hoffentlich kennt einer eine Lösung ohne Update; ich darf gar nicht daran denken was da alles schief gehen kann.

    Gruß Carsten
     
  17. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.955
    Zustimmungen:
    47
    #17 Putzlowitsch, 12. Januar 2008
    Zuletzt bearbeitet: 14. Januar 2008
  18. Landscaper

    Landscaper New Member

    Registriert seit:
    12. Januar 2008
    Beiträge:
    4
    Zustimmungen:
    0
    Hallo Ingo,

    Du bist mein Held ! :D
    Habe das Plugin bei mir installiert und es funktioniert.
    Nach einigen Tests scheint es keine "Nebenwirkungen" zu haben.

    Vielen Dank

    Carsten
     
  19. fressnet

    fressnet Active Member

    Registriert seit:
    6. Dezember 2006
    Beiträge:
    38
    Zustimmungen:
    0
    Hatte eben auch ein Gespräch mit der ahnungslosen Strato-Hotline.
    reverse sort post Wordpress sollte ich mal bei Google versuchen.

    Das Plugin von hier installiert sich bei mir nicht:
    Warning: Cannot modify header information - headers already sent by (output started at /mnt/web5/11/78/5160578/htdocs/blog/wp-content/plugins/123.php:1) in /mnt/web5/11/78/5160578/htdocs/blog/wp-admin/plugins.php on line 16

     
  20. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.955
    Zustimmungen:
    47
    Wichtig ist immer, das vor dem <?php und nach dem ?> keine Leerzeichen oder Leerzeilen stehen. Dann sollte es klappen.
    Habe oben das Plugin als Datei zum runterladen hinzugefügt.

    Gruß
    Ingo
     
    #20 Putzlowitsch, 12. Januar 2008
    Zuletzt bearbeitet: 12. Januar 2008
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden