1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

style.css des Child-Themes wird geladen aber nicht angewendet

Dieses Thema im Forum "Design" wurde erstellt von Achill, 20. Mai 2019.

Schlagworte:
  1. Achill

    Achill Well-Known Member

    Registriert seit:
    13. Februar 2016
    Beiträge:
    45
    Zustimmungen:
    0
    WP 5.2 Multisite

    Hallo!

    Das ist jetzt womöglich ein Spezialisten-Problem:
    Das Theme Twentyfifteen ist Netzwerkweit freigeschaltet. Ein Child-Theme dieses Themes ist für eine Website freigeschaltet. Alles funktioniert.
    Ein weiteres Twentyfifteen-Child-Theme ist für eine andere Website freigeschaltet. Hier funktioniert es nicht: Die style.css des Child-Themes wird zwar geladen, aber nicht angewendet. Ein Blick in den Seitenquelltext zeigt, dass die style.css des Child-Themes nach dem des Parent-Themes geladen wird. Diese Datei kann auch geöffnet werden.

    Auch das Entwicklertool unter Chrome zeigt in den "Sources" die Datei als geladen an und ich kann die CSS-Anweisungen lesen. Untersuche ich ein Element das eine Child-style.css-Anweisung aufwiesen muss, wird diese jedoch nicht angezeigt: es kommen nur die Anweisungen des Parent-Themes zur Anwendung.

    Das tritt sowohl unter Chrome als auch unter Firefox auf.

    Das Problem trat auf, nachdem ich das Plugin "Child-Theme-Configurator" wohl irgendwie falsch eingestellt hatte. Ich habe dort einen Reset versucht, ohne Erfolg. Dann habe ich dieses Plugin gelöscht. Ohne Erfolg. Schließlich habe ich das Theme Twentyfifteen sowie alle zugehörigen Child-Themes gelöscht, die Datenbank optimiert (dabei alle transienten Einträge gelöscht) und neu Installiert. Das Verhalten ändert sich nicht.

    Ich habe allerdings bemerkt, dass offenbar Customizer-Einstellungen weiterhin wirksam waren. Was mich zur Vermutung bringt, dass in der Datenbank noch irgendwo Theme-relevanten Daten stehen.

    Was ich nun zuallererst aber nicht verstehe: Die style.css des Child-Themes ist geladen, kommt aber nicht zur Anwendung. Woran kann das liegen?

    Zudem ist mir aufgefallen, dass der Name des Child-Themes "irgendwo" durch den Verzeichnisnamen des Child-Themes ergänzt wird, wenn in der Child-style.css bei "Theme Name" der gleiche Name steht wie im Parent Theme. Erstmalig ist mir das nach der Installation des Plugins "Child-Theme-Configurator" aufgefallen und das hat sich nach der deinstallation nicht geändert. Ich habe andere Child-Themes anderer Themes, da taucht das nicht auf – die wurden allerdings auch nicht mit dem Plugin bearbeitet.

    Danke für jede Hilfe, denn ich bin mit meinem Latein am Ende...
     
  2. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    5.736
    Zustimmungen:
    489
    Ohne Link zur Seite kann man schwer sagen, was da in welcher Reihenfolge geladen oder nicht geladen wird und welche ggf. Reste aus dem Customizer z.B. "Zusätzliches CSS" o.ä. noch in der Datenbank überlebt haben.

    Probiere es mal mit dem angehängten Twenty Fifteen Childtheme, ganz ohne irgendwelche Configurator Plugins.
     

    Anhänge:

  3. Achill

    Achill Well-Known Member

    Registriert seit:
    13. Februar 2016
    Beiträge:
    45
    Zustimmungen:
    0
    Vielen Dank für die Hilfe, @b3317133!

    Nach einigem ’rumprobieren habe ich den Fehler gefunden: In der Child-style.css war in die url-Angabe einer font-face-Definition, die am Anfang des sheets liegen, ein Zeilenumbruch hereingeruscht (wie auch immer der dahin gekommen ist...), was das gesamte stylesheet unbrauchbar gemacht hat.

    Gibt es irgendwo im Netz eine Möglichkeit, stylesheets prüfen lassen zu können, um genau solche Fehler, die nach dreimal hinsehen eben nicht mehr gesehen werden, zu finden? Oder gibt es bessere Editoren als bluefish, die einen solchen Fauxpax deutlich markieren können?

    Ich finde keine Möglichkeit, das Thema auf "erledigt/gelöst" setzen zu können...
     
  4. SEpp55

    SEpp55 Well-Known Member

    Registriert seit:
    3. Februar 2016
    Beiträge:
    1.533
    Zustimmungen:
    165
    Das ist das ander Forum!
     
  5. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    5.736
    Zustimmungen:
    489
    Oft kommen solche Probleme auch durch veraltete und nicht/falsch funktionierende "Child-Theme Generatoren" o.ä., die im Grunde völlig unnötig sind, wenn man einen Blick in die wordpress.org Dokumentation wagt.
    z.B. https://jigsaw.w3.org/css-validator/
     
    #5 b3317133, 20. Mai 2019
    Zuletzt bearbeitet: 20. Mai 2019
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden