1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Theme mit Passwort-Artikeln nicht kompatibel?

Dieses Thema im Forum "Design" wurde erstellt von Samanta0505, 25. Juli 2014.

  1. Samanta0505

    Samanta0505 Member

    Registriert seit:
    11. Mai 2007
    Beiträge:
    24
    Zustimmungen:
    0
    Hallo liebe Wordpress-Gemeinde,

    ich hab da wieder ein kleines Problem und hoffe, Ihr könnt mir helfen.
    Und zwar war ich dazu gezwungen mein WP-Theme zu ändern, da das alte Probleme damit hatte, passwortgeschützte Artikel in jedem Browser auch als solche zu erkennen. (In Chrome, IE etc. ging es, im Safari wurden die Beiträge so angezeigt.) Später gab es dann nur noch eine weiße Seite, sodass ich genug davon hatte.

    Nun, ein neues Theme war fix gefunden, angepasst und überhaupt. Doch nun kommt das Problem in ähnlicher Weise zurück:
    Wenn ich einen passwortgeschützten Artikel erstelle, kann er von einigen nach der Eingabe gelesen werden, von vielen aber eben auch nicht.
    Zunächst nahm ich an, es sei eine Cookie-Sache und passte die Einstellungen an, doch das Problem besteht weiterhin. Auch das Deaktivieren sämtlicher Plugins brachte keine neuen Erkenntnisse. Nur wenn ich auf z.B. das Theme Twenty Eleven ausweiche, kann das Passwort von allen eingegeben werden und der Artikel erscheint in voller Länge. (15 Leute, unterschiedliche Browser, Cookies erlaubt: 5 können das PW eingeben wie sie wollen, die Abfrage erscheint immer wieder - ich gehöre dazu).


    Wordpress Version: 3.9.1
    Theme:
    sugar & spice

    Woran kann das liegen und - vor allem - wie kann ich es beheben? Hab mich viel belesen, zu exakt diesem Problem aber nichts gefunden und bin um jede Hilfe dankbar!
     
  2. Samanta0505

    Samanta0505 Member

    Registriert seit:
    11. Mai 2007
    Beiträge:
    24
    Zustimmungen:
    0
    keiner eine Idee? :confused:
     
  3. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.965
    Zustimmungen:
    8
    Wenn es ein Kauf-Theme ist, frage den Entwickler. Ich vermute, das niemand das Theme benutzt.
     
  4. mensmaximus

    mensmaximus Well-Known Member

    Registriert seit:
    24. Juli 2014
    Beiträge:
    7.715
    Zustimmungen:
    209
    Wenn Du den WP eigenen Passwortschutz verwendest und es Probleme im Theme gibt, liegt das meistens daran, dass die Entwickler ein eigenes Eingabeformular verwenden. Im Regelfall findest Du dann im Theme einen Filter, der auf 'the_password_form' angewendet wird und zu entsprechendem Problem führt.


    Indem Du die Zeile "add_filter( 'the_password_form', 'name_der_funktion_im_theme' );" auskommentierst, wird das Original Formular verwendet. Ist der Fehler dann beseitigt muss der Entwickler seine Funktion überarbeiten, wenn er ein Interesse daran hat, dass sein Theme weiterhin verbreitet wird.
     
  5. Samanta0505

    Samanta0505 Member

    Registriert seit:
    11. Mai 2007
    Beiträge:
    24
    Zustimmungen:
    0
    Danke @ mensmaximus, das war die Lösung! Hab es auskommentiert und nun funktioniert der Passwortschutz wieder einwandfrei!
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden