Thumnails als Custom Fields nur dann anzeigen wenn existent

Dieses Thema im Forum "Konfiguration" wurde erstellt von Mitglied, 4. November 2008.

  1. Mitglied

    Mitglied Member

    Registriert seit:
    4. Mai 2008
    Beiträge:
    8
    Zustimmungen:
    0
    Moinmoin,

    habe folgendes Problem:

    In meinem Blog zeige ich verlinkte Thumbails zu den Beiträgen:
    <a href="<?php the_permalink() ?>" rel="bookmark"><img src="<?php echo get_post_meta($post->ID, "Thumbnail", true); ?>" alt="<?php echo get_post_meta($post->ID, "Theme Name", true); ?>" border="0" /></a>

    Allerdings will ich nicht für jeden Beitrag ein Thumbnail verwenden. Falls aber kein Thumbnail über die Custom Fields definiert ist, soll auch keine Bildausgabe erfolgen.

    Grund: Im IE werden nichtexistierende Bilder als defekte Bilder angezeigt.

    Hat mir jemand eine Lösung, Bilder (Thumbnails) per php nur dann auszugeben, wenn diese in einem Beitrag auch definiert sind.

    Hilft das Plugin "Get Custom Field Values" bei der Problemlösung. Wenn ja, wie?

    Vielen Dank für Eure Hilfe.
     
  2. Whoppy

    Whoppy Well-Known Member

    Registriert seit:
    27. August 2008
    Beiträge:
    438
    Zustimmungen:
    0
    Morgen,

    habe das bei mir so gelöst:

    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Ich überprüfe ob der Wert von get_post_custom_values nicht leer ist, wenn nein, wird das Bild ausgegeben, wenn ja, gebe ich ein Standardbild aus.

    Gruß Simon