TwentyEleven - Site-Generator

Dieses Thema im Forum "Konfiguration" wurde erstellt von Dok-Tore, 28. Februar 2012.

  1. Dok-Tore

    Dok-Tore Member

    Registriert seit:
    15. November 2011
    Beiträge:
    13
    Zustimmungen:
    0
    Moin Zusammen,

    ich bin gerade dabei eine Seite aufzubauen und habe dazu ein ChildTheme aus dem TwentyEleven gebaut.

    Dazu habe ich die Fussleise "Site-Generator" angepasst. (Links und Rechts eine Grafik mit Hyperlink).

    Mein Problem ist, das diese Grafiken (der Rest wird angezeigt) nur auf der Startseite angezeigt werden und nicht auf den anderen Seiten. Kann mir jemand helfen?

    viele Grüße

    Dok-Tore
     
  2. Pero

    Pero Well-Known Member

    Registriert seit:
    22. Februar 2012
    Beiträge:
    83
    Zustimmungen:
    0
    Hast du das ganze in der footer.php von Twenty Eleven angepasst oder hast du eine footer.php in deinem childtheme erstellt?
     
  3. Dok-Tore

    Dok-Tore Member

    Registriert seit:
    15. November 2011
    Beiträge:
    13
    Zustimmungen:
    0
    Ich habe dafür den footer der twentyeleven in mein childtheme kopiert und angepasst. Ebenso habe ich die style.css angepasst.

    Link: tischlerei-thomas-voss.de/cms
     
  4. Pero

    Pero Well-Known Member

    Registriert seit:
    22. Februar 2012
    Beiträge:
    83
    Zustimmungen:
    0
    Der Link: "impressum" in der mitte des Footers steht aber nicht im childtheme oder?

    Edit://

    [​IMG]

    Die Bilder werden nicht gefunden, also stimmt da was mit den Pfaden nicht.
    Zur Not könntest du auch die direkten Pfade verwenden.
    richtiger Pfad:
    http://tischlerei-thomas-voss.de/cms/wp-content/themes/ttv/images/tel-white.png

    Pfad unter dem er die Bilder auf anderen Seiten sucht:
    http://tischlerei-thomas-voss.de/cms/uber-uns/wp-content/themes/ttv/images/tel-white.png

    Wenn du im CSS also die direkten Pfade verwendest (der obere Pfad) , dann sollte es überall richtig sein.
     
    #4 Pero, 28. Februar 2012
    Zuletzt bearbeitet: 28. Februar 2012
  5. Dok-Tore

    Dok-Tore Member

    Registriert seit:
    15. November 2011
    Beiträge:
    13
    Zustimmungen:
    0
    doch... ich habe den footer ja in drei bereiche aufgeteilt.
     
  6. Pero

    Pero Well-Known Member

    Registriert seit:
    22. Februar 2012
    Beiträge:
    83
    Zustimmungen:
    0
    Wenn du den jeweiligen ids : links_innen und rechts_innen in deiner CSS-Datei als Background die Bilder mit direktem Pfad gibst, dann werden sie auch immer angezeigt.

    ps: Poste bitte deinen editierten footer, dann kann ich dir besser helfen.

    EDIT://

    Ich hab gerade nochmal geschaut, wenn man auf der Seite Über Uns den Pfad des Bildes ändert von:

    HTML:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    zu

    HTML:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    wird es angezeigt.

    die ".." bedeuten, dass er ein Verzeichnis zurückgehen soll und dann in wp-content/themes usw.
     
    #6 Pero, 28. Februar 2012
    Zuletzt bearbeitet: 28. Februar 2012
  7. Dok-Tore

    Dok-Tore Member

    Registriert seit:
    15. November 2011
    Beiträge:
    13
    Zustimmungen:
    0
    nun werden die Bilder aber auf der Startseite nicht mehr angezeigt. Aber ich weiss zumindest wo der Fehler liegt.

    Danke
     
    #7 Dok-Tore, 28. Februar 2012
    Zuletzt bearbeitet: 28. Februar 2012
  8. Pero

    Pero Well-Known Member

    Registriert seit:
    22. Februar 2012
    Beiträge:
    83
    Zustimmungen:
    0
    Ich sehe du hast es geändert. Nur stimmt der Pfad jetzt ja nicht mehr für die Startseite.

    Wenn du den img-tag so änderst:
    HTML:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    wird es auf jeden fall funktionieren.
     
  9. Dok-Tore

    Dok-Tore Member

    Registriert seit:
    15. November 2011
    Beiträge:
    13
    Zustimmungen:
    0
    verstehen muss ich das aber nicht oder?
    Denn die Angabe des Pfades mit wp-content... ist ja grundsätzlich richtig...

    Danke Pero !!!


    Ich würde gerne noch ein Hintergrundbild anstatt der grauen Seite verwenden. Wenn ich die Datei im WP-admin hochlade, dann klappt das leider auf großen Bildschirmen nicht.

    Weisst Du wie ich das verändern kann, damit auf jedem Bildschirm immer der selbe Hintergrund angezeigt wird. Die komplette Seite soll ausgefüllt sein.
     
  10. Pero

    Pero Well-Known Member

    Registriert seit:
    22. Februar 2012
    Beiträge:
    83
    Zustimmungen:
    0
    Bitte gerne ;)

    wenn du ein großes Bild als Hintergrund nutzen willst, dass nicht gekachelt werden soll, dann mache folgendes:

    CSS:

    HTML:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    EDIT://
    Bedenkte, dass du zuerst den Hintergrund in der style.css von Twentyeleven auskommentieren/löschen solltest.

    Gehe dafür in den Ordner Twenty Eleven und öffne die style.css

    In Zeile 330 steht bei dir:
    HTML:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    setze dann/* */ ein.
    HTML:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    und in die style.css deines chil themes packst du den code, den ich oben beschrieben habe.
     
    #10 Pero, 28. Februar 2012
    Zuletzt bearbeitet: 28. Februar 2012
  11. Dok-Tore

    Dok-Tore Member

    Registriert seit:
    15. November 2011
    Beiträge:
    13
    Zustimmungen:
    0
    Hilfe @ Pero !!!

    Irgendwie haut das mit den Bildern in der Fussnote nicht hin. Im Firefox werden die Pics angezeigt. Im IE oder Chrome jedoch nicht.

    Woran kann das denn wohl liegen?
     
  12. Pero

    Pero Well-Known Member

    Registriert seit:
    22. Februar 2012
    Beiträge:
    83
    Zustimmungen:
    0
    Du hast jetzt ganz andere Links im Footer stehen:

    HTML:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    vorher sahen die so aus:

    HTML:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    packe einfach wieder solche direktlinks rein:
    HTML:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!

    Edit://

    Ich gebe dir einen Tip:
    google liebt alt tags, da ein crawler einer Suchmaschine keine Bilder angucken kann.

    Beispiel:
    HTML:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    auch wenn du leere Alt-Tags hinzufügst, hauptsache sie sind da :D
     
  13. Dok-Tore

    Dok-Tore Member

    Registriert seit:
    15. November 2011
    Beiträge:
    13
    Zustimmungen:
    0
    @ pero - danke
     
  14. Pero

    Pero Well-Known Member

    Registriert seit:
    22. Februar 2012
    Beiträge:
    83
    Zustimmungen:
    0
    jetzt fehlt nur noch ein Hintergrundbild ;)
     
  15. Dok-Tore

    Dok-Tore Member

    Registriert seit:
    15. November 2011
    Beiträge:
    13
    Zustimmungen:
    0
    auch fertig... danke Dir...
     
  16. Pero

    Pero Well-Known Member

    Registriert seit:
    22. Februar 2012
    Beiträge:
    83
    Zustimmungen:
    0
    Kein Problem :)
     
  17. Dok-Tore

    Dok-Tore Member

    Registriert seit:
    15. November 2011
    Beiträge:
    13
    Zustimmungen:
    0
    sag mal wenn ich das header foto kleiner haben will... also die größe von 1000x288 auf sagen wir mal 1000x200 stellen will. wo kann ich das denn verstellen?
     
  18. Pero

    Pero Well-Known Member

    Registriert seit:
    22. Februar 2012
    Beiträge:
    83
    Zustimmungen:
    0
    in der style.css in Zeile 539 gibt es:

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    einfach statt height:auto; die 200 px einfügen.

    Ergebnis:
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
     
  19. Dok-Tore

    Dok-Tore Member

    Registriert seit:
    15. November 2011
    Beiträge:
    13
    Zustimmungen:
    0
    danke danke danke
     
  20. Pero

    Pero Well-Known Member

    Registriert seit:
    22. Februar 2012
    Beiträge:
    83
    Zustimmungen:
    0
    Bitte, gerne ;)