1. Herzlich Willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Umlaute in Überschrift werden nicht angezeigt

Dieses Thema im Forum "Konfiguration" wurde erstellt von mintol, 19. September 2010.

  1. mintol

    mintol New Member

    Registriert seit:
    19. September 2010
    Beiträge:
    4
    Zustimmungen:
    0
    Hallo :)

    Ich habe ein Problem, dem ich auch durch intensives "googeln" nicht auf die schliche kommen konnte.
    Auf meinem Blog (www.movieshot.de) werden die Umlaute ausschließlich in der Überschrift nicht angezeigt, zudem wird auch nicht ein symbol gewurschtel angezeigt wie es der fall sein könnte, sondern der Umlaut fehlt einfach.
    Beispiel: Säge, auf meinem Blog in der Überschrift dann: "Sge".

    In den Texten unter der überschrift werden sie ganz normal dargestellt und ich verwende den Zeichensatz UTF-8.
    Wordpress Version: Die aktuellste und Theme: pristilo (http://www.web2feel.com/pristilo/)

    Vllt hilft das auch noch:
    /** Der Datenbankzeichensatz der beim Erstellen der Datenbanktabellen verwendet werden soll */
    define('DB_CHARSET', 'utf8');


    Ich hoffe mir kann jemand helfen!

    LG
     
    #1 mintol, 19. September 2010
    Zuletzt bearbeitet: 19. September 2010
  2. Ammaletu

    Ammaletu Well-Known Member
    Ehrenmitglied

    Registriert seit:
    14. Juli 2007
    Beiträge:
    4.694
    Zustimmungen:
    0
    Du setzt für die Anzeige der Überschriften in einer bestimmten Schriftart das JavaScript "Cufon" ein, und zwar zusammen mit einer Schriftart, welche die Umlaute nicht enthält. Das kann nicht klappen. ;)

    Belies Dich in der Doku des Themes bzw. im Internet mal, was Cufon ist, und überleg dann, ob Du das wirklich brauchst. Falls ja, müsstest Du schauen, dass Du die verwendete Schriftart auf der Cufon-Seite neu generierst, und zwar mit den nötigen Sonderzeichen. Das nur als genereller Hinweis; ich hatte mich dazu für einen anderen Thread vor einem Jahr oder so mal belesen, aber ganz sicher bin ich mir bei den Details nicht mehr. Glaube aber mich zu erinnern, dass man das auf der Cufon-Seite neu generieren lassen konnte.
     
  3. mintol

    mintol New Member

    Registriert seit:
    19. September 2010
    Beiträge:
    4
    Zustimmungen:
    0
    Danke für deine Antwort Ammaletu,

    nach deinem Hinweis auf Cufon (was tatsächlich in meiner header.php aktiviert war) habe ich Cufon überhaupt erstmal installiert und das Problem damit beseitigt :)

    Für die die auch mal das Problem haben sollten,
    hier die Schriftart generieren: http://cufon.shoqolate.com/generate/
    Cufon installieren: http://wordpress.org/extend/plugins/wp-cufon/

    und die Schriftart nach wp-content/plugins/fonts hochladen (den ordner fonts bei bedarf erstellen).

    Mfg
     
  4. Ammaletu

    Ammaletu Well-Known Member
    Ehrenmitglied

    Registriert seit:
    14. Juli 2007
    Beiträge:
    4.694
    Zustimmungen:
    0
    Nur so aus Interesse, stand das in der Doku des Themes denn deutlich genug bzw. überhaupt drin? Das ist ja schon ein wichtiger Schritt für diese Themes, den man nicht vergessen sollte. Eventuell lohnt sich ein Hinweis an den Theme-Autoren, der sich vielleicht gar nicht bewusst ist, dass das nicht nur eine rein optische Sache ist, wenn man Cufon nicht oder falsch konfiguriert.
     
  5. miami.us

    miami.us Member

    Registriert seit:
    22. Juli 2011
    Beiträge:
    21
    Zustimmungen:
    0
    gibts da keine einfachere Möglichkeit um ein Umlaut einzufügen. ich versteh die anleitung überhaupt nicht.
     
  6. gericoach

    gericoach Well-Known Member

    Registriert seit:
    12. August 2008
    Beiträge:
    7.194
    Zustimmungen:
    0
    nein, umlaute kannste nicht in fontdateien einbauen. Suche dir ne ähnliche Schrift, die umlaute kann, generiere ne Datei bei cufon und ändere die Dateieinträge in der style.css
     
  7. miami.us

    miami.us Member

    Registriert seit:
    22. Juli 2011
    Beiträge:
    21
    Zustimmungen:
    0
    aber meine schrift ist arial. ich versteh einfach nicht, warum das nicht geht.
    wie generiere ich denn eine datei bei cufon? ich bin total absoluter anfänger und kapier das einfach nicht.
     
  8. gericoach

    gericoach Well-Known Member

    Registriert seit:
    12. August 2008
    Beiträge:
    7.194
    Zustimmungen:
    0
    bei Arial brauchste kein cufon...
     
  9. miami.us

    miami.us Member

    Registriert seit:
    22. Juli 2011
    Beiträge:
    21
    Zustimmungen:
    0
    ok, also folgendes Problem:
    ich benutze das theme boldy, und ich kann weder die schriftart der page title ändern, noch umlaute einfügen. also wenn ich auf arial "kodiere", und dann die seite anschaue, dann seh ich arial für eine halbe sekunde, dann gehts zurück auf die alte schrift. warum das??? kann mir jemand helfen?
     
  10. miami.us

    miami.us Member

    Registriert seit:
    22. Juli 2011
    Beiträge:
    21
    Zustimmungen:
    0
    hilfe help hilfe...:?:
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden