1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Umlaute mit Postie (Bloggen per Mail)?

Dieses Thema im Forum "Plugins und Widgets" wurde erstellt von nanu, 18. Juli 2005.

  1. nanu

    nanu New Member

    Registriert seit:
    18. Juli 2005
    Beiträge:
    4
    Zustimmungen:
    0
    Hallo,

    habe das postie Plugin installiert um auch Bilder per E-Mail ins Blog mailen zu können.

    Klappt auch ganz gut, nur die Umlaute im Text erscheinen nicht richtig. Mit Firefox nur Fragezeichen. In meinem Palm Browser gar nicht.

    Hat jemand einen Tip?

    Danke und viele Grüße
    Harald

    P.S.:

    http://www.malhiermaldort.de/
    Wordpress: 1.5.1.2

    Infos zu Postie:
    http://www.economysizegeek.com/?page_id=395
     
  2. TigerDE2

    TigerDE2 Well-Known Member

    Registriert seit:
    9. September 2004
    Beiträge:
    1.137
    Zustimmungen:
    0
    Ich hab's gerade mal ausprobiert; dein Handy sendet US-ASCII. Dein Blog erzählt aber den Browsern, es nutze UTF-8. Daher die Anzeigefehler.
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Du hast jetzt mehrere Möglichkeiten.
    a) Du stellst dein Blog auf US-ASCII um. Schlechte Idee, weil das bereits vorhandene Posts brechen würde. Ausserdem ist das nicht wirklich kompatibel.
    b) Du überredest dein Handy, in UTF-8 zu senden. Frag mich nicht wie, da kann dir evt. dein Handyhersteller helfen. Wenn's wirklich am Handy und nicht an der Konvertierung zur E-Mail beim Mobilfunkanbieter liegt.
    c) Du baust dieses Plugin um, passt es an USASCII an und bindest es ein...
    hth
    Christian
     
  3. nanu

    nanu New Member

    Registriert seit:
    18. Juli 2005
    Beiträge:
    4
    Zustimmungen:
    0
    Hallo,

    danke für die Hinweise, das hat mich weitergebracht. Meine Mails kommen als Latin (ISO-8859-1) an. Somit ist das von Dir erwähnte Plugin schon eine erste Hilfe.

    Besser wäre natürlich wenn das Postie Plugin die Umwandlung machen könnte. Den umgekehrten Weg (UTF-> nach Latin) scheint es ja sogar zu geben, es gibt ja bei den Optionen einen Schalter wo man angeben kann, ob das Blog unter Latin läuft.

    Kann mir jemand einen Tip geben, an welcher Stelle in Postie man das am besten angeht?

    Danke und viele Grüße
    Harald
     
  4. TigerDE2

    TigerDE2 Well-Known Member

    Registriert seit:
    9. September 2004
    Beiträge:
    1.137
    Zustimmungen:
    0
    Funktioniert's mittlerweile...?
    Christian
     
  5. nanu

    nanu New Member

    Registriert seit:
    18. Juli 2005
    Beiträge:
    4
    Zustimmungen:
    0
    die Notlösung mit dem Plugin ja, habe das so modifiziert, dass er alle Einträge ab heute von Latin auf UTF umstellt, das latin-to-utf Plugin war ja eigentlich um alte Einträge umzustellen.

    Besser wäre natürlich, wenn ich die Konvertierung in postie hinbekommen würde. Im Abreisestress fehlt mir da aber leider etwas die Zeit lange im php-code nach der richtigen Stelle zu suchen.

    Was mich irritiert, habe im Netz jemand getroffen, bei dem die Umlaute mit Postie klappen, obwohl er auch mails in latin schickt,

    Viele Grüße aus Bonn
    Harald
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden