1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

umlaute werden auf index seite nicht angezeigt

Dieses Thema im Forum "Design" wurde erstellt von oliverberlin79, 30. Mai 2011.

  1. oliverberlin79

    oliverberlin79 Well-Known Member

    Registriert seit:
    7. Oktober 2008
    Beiträge:
    156
    Zustimmungen:
    0
  2. Marcus[IS]

    Marcus[IS] Well-Known Member

    Registriert seit:
    23. August 2009
    Beiträge:
    5.539
    Zustimmungen:
    81
    Mojn,

    das liegt daran, dass dein Theme Cufon verwendet.

    Sprich das Teil geht hin und verwendet eigene Zeichensätze und wandelt die Buchstaben in Grafiken um.
    Wenn der Zeichensatz allerdings keine Deutschen Umlaute enthält, werden diese in alt hergebrachte Weise (ae oe ue sz) umgewandelt.

    Ich verweise mal auf einen Link, den Ammaletu vor etlicher Zeit hier gepostet hatte;
    https://github.com/sorccu/cufon/wiki/about
    Dort wird es auch ein wenig erklärt.

    Du müsstest also mal schauen, welcher Font für die Überschriften (wahrscheinlich in der style.css ein ein fontverweis bei der <h1> Definierung) verwendet wird und diesen nur gegen einen austauschen, der Deutsche Umlaute enthält.

    Und wenn du sogar einen anderen Font verwenden willst, schau mal bei dafont.com vorbei, dort haben sie auch sehr viele Fonts mit Umlauten. ;)
     
  3. oliverberlin79

    oliverberlin79 Well-Known Member

    Registriert seit:
    7. Oktober 2008
    Beiträge:
    156
    Zustimmungen:
    0
    hallo,

    vielen Dank erst mal für den ersten Ansatz. Aber ich konnte noch keinen Link zu einem externem Schriftpfad finden

    zu hi1 steht in der css:
    h1, h2, h3 { font-family:"Trebuchet MS",Arial,Helvetica,sans-serif; line-height:30px; }

    ansonsten gibt es aber auch noch die Zeile:

    h1, h1 a, h1 a:hover, h1 a:visited, #headerimg .description {text-decoration: none;}

    #headerimg kann ich allerdings sonst nirgends in der css ausmachen..

    wir könnte ansonsten noch so ein Fontverweis ausschauenbzw, wo könnte sich die Cufon Datenbank befinden?
     
  4. Marcus[IS]

    Marcus[IS] Well-Known Member

    Registriert seit:
    23. August 2009
    Beiträge:
    5.539
    Zustimmungen:
    81
    Ah ja,
    da hab ich das wohl ein wenig mit Webfonts durcheinandergwürfelt, sorry, aber Cufon basiert ja auf Javascript.

    Ich habe mir das Theme mal eben gezogen und bin in der header.php auf einen Interessanten Eintrag gestoßen;
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Nun habe ich das Theme mal in meine Locale WP Installation gepackt und siehe da, es gibt sogar in den Themekonfigurationen eine Einstellung Cufon zu deaktivieren.

    Ist Cufon bei mir auf der Lokalen Installation aktiv, werden die Umlaute nicht dargestellt, ist es Deaktiviert, habe ich keine Probleme.
     
    #4 Marcus[IS], 31. Mai 2011
    Zuletzt bearbeitet: 31. Mai 2011
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden