1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

WP 4.8 Umstellung auf SSL-Zertifikat - WP-Admin nicht mehr zu erreichen

Dieses Thema im Forum "Konfiguration" wurde erstellt von Andrea1986, 6. August 2018.

  1. Andrea1986

    Andrea1986 Member

    Registriert seit:
    7. Februar 2017
    Beiträge:
    8
    Zustimmungen:
    0
    Hallo ihr Lieben,

    da dachte ich, das Umstellen auf SSL ist nicht allzu kompliziert, und jetzt habe ich wohl was kaputt gemacht :(

    Aber ich fange mal von vorne an. Ich hoste meinen Blog bei web.de. Da habe ich jetzt gesehen, dass die ein SSL Zertifikat anbieten. Das habe ich mit einem Klick angefordert und innerhalb kürzester Zeit kam die Meldung vom Hoster, dass das SSL-Zertifikat aktiviert wurde.

    Aber die Seite ist nach wie vor unverschlüsselt.

    Also habe ich das Plugin Really Simple SSL installiert. Das Plugin hat kein https erkannt und es gab die Möglichkeit, mittels eines Buttons die Seite neu über https zu laden (wenn ich das so noch richtig in Erinnerung habe?) Das Laden der Seite schlug fehl wegen Zeitüberschreitung.

    Jetzt kommt der Punkt, ab dem nichts mehr ging. Da ich irgendwo gelesen habe, dass man das http evtl. manuell auf https umstellen soll, habe ich das unter Einstellungen > Allgemein gemacht. Das heißt, ich habe einfach (naiv, wie ich bin) die URL in den Feldern WordPress-Adresse (URL) und Website-Adresse (URL) händisch geändert.

    Jetzt kann ich mich nicht mehr als Admin anmelden, es kommt immer eine Zeitüberschreitung. Die Webseite lässt sich ganz normal aufrufen (mit der alten URL - also über http)

    Vor der ganzen Aktion habe ich ein Backup erstellt. Allerdings habe ich keinen Schimmer davon, wie ich das jetzt wiederherstellen soll - ohne mich in mein Dashboard anzumelden :(

    Hat jemand eine Idee, wie ich das wieder hin kriege? Aber bitte möglichst einfach erklärt und ohne Programmier-Fachsprache :oops:

    Schon jetzt vielen lieben Dank für eure Unterstützung

    EDIT:
    Jetzt kommt diese Meldung, wenn ich mein Dashboard aufrufen möchte:

    Fehler: Gesicherte Verbindung fehlgeschlagen
    Beim Verbinden mit www.endlichleben-blog.de trat ein Fehler auf. Die Gegenstelle meldet, dass sie auf einen internen Fehler gestoßen ist. Fehlercode: SSL_ERROR_INTERNAL_ERROR_ALERT

    Die Website kann nicht angezeigt werden, da die Authentizität der erhaltenen Daten nicht verifiziert werden konnte.

    Kontaktieren Sie bitte den Inhaber der Website, um ihn über dieses Problem zu informieren.
     
  2. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    6.881
    Zustimmungen:
    651
    Dein Zertifikat ist offenbar noch nicht verfügbar.

    Es gibt diverse Möglichkeiten das zurückzustellen.

    1. Hast Du Zugang zur Datenbank, z.b. über ein Tool "phpMyAdmin" beim Provider? Bei web.de z.B. hier.

    Dann kannst Du dort in der Tabelle wp_options die Einträge siteurl und home anpassen, also dort das https wieder durch http ersetzen.

    Ergänzung: Das sieht in etwa so aus wie auf diesem Screenshot (one.com, gefunden via Suchmaschine), mit einem Klick auf "Edit" in der entspr. Zeile oder mit einen Klick direkt auf den derzeit falschen Eintrag in der Spalte option_value kann man Änderungen machen.
     
    #2 b3317133, 6. August 2018
    Zuletzt bearbeitet: 6. August 2018
    MarcelTannich und Andrea1986 gefällt das.
  3. Andrea1986

    Andrea1986 Member

    Registriert seit:
    7. Februar 2017
    Beiträge:
    8
    Zustimmungen:
    0
    Du bist ein Schatz :)
    Jetzt kann ich mich wieder einloggen.
    Vielen lieben Dank für Deine Hilfe
     
  4. wpgray

    wpgray Well-Known Member

    Registriert seit:
    5. August 2018
    Beiträge:
    47
    Zustimmungen:
    3
    und tu dir selbst einen gefallen und deinstallier dieses plugin und hol dir ein zertifikat bei deinem hoster oder über lets encrypt..
     
  5. FloRet

    FloRet Well-Known Member

    Registriert seit:
    20. September 2016
    Beiträge:
    1.196
    Zustimmungen:
    90
    Hallo @Andrea1986

    Es scheint so, als ob Dein Zertifikatsproblem gelöst ist! Was noch auffällt - Binde das Bild für den Werbebanner zu energiebilder-selber-malen mit https ein, denn ansonsten bleibt der "gemischte Inhalt" von http und https noch weiterhin vorhanden = Nicht sicher!

    Beste Grüße
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden