1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Und noch einmal "Out-of-Memory"

Dieses Thema im Forum "Installation" wurde erstellt von werderblog, 21. Juli 2009.

  1. werderblog

    werderblog Member

    Registriert seit:
    21. Juli 2009
    Beiträge:
    8
    Zustimmungen:
    0
    Und noch einmal "Out-of-Memory" (Deutsche Sprachdatei)

    Hallo zusammen,

    ich weiß, dass dieses Thema in der Vergangenheit schon sehr oft besprochen worden ist, allerdings habe ich bisher nur Workarounds gefunden und irgendwie finde ich das nicht zufriedenstellend.

    Nach Upgrade auf 2.8.2 habe auch ich im Dashboard die bekannten "Out-of-Memory"-Fehler (vgl. z.B. hier: http://forum.wordpress-deutschland.org/installation/55528-update-auf-wp-2-8-2-a.html).




    Ich habe sämtliche Tipps durchgeführt:
    • Plugins deaktiviert
    • define('WP_MEMORY_LIMIT', '32M'); in WP-Config eingefügt
    • 123-Tools integriert und Komponenten ausgeschaltet
    • ...
    Ich habe das Memory-Usage-Plugin installiert und verbrauche demnach unter 20 MB (bei aktivierten Plugins). Laut Provider stehen mir 36 MB zur Verfügung. Dürfte also kein Problem sein.

    Das einzige, was wirklich hilft, ist die Deaktivierung der deutschen Sprachdatei. Nur möchte ich mich aber damit nicht abfinden.

    Hat jemand eine Idee, was hier im Argen liegen könnte?

    Danke und Gruß
    Werderblog
     
    #1 werderblog, 21. Juli 2009
    Zuletzt bearbeitet: 22. Juli 2009
  2. jottlieb

    jottlieb Well-Known Member
    Ehrenmitglied

    Registriert seit:
    20. August 2005
    Beiträge:
    17.381
    Zustimmungen:
    0
    Poste doch mal bitte die komplette Fehlermeldung.
     
  3. werderblog

    werderblog Member

    Registriert seit:
    21. Juli 2009
    Beiträge:
    8
    Zustimmungen:
    0
    Fatal error: Out of memory (allocated 21233664) (tried to allocate 311296 bytes) in /home/www/werderblog/wp-includes/class-simplepie.php on line 4134
     
  4. werderblog

    werderblog Member

    Registriert seit:
    21. Juli 2009
    Beiträge:
    8
    Zustimmungen:
    0
    Mit aktivierter deutscher Sprachdatei benötige ich laut Memory-Usage-Plugin ca. 4 MB mehr Speicher (ca. 20 MB anstatt 16 MB).

    Ich verwende übrigens PHP-Version 5.2.8.
     
  5. marX

    marX Well-Known Member
    Ehrenmitglied

    Registriert seit:
    5. Oktober 2006
    Beiträge:
    12.943
    Zustimmungen:
    0
    Das sind 20 MB, keine 36. Wenn phpinfo() 36 MB sagt, dann könnte z.B. ein Plugin den Wert runtersetzen.

    Das hier wäre in dem Fall übrigens sinnfrei:
    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Du würdest das Limit ja runtersetzen.
     
  6. werderblog

    werderblog Member

    Registriert seit:
    21. Juli 2009
    Beiträge:
    8
    Zustimmungen:
    0
    Laut phpinfo() sollten mir zumindest 25 MB zur Verfügung stehen. Der Wert 21233664 passt also auch nicht so wirklich.

    Ich habe dennoch mal bei meinem Provider nachgehakt, warum der Wert so niedrig ist und ihn gebeten, ihn entsprechend hochzusetzen.
     
  7. werderblog

    werderblog Member

    Registriert seit:
    21. Juli 2009
    Beiträge:
    8
    Zustimmungen:
    0
    So, mein Provider hat den Wert jetzt auf 36 MB hochgesetzt. PHPInfo weist auch diesen Wert aus - genauso wie das Memory-Usage-Plugin.

    Leider ändert sich an der Fehlermeldung rein gar nichts. Wenn ich das deutsche Sprachpaket aktiviere, werden laut Plugin 19.47 MB also 54 % des Gesamtspeichers verbraucht (ohne Sprachpaket sind es nur 14.96 MB) und die bereits geposteten Fehlermeldungen angezeigt.

    Mich verwundern allerdings die Zahlenwerte in der Fehlermeldung:
    Die allokierten 21 MB könnte man ja noch auf Ungenauigkeiten im Plugin zurückführen, aber warum kann er die anscheinend benötigten ca. 31 MB nicht allokieren, wenn ihm doch 36 MB zur Verfügung stehen?

    Jemand eine Idee?
     
  8. tomatl

    tomatl Well-Known Member

    Registriert seit:
    4. Juni 2006
    Beiträge:
    62
    Zustimmungen:
    0
    Tja, das mit der deutschen Sprachdatei in der config.php ist bei mir auch so. Sobald ich de_DE rausstreiche funktionierts, sobald es eingetragen ist, erscheint folgende Fehlermeldung:

    Fatal error: Allowed memory size of 52428800 bytes exhausted (tried to allocate 1 bytes) in /home/.sites/302/site611/web/wp-includes/pomo/mo.php on line 170

    Den Memory-Wert hat mein Provider gerade auf 50 MB erhöht, zuvor hatte ich 44 MB.

    Kann es wirklich nur an der deutschen Sprachdatei liegen? Würde mich sehr wundern...

    Beste Grüße
    Henry
     
  9. jottlieb

    jottlieb Well-Known Member
    Ehrenmitglied

    Registriert seit:
    20. August 2005
    Beiträge:
    17.381
    Zustimmungen:
    0
    @tomatl:
    Dein Blog verbraucht 55 MB? Das ist ja Wahnsinn....
    Ich verweise auch nochmal auf http://blog.wordpress-deutschland.org/2009/06/16/fatal-error-allowed-memory-size-of-bytes-exhausted.html
    Es scheint Kombinationen zu geben, bei denen WP je nach Server verdammt viel Speicher frisst. Warum, das ist noch nicht klar.

    Zur deutschen Sprachdatei: Diese wird komplett in den Speicher geladen, das kann gerne bis zu 2 MB ausmachen. Aus diesem Grund läuft bei vielen (vorerst) der Blog wieder, wenn man die Sprachdatei rausnimmt, da diese 2 MB die sein können, die das Fass zum überlaufen bringen.
    Außerdem ist AFAIK in WP 2.8 die gettext-Funktion auch nicht gerade schlank programmiert.
     
  10. tomatl

    tomatl Well-Known Member

    Registriert seit:
    4. Juni 2006
    Beiträge:
    62
    Zustimmungen:
    0
    Ich verstehe es auch nicht, so viel hat mein Blog noch nie verbraucht! Ohne deutsche Sprachdatei läuft es derzeit (laut memory overview) mit 17,25 MB Usage.

    Sobald ich die de_DE in die config.php einfüge, geht es immer bis an Speicherlimit - mit besagter Fehlermeldung. Komischerweise stieß ich schon bei 44 MB um ein paar KB an die Grenzen, und jetzt sogar bei 50 MB???

    Mit Wp2.8.1 lief es übrigens noch einwandfrei... *grübel*
     
  11. jottlieb

    jottlieb Well-Known Member
    Ehrenmitglied

    Registriert seit:
    20. August 2005
    Beiträge:
    17.381
    Zustimmungen:
    0
    Kannst du wirklich verfizieren dass dein Blog ohne Sprachdatei 17 MB braucht und mit das 55 MB Limit sprengt?

    Wenn ja, dann äh...muss sich das mal ein Profi angucken :shock:
     
  12. codestyling

    codestyling WPD-Team

    Registriert seit:
    30. März 2008
    Beiträge:
    1.904
    Zustimmungen:
    0
    Wie genau hast du die deutsche Sprachdatei da hinbekommen ?

    Erst kürzlich hatten wir hier das Problem, das jemand Bilder per FTP (PNG's) hochgeladen hatte, die das FTP Programm fälschlicherweise als Text! erkannt hat und Korrekturen an Zeilenumbrüchen gemacht hat.
    Wenn sowas mit der de_DE.mo Datei beim Upload passiert (Datei danach beschädigt!), dann lädt die endlos den Speicher zu bis der Provider Stop sagt.
    Kannst du die Sprachdatei von WP nochmal per FTP im Transfer Modus Binär hochladen ?
    (Es könnte aber auch die Sprachdateien von Plugins erwischt haben).

    Weitere mögliche Gründe sind Fehleinstellungen beim Provider. Bespielsweise ist eine PHP Einstellung zend.ze1_compatibility_mode = On für ein benutztes PHP >= 5.0 tödlich und crashed je nach Provider umgehend das Dashboard.

    Auch ist eine andere Einstellung als mbstring.func_overload = 0 sehr bedenklich und hat u.U. den gleichen Effekt auf die Sprachdateien für WP Versionen 2.8.0 / 2.8.1 wie oben beschrieben.
     
  13. tomatl

    tomatl Well-Known Member

    Registriert seit:
    4. Juni 2006
    Beiträge:
    62
    Zustimmungen:
    0
    Ohne Sprachdatei liefert es mir derzeit: Memory usage: 17.26 MByte.

    Habe versuchsweise die de_DE erneut in die config.php kopiert. Ergebnis:

    Fatal error: Allowed memory size of 52428800 bytes exhausted (tried to allocate 131072 bytes) in /home/.sites/302/site611/web/wp-includes/pomo/mo.php on line 170

    Aber das kann doch nicht sein, dass die 50 MB nur von der deutschen Sprachdatei völlig ausgeschöpft werden???

    Irgendwie kommt mir das ziemlich spanisch vor???

    Aber besten Dank auf alle Fälle für die Antworten!
     
  14. jottlieb

    jottlieb Well-Known Member
    Ehrenmitglied

    Registriert seit:
    20. August 2005
    Beiträge:
    17.381
    Zustimmungen:
    0
    Beachte mal was codestyling fünf Minuten vor deinem Beitrag gesagt hat. Also erster Schritt wäre das erneute Hochladen der Sprachdatei im richtigen Modus.
     
  15. tomatl

    tomatl Well-Known Member

    Registriert seit:
    4. Juni 2006
    Beiträge:
    62
    Zustimmungen:
    0
    YEP, das wars!!! Habe alle Dateien nochmals neu hochgeladen (Binär-Modus). Da hat mir Filzezilla anscheinend einen Streich gespielt. Jetzt funktioniert es. Die Memory Usage hat sich jetzt zwar auf 22,25 MB erhöht, aber nachdem mir mein Provider heute 6 MB kostenlos "spendiert" hat, auch kein Problem... ;)

    Jedenfalls besten Dank nochmal für Eure Tipps Codestyling und Jottlieb!!!
    Henry
     
  16. werderblog

    werderblog Member

    Registriert seit:
    21. Juli 2009
    Beiträge:
    8
    Zustimmungen:
    0
    Hmmm...bei mir hilft das leider nicht weiter. Die Einstellungen sind alle richtig gesetzt und auch ein erneuter Upload im Binär-Mode macht keinen Unterschied.

    Hat noch jemand eine Idee? Nach wie vor verwundern mich die komischen Werte (siehe Post von heute um 9:25).
     
  17. marX

    marX Well-Known Member
    Ehrenmitglied

    Registriert seit:
    5. Oktober 2006
    Beiträge:
    12.943
    Zustimmungen:
    0
    Kannst du die Plugins ausschließen? Dann würde ich nochmal wp-config.php und wp-settings.php durchschauen ob da irgendwo das Memory Limit verändert wird.
     
  18. Suleitec

    Suleitec Well-Known Member

    Registriert seit:
    14. Juli 2009
    Beiträge:
    57
    Zustimmungen:
    0
    Ich habe heute mal einen test gemacht. Habe Wp in der 2.8er Version per Mausklick auf einen Server installiert, also kein Filezilla Problem möglich.
    Standard Theme. Als Plugin nur das Memory Usage Tool zum auslesen.

    Das ganze einmal unter PHP als Teil des Apache und als CGI Modul aufgerufen, beide PHP Info statisch abgespeichert zum vergleichen.

    Dann 3 Plugins installiert und die gleiche Messung notiert.

    Dann habe ich den Account per Umzugsscript von einem Server auf den andren gezogen, dabei werden keien Dateien verändern, alle Rechte, Zeichensätze etc bleiben erhalten zumal gepackt umgezogen wird.

    Auf dem neuen Ziel Server exakt die gleichen Tests gemacht und die Werte notiert. Der Unterschied im Speicherbedarf des WP ´s ohne Plugins lag zwischend en beiden Servern von 19 - 32 MB ! Der Speicherbedarf der Plugins verdoppelte sich. Hier mal die genauen Daten inkl der PHP Info Dateien: http://erst-testen.de Wenns grad nicht erreichbar ist, bin ichs von Server zu Server am ziehen für weitere Tests.
     
  19. jottlieb

    jottlieb Well-Known Member
    Ehrenmitglied

    Registriert seit:
    20. August 2005
    Beiträge:
    17.381
    Zustimmungen:
    0
    Das ist doch schon mal sehr aufschlussreich. Beide Server wo so viel Speicher verbraucht wird haben mindestens PHP 5.2.9-1nmm1 als gemeinsamen nennen.
    Die anderen haben ältere Version. Mein Blog, der auch problemlos auf euren Servern läuft läuft unter PHP 5.2.5

    Nachtrag: Mal einen T-Online Server getestet. Der hat auch PHP 5.2.9 aber nicht diese Probleme.

    Meine phpinfo: http://blog.zeitgrund.de/bla_phpinfo.php
    T-Online phpinfo: http://3zg.de/temp/phpinfo_tonline.htm

    Und wenn ich mir das hier anschaue sieht's auch nicht so aus, als läge es an der PHP-Version.
     
    #19 jottlieb, 22. Juli 2009
    Zuletzt bearbeitet: 22. Juli 2009
  20. Suleitec

    Suleitec Well-Known Member

    Registriert seit:
    14. Juli 2009
    Beiträge:
    57
    Zustimmungen:
    0
    Ich habe vor 2 Tagen einen Kunden-Account mit WP von einem alten PHP 4.4 Server auf den Server 6620 gezogen. Sein Speicherbedarf ging nach seiner Aussage von 17 auf 24 MB hoch (Anlass meines Test-Beginns, da es blöd ist wenn wir den Kunden extra 64 MB geben und das System dann mehr frist als auf den alten Servern).

    Ich habe bei einem anderen Blog, auch auf dem 6620,grade ein automatisches Update von 2.8.1 auf 2.8.2 gemacht. Damit sank der verbrauchte Speicher von 61% auf 54% ... nichts weiter gemacht, nur auto Update des WP selbst.

    Alles seltsam.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden