1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Upgrade auf 2.0.4

Dieses Thema im Forum "Installation" wurde erstellt von tboley, 29. Juli 2006.

  1. tboley

    tboley Well-Known Member

    Registriert seit:
    27. Oktober 2005
    Beiträge:
    1.178
    Zustimmungen:
    0
    Da die entsprechenden Seite im Codex wieder nicht erreichbar sind, hier eine kurze Zusammenfassung, wie ein Upgrade von 2.0.3 auf 2.0.4 zu bewerkstelligen ist - nur die geänderten Dateien / Ordner austauschen:

    Ordner /wp-admin/ komplett aktualisieren

    Plugins /wp-content/plugins/akismet/akismet.php und /wp-content/plugins/wp-db-backup.php mit den neuen Versionen aus 2.0.4 austauschen

    Ordner /wp-includes/ komplett aktualisieren (Sprachdatei vorher sichern und anschließend wiederherstellen!)

    Im Stammverzeichnis gab es Änderungen an folgenden Dateien:

    wp-login.php
    wp-pass.php
    wp-settings.php
    wp-trackback.php
    xmlrpc.php

    Bei den Default-Themes wurden auch Änderungen vogenommen (falls die jemand verwendet).

    Abschließend noch mal eine vollständige Liste aller geänderten Dateien:

    /wp-admin/admin-db.php differ
    /wp-admin/admin-functions.php
    /wp-admin/admin.php
    /wp-admin/categories.php differ
    /wp-admin/edit-comments.php
    /wp-admin/edit-form-advanced.php
    /wp-admin/edit-form-comment.php
    /wp-admin/edit-form.php
    /wp-admin/edit-link-form.php
    /wp-admin/edit-page-form.php
    /wp-admin/edit-pages.php
    /wp-admin/images: box-bg-left.gif
    /wp-admin/images: box-bg-right.gif
    /wp-admin/images: box-butt-left.gif
    /wp-admin/images: box-butt-right.gif
    /wp-admin/images: box-head-left.gif
    /wp-admin/images: box-head-right.gif
    /wp-admin/import/blogger.php
    /wp-admin/import/dotclear.php
    /wp-admin/import/textpattern.php
    /wp-admin/import.php
    /wp-admin/index.php
    /wp-admin/inline-uploading.php
    /wp-admin/link-categories.php
    /wp-admin/link-manager.php
    /wp-admin/moderation.php
    /wp-admin/options.phper
    /wp-admin/plugin-editor.php
    /wp-admin/plugins.php
    /wp-admin/post.php
    /wp-admin/setup-config.php
    /wp-admin/sidebar.php
    /wp-admin/templates.php
    /wp-admin/theme-editor.php
    /wp-admin/themes.php
    /wp-admin/update-links.php
    /wp-admin/upgrade-schema.php
    /wp-admin/upgrade.php
    /wp-admin/user-edit.php
    /wp-admin/users.php
    /wp-admin/wp-admin.css
    /wp-content/plugins/akismet/akismet.php
    /wp-content/plugins/wp-db-backup.php


    /wp-includes/class-snoopy.php
    /wp-includes/classes.php differ
    /wp-includes/comment-functions.php differ
    /wp-includes/default-filters.php differ
    /wp-includes/functions-formatting.php differ
    /wp-includes/functions-post.php differ
    /wp-includes/functions.php differ
    /wp-includes/gettext.php differ
    /wp-includes/kses.php differ
    /wp-includes/pluggable-functions.php
    /wp-includes/streams.php
    /wp-includes/template-functions-author.php
    /wp-includes/template-functions-general.php
    /wp-includes/vars.php
    /wp-includes/version.php
    /wp-includes/wp-db.php

    wp-login.php
    wp-pass.php
    wp-settings.php
    wp-trackback.php
    xmlrpc.php

    Jetzt nur noch /wp-admin/upgrade.php aufrufen, fertig! Jetzt meldet sich WordPress mit Version 2.0.4.
     
    #1 tboley, 29. Juli 2006
    Zuletzt bearbeitet: 29. Juli 2006
  2. SuMu

    SuMu Well-Known Member

    Registriert seit:
    5. Januar 2006
    Beiträge:
    6.090
    Zustimmungen:
    26
    habe ich versucht ,wp 2.03 auf wp 2.04 aktualisiert, es kommt eine Fehlermeldung:

    Warning: main(/home/sumu/public_html/sumu.psychomuell/wp-includes/cache.php) [function.main]: failed to open stream: No such file or directory in /home/sumu/public_html/sumu.psychomuell/wp-settings.php on line 108

    Fatal error: main() [function.require]: Failed opening required '/home/sumu/public_html/sumu.psychomuell/wp-includes/cache.php' (include_path='.:/usr/share/php') in /home/sumu/public_html/sumu.psychomuell/wp-settings.php on line 108

    kann mir da jemand helfen?
     
  3. killercup

    killercup Well-Known Member

    Registriert seit:
    25. Februar 2006
    Beiträge:
    230
    Zustimmungen:
    0
    überschreib deine wp-settings nochmal.
     
  4. SuMu

    SuMu Well-Known Member

    Registriert seit:
    5. Januar 2006
    Beiträge:
    6.090
    Zustimmungen:
    26
    habe ich gemacht, geht leider noch nicht...:(
     
  5. jottlieb

    jottlieb Well-Known Member
    Ehrenmitglied

    Registriert seit:
    20. August 2005
    Beiträge:
    17.381
    Zustimmungen:
    0
    Dann schmeiß einfach alle Dateien hoch außer dem Ordner wp-content.
     
  6. SuMu

    SuMu Well-Known Member

    Registriert seit:
    5. Januar 2006
    Beiträge:
    6.090
    Zustimmungen:
    26
    habe ich gemacht:
    Fehlermeldung:

    Fatal error: Only variables can be passed by reference in /home/sumu/public_html/sumu.psychomuell/wp-includes/gettext.php on line 66

    jetzt bleibe ich erst mal bei 2.03
     
  7. Ferdinand

    Ferdinand Well-Known Member

    Registriert seit:
    25. Juni 2006
    Beiträge:
    308
    Zustimmungen:
    0
    tboley,

    danke für die Liste.
    Alles glatt gegangen.

    :cool:
     
  8. Monika

    Monika Well-Known Member
    Ehrenmitglied

    Registriert seit:
    4. Juni 2005
    Beiträge:
    14.126
    Zustimmungen:
    2
    ich habe sowohl anhand der Liste
    Merci dafür
    wie auch mit der Vollversion mehr als etliche Updates heute Abend hinter mir,

    meine eigenen Seiten fehlen noch -wie meist.
    ich wünsch mir einfach bei den Plugins eine Liste wo ich anhaken kann und alle auf einmal sind aktiviert oder deaktiviert,

    dies ist das einzig nervende ...
    Plugins deaktivieren,
    Plugins aktivieren

    ;)

    lg
     
  9. Ilona

    Ilona Well-Known Member

    Registriert seit:
    17. November 2005
    Beiträge:
    84
    Zustimmungen:
    0
    Genau! Das nervt wirklich. Das wäre noch ne gute Verbesserung, wenn das beim Upgrade automatisiert werden könnte.

    Incl. der Einstellungen, die man bei manchen Plugins nach dem Upgrade wieder machen muss.

    Aber jetzt habe ich es mal wieder hinter mir. Hat alles prima geklappt.

    Danke auch für die nette Bereitstellung!

    Gruß
    Ilona
     
  10. caschy

    caschy Well-Known Member

    Registriert seit:
    17. März 2006
    Beiträge:
    108
    Zustimmungen:
    0
    Danke tboley - hat alles reibungslos funktioniert - ohne vorheriges Plugin deaktivieren.
     
  11. SuMu

    SuMu Well-Known Member

    Registriert seit:
    5. Januar 2006
    Beiträge:
    6.090
    Zustimmungen:
    26
    ich habe es jetzt 4 mal versucht, von WP 2.03 auf WP 2.04 zu updaten!
    ich bekomme nur unterschiedliche Fehlermeldungen... :((
    Ich werde wohl mein Blog demnächst neu installieren...
     
  12. dasralph

    dasralph New Member

    Registriert seit:
    16. Mai 2006
    Beiträge:
    4
    Zustimmungen:
    0
    Hallo!


    Laut der Ankündigung auf wordpress.org wurden einige Sicherheitslücken beseitigt und 50 Fehler berichtigt.
    Gibt es eine Übersicht, um welche es genau geht, also eine art release notes?


    Danke! Ralph
     
  13. ! 4rtist.com#───█

    ! 4rtist.com#───█ Well-Known Member

    Registriert seit:
    27. November 2005
    Beiträge:
    181
    Zustimmungen:
    0
    habe mich dem Versuch angeschlossen , ohne deaktivierte plugins upzugraden , ging ohne probleme
    auch dan die datei db-backup.php habe ich nicht ausgetauscht
     
    #13 ! 4rtist.com#───█, 30. Juli 2006
    Zuletzt bearbeitet: 30. Juli 2006
  14. Monika

    Monika Well-Known Member
    Ehrenmitglied

    Registriert seit:
    4. Juni 2005
    Beiträge:
    14.126
    Zustimmungen:
    2
    1.welche Fehlermeldungen
    2. alle Plugins deaktiviert
    3. erzähle mehr ,

    lg
     
  15. Einstein

    Einstein Well-Known Member

    Registriert seit:
    4. April 2006
    Beiträge:
    76
    Zustimmungen:
    0
    Überprüfe mal die Freigabe der wp-includes denn die Fehlermeldungen die du hast lassen vermuten das man nicht auf den Ordner zugreifen kann bzw. auf die dort gemeldeten Dateien.
     
  16. SpuTniQ

    SpuTniQ Well-Known Member

    Registriert seit:
    21. März 2006
    Beiträge:
    49
    Zustimmungen:
    0
    Danke Tboley!

    Hat wunderbar funktioniert... :lol:
     
  17. macman

    macman New Member

    Registriert seit:
    31. Juli 2006
    Beiträge:
    3
    Zustimmungen:
    0
    Das Upgrade, wie im ersten Post beschrieben, hat auch bei mir perfekt geklappt. All das sogar ohne deaktivierung meiner Plugins.

    Vielen Dank!
     
  18. tboley

    tboley Well-Known Member

    Registriert seit:
    27. Oktober 2005
    Beiträge:
    1.178
    Zustimmungen:
    0
    Für die Macnutzer, die mit Safari bloggen, habe ich die Datei admin-functions.php nach dieser Anleitung so angepasst, dass die Quicktag-Buttons nach dem Upgrade wieder funktionieren:
     
  19. matze1308

    matze1308 Member

    Registriert seit:
    24. Juli 2006
    Beiträge:
    13
    Zustimmungen:
    0
    hat sich eigentlich was am design der admin-seiten geändert? ich hoffe nicht, denn sonst hat irgendwas nicht geklappt. ;)
     
  20. jottlieb

    jottlieb Well-Known Member
    Ehrenmitglied

    Registriert seit:
    20. August 2005
    Beiträge:
    17.381
    Zustimmungen:
    0
    Nö da blieb alles beim alten.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden