1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

url bei google nicht indexierbar Fehler ( 401) unautorisierte Anforderung

Dieses Thema im Forum "Installation" wurde erstellt von mich_82, 5. Mai 2021.

  1. mich_82

    mich_82 Member

    Registriert seit:
    24. November 2020
    Beiträge:
    11
    Zustimmungen:
    0
    Hallo zusammen,
    Ich bin nicht ganz sicher ob mein Fehler hier reingehört oder gar nichts mit Wordpress zu tun hat... falls nicht tut es mir leid, vielleicht hat ja trotzdem jemand einen Tipp für mich...

    Ich benutze WP 5.7.1
    Woo Commerce + Germanized und ein paar weitere Plugins
    Top Shop Theme

    Meine Url : pferdeanhänger-mieten.at
    meine Sitemap: https://www.pferdeanhänger-mieten.at/wp-sitemap.xml - wird von Yoast umgeleitet

    Nun zu meinem Problem: ( siehe Bild2)
    Google Search Console sagt mir bei der Live Prüfung der Url
    "Fehler wegen nicht autorisierter Anforderung ( 401) " blockiert
    und beim einreichen der Sitemap:
    "konnte nicht abgerufen werden"

    diese Fehler treten auf egal ob ich die Url mit oder ohne Umlaute schreibe( xn--pferdeanhnger-mieten-jzb.at)

    - soweit ich das rausfinden konnte, kommt dieser Fehler meistens bei Seiten mit Login / Passwörtern oder ähnlichem..... Das gibt es bei mir nicht....
    Ich habe auch schon alle Plugins deaktiviert - der Fehler bleibt bestehen

    Ich habe bei meinem Server auch noch folgenden Error gefunden - siehe Bild 1

    Den Hoster ( World4you) habe ich schon angeschrieben- vor 5 Werktagen, nachdem ich aber noch keine Antwort bekommen habe, hoffe ich auf Hilfe von euch ;o)
    Vielen Dank Michaela bild2.png BIld1.png
     
  2. Henk1060

    Henk1060 Well-Known Member

    Registriert seit:
    4. September 2014
    Beiträge:
    3.863
    Zustimmungen:
    336
    am screenshot sehe ich dir url ohne ssl
    trage die url mit https:// ein
     
  3. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    10.594
    Zustimmungen:
    1.499
    Die Google Search Console hat recht, der Server antwortet derzeit offenbar bei bestimmten Bedingungen des abrufenden Clients/Browsers und/oder bei bestimmte IP-Bereichen mit einem HTTP Status 401 Unauthorized, prüfbar z.B. hier:
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Mögliche Ansätze:
    • alle ggf. vorhandenen Sicherheits-Plugins deaktivieren
    • die .htaccess Datei auf manuelle Sperreinträge oder Reste von Sicherheits-Plugins prüfen
    • beim Hostinganbieter hinterfragen, ob dort irgendwelche Sicherheitsfunktionen aktiv sind
    Mit WordPress hat es vermutlich nichts zu tun, da der Effekt alle möglichen Aufrufe auch ausserhalb von WordPress betrifft.
     
  4. mich_82

    mich_82 Member

    Registriert seit:
    24. November 2020
    Beiträge:
    11
    Zustimmungen:
    0
    @Henk1060 vielen Dank- aber das passiert trotz https....
    @b3317133 Danke - Sicherheitsplugins sind eigentlich keine drauf, es gab nur ein Captcha Code plugin ( war vorinstalliert auf Wp) das hab ich deaktiviert, weil es folgenden Fehler aufwirft " Eine PHP-Sitzung wurde durch einen session_start()-Funktionsaufruf erzeugt. Dies beeinträchtigt die REST-API- und Loopback-Anfragen. Die Sitzung sollte von session_write_close() geschlossen werden, bevor irgendwelche HTTP-Anfragen erfolgen."
    Beim Hostinganbieter hab ich eh schon vor ein paar Tagen angefragt- dann werde ich wohl auf die Antwort warten müssen...
    weil so richtig in den Dateien herumpfuschen will ich nicht- davon versteh ich definitiv zu wenig ;)
     
  5. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    10.594
    Zustimmungen:
    1.499
    Es sieht so aus, als wäre derzeit mindestens ein Sicherheitsplugin aktiv, Disable REST API, das dürfte vermutlich nichts mit dem Problem zu tun haben, lässt aber darauf schliessen, dass ggf. noch andere ähnliche Plugins laufen oder sonstige Basteleien vorhanden sein könnten, daher die Hinweise.
     
  6. mich_82

    mich_82 Member

    Registriert seit:
    24. November 2020
    Beiträge:
    11
    Zustimmungen:
    0
    oh erwischt ;) - mir war nicht klar dass das ein Sicherheitsplugin ist... jetzt komm ich mir so ahnungslos vor wie ich wahrscheinlich bin.... falls ich es mit dem Hoster nicht lösen kann, darf ich dich dann anschreiben bezüglich einer bezahlten Lösung oder müsste ich das extra in die Jobbörse stellen ?
     
  7. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    10.594
    Zustimmungen:
    1.499
    Poste ein Hilfegesuch in die Jobbörse, dann kannst Du entspr. Angebote bekommen.
     
    mich_82 gefällt das.
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden