1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Von lokal auf Server - Seite wird nicht aufgerufen (403 forbidden ...)

Dieses Thema im Forum "Installation" wurde erstellt von Richterprodukt, 8. September 2013.

Schlagworte:
  1. Richterprodukt

    Richterprodukt Well-Known Member

    Registriert seit:
    26. Januar 2013
    Beiträge:
    51
    Zustimmungen:
    0
    Hallo!

    Ich wollte heute mein XAMPP-Setup auf meinen Server stellen und bin haargenau nach dieser Anleitung vorgegangen. Also DB exportiert, SQL bearbeitet und "http://localhost/domainname/" mit "http://www.domainname.de/" ersetzt (wirklich mit slashs am Ende?). Dann wp-config.php bearbeitet, db-Daten von der Server-Datenbank eingetragen, MySQL-Serveradresse auf "localhost" belassen (ist angeblich bei Alfahosting so).

    Unter "htdocs" im Xampp-Ordner liegt mein WP-Setup in einem Ordner, der den Namen der Domain hat (hier "domainname"). Diesen Ordner habe ich komplett auf meinen Server gezogen. Und zwar in den Ordner "html". Dann über Server-phpMyAdmin die modifizierte DB importiert.

    Rufe ich dann jedoch die Domain auf, erscheint das Alfahosting-Bild "Domain ist registriert worden blabla". Keine Spur von meiner Seite. Im Confixx-Menü habe ich's dann mal mit der Einrichtung von Weiterleitungen probiert, weil ich dachte, vielleicht muss die Domain auf den Unterordner "domainname" verweisen. Siehe Bild. Nützt aber auch nix. Es kommt dann nicht mehr das Alfahosting-Bild, sondern "403 forbidden - You don't have permission to access / on this server. Apache Server at www.domainname.de Port 80"

    Nächster Versuch: Alle Inhalte aus "html/domainname" rübergeschoben in "html". Gleiches Ergebnis. :/

    Okay, was kann ich tun? Bestimmt nur ein dummer kleiner Anfängerfehler.

    Gruß
    rp
     

    Anhänge:

  2. Richterprodukt

    Richterprodukt Well-Known Member

    Registriert seit:
    26. Januar 2013
    Beiträge:
    51
    Zustimmungen:
    0
    Verzweiflung! :/
    Kann es vielleicht sein, dass ich die Wordpress-Dateien erst auf den Server schieben sollte, wenn ich folgendes vorher gemacht habe? Wordpress - Einstellungen allgemein - Wordpress Adresse (URL): ändern von "http://localhost/domainname" in "http://www.domainname.de" und ändern von Seiten Adresse (URL) in "http://www.domainname.de"? Das jedoch stand nicht im Tutorial.

    plz hlp!

    In der htaccess steht übrigens folgendes:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /domainname/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /domainname/index.php [L]
    </IfModule>


    # END WordPress
     
    #2 Richterprodukt, 8. September 2013
    Zuletzt bearbeitet: 8. September 2013
  3. Melewo

    Melewo Well-Known Member

    Registriert seit:
    8. Juli 2013
    Beiträge:
    3.097
    Zustimmungen:
    0
    Wie umfangreich ist denn Deine DB unter Localhost bereits?
    Kommst Du nicht viel schneller weg, wenn Du WP in 5 Minuten im Web einrichtest und erst danach die drei Testartikel von Localhost übernimmst, falls es noch nicht mehr sein sollten?
    Was Du dann unter Localhost an Dateien bearbeitest, brauchst Du nur noch per FTP hochladen.
     
  4. Richterprodukt

    Richterprodukt Well-Known Member

    Registriert seit:
    26. Januar 2013
    Beiträge:
    51
    Zustimmungen:
    0
    Da ist schon Einiges mehr an komplexen Artikeln drin. Und Bildergalerien, etc. etc.. Wäre ein viel zu großer Aufwand.
     
  5. Appendix

    Appendix Well-Known Member

    Registriert seit:
    22. August 2013
    Beiträge:
    199
    Zustimmungen:
    0
    Liegt in dem html Ordner zufällig eine "index.htm" oder "index.html" ? Wenn ja, löschen.
    Anschließend deine Seite neu aufrufen/aktualisieren mit F5 oder STRG + F5.
     
  6. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.965
    Zustimmungen:
    8
    Schau mal, ob eine index.html oder index.htm vorhanden ist und lösche diese.
     
  7. Richterprodukt

    Richterprodukt Well-Known Member

    Registriert seit:
    26. Januar 2013
    Beiträge:
    51
    Zustimmungen:
    0
    Ja, da war eine. Gelöscht. Aber das Problem ist offenbar eins vom Server. Ich kann nicht mal ein .jpg aus "html" oder "html/domainname" aufrufen. 403 - forbidden. WTF?!

    EDIT: mod_rewrite war offenbar serverseitig OFF. Habe ich mal aktiviert. Mal gucken, was gleich passiert ...
     
    #7 Richterprodukt, 8. September 2013
    Zuletzt bearbeitet: 8. September 2013
  8. Appendix

    Appendix Well-Known Member

    Registriert seit:
    22. August 2013
    Beiträge:
    199
    Zustimmungen:
    0
    Es besteht natürlich auch die Möglichkeit, dass eine fehlerhafte Konfiguration des Servers vorliegt, wenn du nicht mal ein Bild aufrufen kannst. Kannst ja den Support mal bitten sich das anzugucken.

    Vorher abe rmal die .htaccess löschen und nochmal mit dem Bild probieren, vielleicht hast du da auch irgend einen Mist drin stehen, kannst sie ja mal hier posten.
     
  9. Richterprodukt

    Richterprodukt Well-Known Member

    Registriert seit:
    26. Januar 2013
    Beiträge:
    51
    Zustimmungen:
    0
    So, mittlerweile bin ich mit 5 Millionen Megawatt geladen! :twisted: Danke an alle Tutorials-Schreiber, die behaupten "lokales Setup moven ist GAR KEIN PROBLEM!". Von wegen!

    Ich habe den Support kontaktiert. Ausführliche Antworten bekommen. Zunächst mod_rewrite in den Server-Settings aktiviert. Und eine Index.html gelöscht. Seite aufgerufen - juhu, Login-Fenster (habe ein Login vorgeschaltet). Keine Bilder werden geladen. Login ging auch nicht, bzw. führte ins Leere (Details vergessen). Dann nochmal Support kontaktiert. Ich soll im Confixx Weiterleitungen für die Domain auf den Unterordner führen lassen. Gemacht. Und siehe da: Seite geht auf. ABER mit einem KOMPLETT anderen Aussehen! Logo nicht drin, Beiträge werden ganz anders dargestellt, Beiträge fehlen (teilweise sind aber welche da) und all die Custom Settings, die ich vorher im Theme-Editor lokal gemacht hatte, wo auch alles wunderbar lief, sind online nun einfach weg. Mehr noch: Jetzt werden die URLs wegen der Weiterleitung so angezeigt: www.domainname.de/domainname. Das ist natürlich Mist. Also habe ich jetzt den kompletten WP-Ordner auf dem Server ins Hauptverzeichnis ("html") verschoben und die htaccess wieder angepasst, Weiterleitungen gekillt. Tadaaaa: 500 - internal server error. Hey, super!
     
  10. Richterprodukt

    Richterprodukt Well-Known Member

    Registriert seit:
    26. Januar 2013
    Beiträge:
    51
    Zustimmungen:
    0
    In mein XAMPP-Setup komme ich jetzt auch nicht mehr, weil ich zuletzt die Seiten-URLs in den WordPress-Settings auf www.domainname.de gestellt habe. :( Ähm, wie komme ich zurück ins local Wordpress?
     
  11. Appendix

    Appendix Well-Known Member

    Registriert seit:
    22. August 2013
    Beiträge:
    199
    Zustimmungen:
    0
    In dem du die URL Settings wieder umstellst ;)

    Einen 500er bekommt man nicht einfach so, sondern weil etwas falsch ist. zu 99% hat der vor dem Bildschirm etwas falsch gemacht, also nicht aufregen, kurz beruhigen, und alles noch mal in Ruhe kontrollieren...
     
  12. Richterprodukt

    Richterprodukt Well-Known Member

    Registriert seit:
    26. Januar 2013
    Beiträge:
    51
    Zustimmungen:
    0
    Die URL-Settings (lokal) kann ich aber nicht einfach übers WordPress-Backend umstellen, weil ich dort nicht mehr reinkomme. :(
     
  13. Appendix

    Appendix Well-Known Member

    Registriert seit:
    22. August 2013
    Beiträge:
    199
    Zustimmungen:
    0
  14. Richterprodukt

    Richterprodukt Well-Known Member

    Registriert seit:
    26. Januar 2013
    Beiträge:
    51
    Zustimmungen:
    0
    Okay. Beide Werte auf "localhost/domainname" geändert. Rufe ich jetzt die lokale URL auf (localhost/domainname) öffnet er das XAMPP-Fenster unter "localhost/xampp". Irgendwo ist noch ein kleiner Wurm drin. Mir würde es ja erstmal reichen, wenn ich das lokale Setup so erreichen könnte, wie vorher.

    EDIT: Also, ich werde nun auf localhost/xampp umgeleitet und es öffnet sich im Browser das XAMPP-Menü. Gebe ich localhost/domainname/wp-login.php kommt das login-fenster, ich kann mich einloggen, lande dann jedoch wieder im XAMPP-Fenster. Gebe ich beispielhaft localhost/domainname/wp-config.php ein, bleibt das Fenster weiß.
     
    #14 Richterprodukt, 8. September 2013
    Zuletzt bearbeitet: 8. September 2013
  15. Appendix

    Appendix Well-Known Member

    Registriert seit:
    22. August 2013
    Beiträge:
    199
    Zustimmungen:
    0
    Sicher, dass alle WP Dateien in dem Ordner noch vorhanden sind?
    Ist in dem Ordner eine index.htm/html ? Löschen...
     
  16. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.965
    Zustimmungen:
    8
  17. Richterprodukt

    Richterprodukt Well-Known Member

    Registriert seit:
    26. Januar 2013
    Beiträge:
    51
    Zustimmungen:
    0
    Ja, alles da. Habe im lokalen Setup nichts gelöscht. Ich habe jetzt sicherheitshalber nochmal das Backup des WP-Ordners von gestern Abend rüberkopiert. Nun kommt der Login-Screen. Ich log mich ein, Seite öffnet sich. Logo, Werbebanner, alles da. Auch Beiträge werden angezeigt. Aber ganz oben steht "Seite nicht auffindbar" und die Inhalte der Beiträge werden nicht angezeigt. Auch wenn ich einen Beitrag anklicke kommt die Meldung. D.h. es stimmt noch was mit den Permalinks nicht?
    Ach, und besonders viel Angst macht es mir jetzt, wie das WordPress-Backend lokal nun aussieht. Wenn ich mir jetzt das lokale Setup auch noch zerschossen habe - aus welchen Gründen auch immer - kann ich mir die Kugel geben. 5 Wochen Arbeit umsonst.
    Siehe Bild:
     

    Anhänge:

  18. Appendix

    Appendix Well-Known Member

    Registriert seit:
    22. August 2013
    Beiträge:
    199
    Zustimmungen:
    0
    Da findet er wohl keine Styledaten. Da stimmen einige Pfade wohl nicht...
    Ich schreib dir mal eben eine PN... vielleicht kann ich dir noch anders helfen.
     
  19. Richterprodukt

    Richterprodukt Well-Known Member

    Registriert seit:
    26. Januar 2013
    Beiträge:
    51
    Zustimmungen:
    0
    Kam meine PN an, Appendix? Irgendwie zeigt er mir nix im Ausgang an. Hm.

    Hab mal Search & Replace auf der Online-Version laufen lassen. Er findet "localhost/domainname" 2 x in den wp_options, 26 x in wp_postmeta und 68 x in wp_posts. Soll ich jetzt alles mit "www.domainname.de" oder mit "www.domainname.de/domainname" ersetzen?
     
  20. Appendix

    Appendix Well-Known Member

    Registriert seit:
    22. August 2013
    Beiträge:
    199
    Zustimmungen:
    0
    Ja kam an.

    Je nachdem wo deine WP Installation nun liegt... Wenn sie in dem Unterordner "/domainname" liegt, dann muss das mit rein, ansonsten halt ohne.

    Tu dir bitte selbst einen Gefallen, und mach immer ein Backup vor solchen Änderungen.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden