1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Vorschaubilder "Groß" verschwinden immer wieder.

Dieses Thema im Forum "Allgemeines" wurde erstellt von Andreas Franke, 10. Juli 2019.

  1. Andreas Franke

    Andreas Franke New Member

    Registriert seit:
    8. Juli 2019
    Beiträge:
    3
    Zustimmungen:
    0
    Hallo liebe Leute.
    Ich habe auf meiner Seite ein echtes Problem, dass ich nicht lösen kann. Von den von Wordpress generierten Vorschaubildern verschwinden bei mir immer wieder die der Größe "Large" und zwar wirklich, will sagen sie verschwinden nach kurzer Zeit (innerhalb weniger Minuten) aus dem Filesystem!

    Direkt nach dem Upload "large" = 800x600:

    filezilla_2019-07-08_11-41-35.png

    Nach 3 - 4 Minuten "large" = 800x600:

    filezilla_2019-07-08_11-45-53.png

    Beim Upload werden alle Größen korrekt erzeugt. Das ganze führt dazu, dass alle meine Beiträge immer wieder ohne Bilder dargestellt werden, besonders ärgerlich bei größeren Wordpress-Galerien.

    2019-07-08_12-07-28.jpg

    Ich wäre für jeden Tipp dankbar, denn ich verzweifle langsam aber sicher.

    Vielen Dank im Voraus
     
    #1 Andreas Franke, 10. Juli 2019
    Zuletzt bearbeitet: 10. Juli 2019
  2. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    6.384
    Zustimmungen:
    573
    Deaktiviere alle Cache- und CDN- und sonstige "Optimierungs"-Plugins. Falls es dann weiterhin passiert, welche genauen Plugins laufen noch?

    Die im Screenshot der FTP-Liste "verschwundene" Datei /wp-content/uploads/2018/07/001-GALERIE-TEST-1-800x600.jpg scheint allerdings derzeit auf dem Server zu existieren und ist abrufbar.
     
  3. Andreas Franke

    Andreas Franke New Member

    Registriert seit:
    8. Juli 2019
    Beiträge:
    3
    Zustimmungen:
    0
    Vielen Dank für deine Antwort B3317133
    CDN habe ich bereits abgeschaltet, Cache-Plugin schalte ich jetzt testweise ebenfalls mal ab.
    Eine Liste der Plugins habe ich hier.

    Ja ich habe gerade alle Vorschauen regenerieren lassen. Das wird allerdings nicht lange vorhalten und das Bild wird wieder verschwinden.
     
  4. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    6.384
    Zustimmungen:
    573
    Als erstes würde man ja vermuten, dass bei Veränderungen bei Bildern dieses Image Optimizer Plugin verantwortlich sein könnte...

    Viele Plugins, wie auch z.B. Jetpack, werden oft ohne jegliches Lesen von Anleitungen usw. verwendet, und das führt dann zu irgendwelchen "überraschenden" Effekten.

    Am Rande, Betasoftware wie das Gutenberg Plugin sollte man nicht auf einer Liveseite verwenden, der Gutenberg Editor in der "stable" Version (also wenn man Gutenberg sehr wohlwollend irgendwie überhaupt als "stable" bezeichnen möchte) ist ohnehin in WordPress 5.2.2 enthalten.
     
    #4 b3317133, 10. Juli 2019
    Zuletzt bearbeitet: 10. Juli 2019
  5. Andreas Franke

    Andreas Franke New Member

    Registriert seit:
    8. Juli 2019
    Beiträge:
    3
    Zustimmungen:
    0
    Die Vermutung lag nahe, aber das passierte schon vor der Installation des Image-Optimizer-Plugins. Ich hatte es auch schon entsprechend entfernt. Das ändert nichts.

    Jetpack hatte ich ebenfalls schon entfernt ohne Erfolg und ich habe die Anleitung gelesen. Ich verwende es auch auf 2 anderen WP-Installationen in identischer Konfiguration ohne Probleme. Hauptsächlich nutze ich es um alle Plugins in meinen Installationen automatisch auf dem aktuellsten Stand zu halten.

    Ja da gebe ich dir absolut recht. Allerdings ist das Gutenberg-Plugin nirgends als "Beta" gekennzeichnet, so dass ich davon ausgegangen bin, dass es sich um die aktuellste stabile Version handelt. Wenn man das Gutenberg Plugin entfernt, dann funktioniert die "mitgelieferte" Gutenberg-Version nicht mehr einwandfrei.
     
  6. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    6.384
    Zustimmungen:
    573
    In der von Dir geposteten Plugin Liste ist das Optimize Plugin aktiv. Im Forum des Plugins wird von ähnlichen Fällen berichtet. Die Anleitung des Plugins spricht von automatischen Abläufen im Hintergrund.

    Was hat der Plugin Support auf Deine Anfrage nach Zusendung des Logs geantwortet?

    Wenn das mit WordPress 5.2.2 mitgelieferte Gutenberg nicht funktioniert, wende Dich am besten an den Gutenberg Support, die Entwickler lesen hier im Forum nicht mit. Die Pluginversion von Gutenberg ist eine ständig angepasste Arbeitsversion (zuletzt z.B. vor wenigen Stunden) die man vor dem nächsten Release von WordPress testen kann.

    Um alleine Plugins auf dem neusten Stand zu halten, ist Jetpack ein absoluter Overkill, es genügt eine Zeile Code.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden