1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

W.P. 3.5: Mediathek zeigt keine Bilder an // Fehlermeldung beim Bilderupload

Dieses Thema im Forum "Installation" wurde erstellt von 2stern, 27. Dezember 2012.

  1. fuhrmara

    fuhrmara Well-Known Member

    Registriert seit:
    15. Januar 2009
    Beiträge:
    275
    Zustimmungen:
    0
    Also ich habs mit dem neuen 2012 Theme versucht, alle Plugins deinstalliert.
    Leider gleiches Problem.
     
  2. Internett

    Internett New Member

    Registriert seit:
    4. Januar 2013
    Beiträge:
    4
    Zustimmungen:
    0
    Habe mir einen jungfräulichen Testblog angelegt.
    Keine Plugins, Theme 2012, WP 3.5.
    Unterschiedliche Bildergrössen hochgeladen.
    Keine Probleme mit dem Internet Explorer.
     
  3. joso

    joso New Member

    Registriert seit:
    7. Januar 2013
    Beiträge:
    1
    Zustimmungen:
    0
    Hi alle

    Also, ich habe entdeckt, dass das neue Update 3.5 eine Datei .htaccess im uploads Verzeichnis anlegt, das habe ich wieder gelöscht und schon waren die Bilder wieder wie in der alten Version gewohnt zu sehen. Der Inhalt der htaccess Datei war sowieso unsinnig/unvollständig.
    Vielleicht hilft es Euch ja irgendwie.
    ciao
    Jonas
     
  4. fuhrmara

    fuhrmara Well-Known Member

    Registriert seit:
    15. Januar 2009
    Beiträge:
    275
    Zustimmungen:
    0
    Also die gibt es eigentlich schon immer. Da werden die Rewrite Rules definiert.
     
  5. Internett

    Internett New Member

    Registriert seit:
    4. Januar 2013
    Beiträge:
    4
    Zustimmungen:
    0
    @joso

    Das Löschen der .htaccess hat bei mir das Problem mit dem IE wirklich gelöst. Bei mir waren aber nur 2 Zeilen drin: Begin Wordpress und End Wordpress.
     
  6. opolio

    opolio Well-Known Member

    Registriert seit:
    20. Februar 2006
    Beiträge:
    59
    Zustimmungen:
    0
    Hi, ich habe die .htaccess gelöscht, aber auch das half nichts. Wenn ich den Dialog beim Artikel erstellen öffne, dann sehe ich auch kein Bild der Mediathek.

    Liegt es an Wordpress 3.5?
     
  7. Reo

    Reo New Member

    Registriert seit:
    10. Januar 2013
    Beiträge:
    4
    Zustimmungen:
    0
    Es liegt an WP 3.5 und wohl an inkompatiblen Erweiterungen

    Liegt es an Wordpress 3.5?[/QUOTE]

    Wir haben auf Polizei24.ch das gleiche Problem. Dort laufen viele Erweiterungen (plugins) und bei SchweizBlog.ch tritt es nicht auf, dort laufen weniger Erweiterungen.

    Ich glaub daher auch, daß es mit den "plugins" zusammenhängt.

    Aber soetwas hab ich noch bei keiner einzigen WP-Aktualisierung gehabt. Es gibt soviele Probleme und auch massive Verschlechterungen, daß ich sehr traurig bin darüber: http://chamaeleonmedia.ch/?p=98
     
  8. infected

    infected Well-Known Member

    Registriert seit:
    9. Juli 2006
    Beiträge:
    9.816
    Zustimmungen:
    1
    Wie ihr selbst schon herausgefunden habt, liegt es zum Großteil an den Plugins oder Themes. Und wenn die jeweiligen Autoren ihre Projekte nicht aktualisieren, dann ist das nicht die Schuld der WP Entwickler. Wendet Euch doch einfach mal mit den Problemen an die Plugin-/Themeautoren, diese müssen nachbessern. Die Grundsoftware, also WordPress selbst, läuft ohne diese externen Erweiterungen nämlich weitestgehend problemlos.

    Na was erwartest Du bei einem größeren Versionssprung? Sollen die WP-Entwickler vorab alle 23.000 Plugins auf ihre Kompatibilität hin überprüfen und warten bis alle Autoren ihren Code angepasst haben? Wenn sie das machen würden, dann wären wir heute noch bei WP 1.5.
     
  9. 10toe

    10toe New Member

    Registriert seit:
    28. Dezember 2012
    Beiträge:
    4
    Zustimmungen:
    0
    Geschafft! Ich habe das Problem gefunden!

    Bei mir war es tatsächlich das PHP-Memory-Limit. Alle Tipps mit Änderungen der wp-config.php brachten leider nichts, weil es von Host-Seite zu niedrig eingestellt war. Jetzt, wo ich herausgefunden habe, wie man das Memory-Limit auf der Administrationsseite der Domain erhöht, schnurrt wordpress wieder! :)

    Viele Grüße!
    10toe
     
  10. Reo

    Reo New Member

    Registriert seit:
    10. Januar 2013
    Beiträge:
    4
    Zustimmungen:
    0
    Zitat: "Und wenn die jeweiligen Autoren ihre Projekte nicht aktualisieren, dann ist das nicht die Schuld der WP-Entwickler."

    Antwort: Dann müßte das ja bei jeder WP-Aktualisierung so laufen. Nach dem, was ich jetzt erlebt hab, werd ich - und werden sicher viele andere auch extrem zurückhaltend sein bei neuen WP-Installationen. Einmal abgesehen davon, daß die neue Bildhochlade-Funktion jetzt viel langsamer ist und darüberhinaus auch ohne die neue Langsamkeit des WP viel mehr Arbeitsschritte braucht und extrem umständlich geworden ist. Finde ich extrem schade. Dieser "größere" Versionssprung ist für mich wie eine Rolle rückwärts, Entschuldigung.

    Für alle, die - aus welchen Gründen auch immer - Probleme mit dem Bild-Hochladen haben, eine vielleicht hilfreiche Anregung. Das Bild-einfügen in Beiträge geht über den Umweg, "Bild von URL einfügen". Obwohl ich gerade jede Erweiterung ("plugin") nach und nach deinstalliere und wieder aktiviere, um herauszufinden, welche Erweiterung möglicherweise mit dem "größeren Versionssprung" nicht klarkommt, konnte ich über diesen Weg Bilder hochladen. Dazu muß das Bild natürlich auf einer anderen Webseite schon sein wie hier auf Rhätische-Zeitung.ch, was natürlich nicht immer der Fall ist, aber als Notlösung sicher dem ein oder anderen helfen kann, bis er das eigentliche Problem (Thema oder Erweiterung vermutlich) lösen konnte: http://polizei24.ch/trimmis-leichtverletzte-lenkerin-nach-unfall-auf-der-a13/
     
  11. opolio

    opolio Well-Known Member

    Registriert seit:
    20. Februar 2006
    Beiträge:
    59
    Zustimmungen:
    0
    Hi, bei mir lag es am Theme. Habe nach langem Suchen auch eine Lösung gefunden.

    Wer auch Minimatica nutzt, dem empfehle ich folgendes.


     
  12. fuhrmara

    fuhrmara Well-Known Member

    Registriert seit:
    15. Januar 2009
    Beiträge:
    275
    Zustimmungen:
    0
    Also an das Memory_Limit Problem glaube ich eigentlich nicht mehr.
    Habe die Images nun auf 1024*768 reduziert und erhalte trotzdem den gleichen Fehler.
     
  13. 10toe

    10toe New Member

    Registriert seit:
    28. Dezember 2012
    Beiträge:
    4
    Zustimmungen:
    0
    Dennoch solltest Du es versuchen. Mit Hilfe von codestylings Plugin "WP System Health" konnte ich feststellen, dass ich, egal was ich in die wp-config.php eintrage, immer ein php-memory-limit von 64MB hatte. Damit blieben effektiv ca. 32MB übrig, was für die Media-Manager-Vorgänge (selbst beim Hochladen kleinerer Bilder) offenbar zu wenig war.

    Jetzt habe ich das Limit vom Host aus auf Maximal stellen lassen (256MB), und es läuft super!

    Viele Grüße!
    10toe
     
  14. Freerk

    Freerk New Member

    Registriert seit:
    15. Januar 2013
    Beiträge:
    1
    Zustimmungen:
    0
    Geheiligt seist Du, OPOLIO!
    Vielen Dank, bei mir läuft jetzt auch alles wieder.
     
  15. snoofox

    snoofox Member

    Registriert seit:
    27. Januar 2009
    Beiträge:
    6
    Zustimmungen:
    0
    Hallo, ich frage noch mal nach dem Ansatz der .htaccess im uploads-Verzeichnis. Bei mir hat sich das (ursprünglich diskutierte) Problem ergeben, dass die Bilddateien in uploads zwar da sind, aber weder auf der Site noch in der Mediathek angezeigt wurden, genauer gesagt das Bild an sich wurde nicht dargestellt, das eines da war wurde erkannt.

    Nach dem Löschen der .htaccess im uploads ist das Problem behoben, aber die Datei wird nach einigen Minuten wieder automatisch erstellt (Inhalt ist dann nur: Options -Indexes), so dass mich das nicht weiter bringt. Quer durch die Foren suchen hat mich bisher auch nicht weiter gebracht, ich denke aber der Ansatz bei der .htaccess zu suchen ist die richtige Richtung.

    Irgendwelche weitere Ideen?
     
  16. fuhrmara

    fuhrmara Well-Known Member

    Registriert seit:
    15. Januar 2009
    Beiträge:
    275
    Zustimmungen:
    0
    Mal auf die Byte-Größe der Files geachtet.
    Bei mir ist es so das die generierten Thumbs zwar als File da sind, aber nur mit 0Byte.
     
  17. snoofox

    snoofox Member

    Registriert seit:
    27. Januar 2009
    Beiträge:
    6
    Zustimmungen:
    0
    Files sind da mit "richtiger" Größe. Habe eine neues Bild hochgeladen, Original mit 125KB, generierte Thumbs sind da zwischen 2KB und 55KB...
    Habe jetzt auch mal mit dem Hoster Kontakt aufgenommen, der das zumindest merkwürdig findet und weiter nachforscht. Wir haben auch festgestellt, dass auch ein direkter Bildaufruf per URL nicht klappt...
     
  18. fuhrmara

    fuhrmara Well-Known Member

    Registriert seit:
    15. Januar 2009
    Beiträge:
    275
    Zustimmungen:
    0
  19. Belv3dere

    Belv3dere New Member

    Registriert seit:
    29. Januar 2013
    Beiträge:
    1
    Zustimmungen:
    0
    Also bei mir ist das Problem immer noch nicht gelöst. Hab schon einiges probiert. Die PHP Version kann ich ausschließen da ich 2 WordPress Installationen auf dem selben Server betreibe. Beide die aktuellste Version. Bei einem klappts ohne Probleme. hochladen etc alles einwandfrei. Bei der zweiten Installation aber nicht. Aber NUR beim Hochladen aus einem Beitrag. Wenn ich über Medien gehe und dort hochlade klappt es wunderbar. Die Bilder kann ich dann aber bei den Beiträgen NICHT auswählen.

    Weiß absolut nicht weiter. :(
     
  20. inovelop

    inovelop Member

    Registriert seit:
    27. Januar 2012
    Beiträge:
    21
    Zustimmungen:
    0
    hallo,

    habe das selbe Problem. PHP Version 5.3, WordPress 3.5. habe auf meinen Server 40 WP Installation bei allen klappts nur nicht bei einer.

    Server hat 4x 2,2Ghz, u. 16 GB Ram. Für die Fehlerbehaftete Installation habe ich schon 512 MB Speicher freigegeben jedoch ohne ergebniss.

    weiß auch nicht mehr weiter.
    lg
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden