1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

W3C Validation searchform.php

Dieses Thema im Forum "Allgemeines" wurde erstellt von wombii, 14. September 2012.

Schlagworte:
  1. wombii

    wombii Member

    Registriert seit:
    2. November 2011
    Beiträge:
    16
    Zustimmungen:
    0
    Hi,

    ich versuche seit geraumer Zeit die searchform.php W3C valide zu bekommen. Schon quer durchs Netz gelesen, aber krieg es einfach nicht hin. Hat jemand einen Tip?

    Um folgenden Code handelt es sich:

    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    http://validator.w3.org/check?uri=http%3A%2F%2Fwww.in-australien.com%2Fadelaide_1011447&charset=%28detect+automatically%29&doctype=Inline&group=0&user-agent=W3C_Validator%2F1.3

    Und folgende 4 Meldungen beziehen sich alle auf diese 4 Code-Zeilen der Searchform.php:


    1. Line 463, Column 60: end tag for "input" omitted, but OMITTAG NO was specified
      type="text" value="" name="s" class="ina-search-text"></div> You may have neglected to close an element, or perhaps you meant to "self-close" an element, that is, ending it with "/>" instead of ">".

    2. Line 462, Column 67: start tag was here
      action="/" name="searchform" method="get" class="ina-search"><div><input
    3. Line 465, Column 56: end tag for "input" omitted, but OMITTAG NO was specified
      …bmit" value="" class="ina-search-button"></form></div></div></li></ul></li><li> You may have neglected to close an element, or perhaps you meant to "self-close" an element, that is, ending it with "/>" instead of ">".

    4. Line 464, Column 1: start tag was here
      <input

      Bin mit meinem Latein am Ende ...

      lg wombii
     
  2. wombii

    wombii Member

    Registriert seit:
    2. November 2011
    Beiträge:
    16
    Zustimmungen:
    0
    ok, die stunden hätt ich mir sparen koennen, habe die searchform ja noch einmal links auf der seite in einem plugin eingebunden und da waren auch die nicht schließenden Starttags. Ich habe die ganze Zeit fälschlicherweise in der searchform.php nach Fehlern gesucht. ;)