1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

White screen of death beheben

Dieses Thema im Forum "Allgemeines" wurde erstellt von David Pka, 4. August 2018.

  1. David Pka

    David Pka Well-Known Member

    Registriert seit:
    12. August 2017
    Beiträge:
    50
    Zustimmungen:
    0
    Guten Tag,

    ich benötige mal wieder Hilfe.. Ich versuche schon seit Stunden das Problem zu beheben und stehe immer mehr auf dem Schlauch... Wahrscheinlich eine Woo Einstellung?
    Und zwar habe ich auf 2 Seiten meiner Website den sogenannten white screen of death..
    Ich habe schon versucht Plugins aus und ein zu schalten, jedoch ohne wirklichen Erfolg.
    Über FTP habe ich define(‚WP_DEBUG‘, false); zu true geändert um mir eine Fehlermeldung anzeigen zu lassen, jedoch weiß ich nichtg wie ich das Problem dann behebe.

    Es werden 18 ähnliche Fehlermeldungen angezeigt welche in etwa so lauten:
    Notice: Undefined index: shared_secret_dk in /www/htdocs/w01733ec/stellanz.de/wp-content/plugins/klarna-payments-for-woocommerce/includes/class-wc-klarna-banners.php on line 47

    Alle Fehler beziehen sich auf die Zeile 47


    Öffne ich diese Datei lautet die Zeile 47 wie folgt:
    if ( '' !== $kp_settings[ 'merchant_id_' . $country ] && '' !== $kp_settings[ 'shared_secret_' . $country ] ) {

    Explizit geht es um diese Seiten: Sobald ich auf eine Stellenanzeige klicke
    https://stellanz.de/klassische-jobsuche/

    Oder sobald ich auf ein Produkt -> z.B. Basic klicke
    https://stellanz.de/fuer-arbeitgeber/

    Habt ihr eine eventuelle Lösung um mein Problem zu beheben?

    Im voraus vielen Dank!!

    Mit freundlichen Grüßen
    David Pelka
     
  2. wpgray

    wpgray Active Member

    Registriert seit:
    5. August 2018
    Beiträge:
    31
    Zustimmungen:
    3
    schalte mal das klarna gateway ab und schau ob der fehler dann immer noch erscheint!
     
    David Pka gefällt das.
  3. wpgray

    wpgray Active Member

    Registriert seit:
    5. August 2018
    Beiträge:
    31
    Zustimmungen:
    3
    hab mir gerade die seite angeschaut...
    behebe diese fehler mal :)
     

    Anhänge:

    David Pka gefällt das.
  4. David Pka

    David Pka Well-Known Member

    Registriert seit:
    12. August 2017
    Beiträge:
    50
    Zustimmungen:
    0
    Danke für deine Hilfe.
    Das mit dem Klarna Plugin deaktivieren hat nicht geholfen.
    Ich habe mich mal auf die Suche nach den Fehlern anhand deines Screenshot gemacht, leider weiß ich überhaup nicht wo ich mit der Suche beginnen soll.
    Ich dachte eventuell, dass es am deaktivierten Plugin "duplicate post" liegt, jedoch gab es keinen Erfolg.

    nach der Fehlerquelle #security bzw. #workdscout_user_login war ich auch am Suchen, weiß leider keinen Lösungsansatz dazu..
    Kannst du mir helfen die Fehlerquelle zu identifizieren bzw. einzugrenzen?
    Ich bin leider kein Wordpress Experte wenn es um kompliziertere Sachen geht..

    Vielen Dank!
     
  5. SirEctor

    SirEctor WPDE-Team
    Mitarbeiter

    Registriert seit:
    28. Oktober 2008
    Beiträge:
    10.739
    Zustimmungen:
    141
    Wechsel mal auf ein Standard-Theme und teste.
     
    David Pka gefällt das.
  6. wpgray

    wpgray Active Member

    Registriert seit:
    5. August 2018
    Beiträge:
    31
    Zustimmungen:
    3
    david das kann ich so pauschal auch nicht.. du kannst mir aber gerne einen admin anlegen und ich schau mir das an.. dann bestimmt :)
     
  7. wpgray

    wpgray Active Member

    Registriert seit:
    5. August 2018
    Beiträge:
    31
    Zustimmungen:
    3
    also auf jeden fall alles ein google problem.
    ganz unten das gelbe ist der fehler für eine falsche oder fehlende google maps API.

    Die anderen beiden Felder kommen auch von einem google service. hast du ein google plugin mit recaptcha?
     
    David Pka gefällt das.
  8. David Pka

    David Pka Well-Known Member

    Registriert seit:
    12. August 2017
    Beiträge:
    50
    Zustimmungen:
    0
    Habe es mit einem Standard Theme versucht und da funktioniert alles einwandfrei!
    Nur wie finde ich jetzt heraus wo es in meinem Theme hackt? :(
     
  9. David Pka

    David Pka Well-Known Member

    Registriert seit:
    12. August 2017
    Beiträge:
    50
    Zustimmungen:
    0
    Ich habe alles Mögliche von Google über den Costumizer ausgeschaltet, aber der Fehler blieb bestehen. Einen recaptcha benutze ich nicht..
     
  10. SirEctor

    SirEctor WPDE-Team
    Mitarbeiter

    Registriert seit:
    28. Oktober 2008
    Beiträge:
    10.739
    Zustimmungen:
    141
    Das ist definitiv ein Theme Problem. Kontaktiere den Theme-Autor oder such dir ein anderes Theme.
     
    David Pka gefällt das.
  11. David Pka

    David Pka Well-Known Member

    Registriert seit:
    12. August 2017
    Beiträge:
    50
    Zustimmungen:
    0
    Danke für die Hilfe.
    Ich habe zunächst den Theme- Autor kontaktiert und warte auf sein Feedback.
    Ich berichte sobald ich die Antwort erhalten habe wo der Fehler lag. Falls die mir da weiterhelfen..
     
  12. David Pka

    David Pka Well-Known Member

    Registriert seit:
    12. August 2017
    Beiträge:
    50
    Zustimmungen:
    0
    Guten Abend,

    ich melde mich mit Neuigkeiten zurück. Der Theme-Autor hat das Problem lösen können.
    Und zwar habe ich bei den zusätzliche CSS folgenden Code eingefügt: .single { display: none; }
    Damit habe ich auf jeder Seite, die hässliche Titelbar entfernen können, da diese mich störten und nicht schön aussehen.
    Mit dem CSS Code funktionieren meine oben erwähnten Seiten nicht mehr.

    Nun ist meine Frage wie ich die Titelbar auf jeder Seite ohne CSS Code entfernen kann?

    Im voraus vielen Dank!
     
  13. FloRet

    FloRet Well-Known Member

    Registriert seit:
    20. September 2016
    Beiträge:
    825
    Zustimmungen:
    38
    Der CSS Code an sich sollte keinen "White Screen of Death" hervorrufen!

    Versuche mal folgenden CSS Code via Custom CSS
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Grüße
     
    David Pka gefällt das.
  14. David Pka

    David Pka Well-Known Member

    Registriert seit:
    12. August 2017
    Beiträge:
    50
    Zustimmungen:
    0
    Der Code hat funktioniert und es scheinen auch noch alle Seiten zu funktionieren. Besten Dank für die ganze Hilfe!

    Edit maxe: bitte keine direkten Voll-Zitate
     
    #14 David Pka, 10. August 2018
    Zuletzt von einem Moderator bearbeitet: 10. August 2018
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden