1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

WordPress 1.5.1 RSS-Fehler und Fix

Dieses Thema im Forum "Allgemeines" wurde erstellt von Olaf, 17. Mai 2005.

  1. Olaf

    Olaf WPDE-Team
    Mitarbeiter

    Registriert seit:
    3. September 2004
    Beiträge:
    2.737
    Zustimmungen:
    29
    Durch einen Fehler in WordPress 1.5.1 wird der Feed nur 24 Stunden nach Veröffentlichung eines Beitrags angezeigt, danach wird ein Fehler bzw. eine leere Seite ausgegeben.

    Beschreibung und Fix des Problems gibt`s hier:
    http://fernando.dubtribe.com/archives/2005/05/10/solution-to-wp151-rss-errors/


    Der Fehler betrifft die Datei "wp-blog-header.php" im WP-Hauptverzeichnis. Die korrigierte Datei kann hier heruntergeladen werden:

    http://wordpress-deutschland.org/wp-blog-header.phps

    Einfach die Seite als "wp-blog-header.php" speichern und in das WP-Hauptverzeichnis kopieren. Nach der Veröffentlichung eines Beitrags funktioniert der Feed wieder.

    Die Entwickler arbeiten gerade an der Version 1.5.2. Die Version soll in der nächsten Zeit freigegeben werden und neben diesem Fehler noch einige andere Probleme beheben.
     
  2. R-Craven

    R-Craven Active Member

    Registriert seit:
    15. September 2004
    Beiträge:
    40
    Zustimmungen:
    0
    Hab die neue Datei hochgeladen aber mein RSS-Feed ist noch immer leer ... zumindest wenn ich es über http://weblog.r-craven.de/feed/ ansprechen will. Über http://weblog.r-craven.de/?feed=rss2 ist es einwandfrei erreichbar.

    Weiß jemand, was da falsch läuft? Hab den Fehler auch erst gestern bemerkt. Die Links zu den Feeds werden ganz normal über die Funktionen
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    bzw.
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    generiert.
     
  3. suedkind

    suedkind Well-Known Member

    Registriert seit:
    5. Oktober 2004
    Beiträge:
    1.665
    Zustimmungen:
    0
  4. R-Craven

    R-Craven Active Member

    Registriert seit:
    15. September 2004
    Beiträge:
    40
    Zustimmungen:
    0
    Sehr seltsam ... gerade eben war es noch leer. Hat der Server auf dem meine Site lieg Schluckauf oder so?! ;) ... Schon wieder so ein WP-Mysterium. Hatte ja schon mal Feed-Probleme, die sich plötzlich von selbst gelöst haben.

    Aber Danke fürs Nachschauen, suedkind :).
     
  5. suedkind

    suedkind Well-Known Member

    Registriert seit:
    5. Oktober 2004
    Beiträge:
    1.665
    Zustimmungen:
    0
    hattest du in der zwischenzeit irgendwelche aktivitäten? posts? kommentare?
     
  6. R-Craven

    R-Craven Active Member

    Registriert seit:
    15. September 2004
    Beiträge:
    40
    Zustimmungen:
    0
    Nö ... hab das Posting zum Thema "RSS-Bug" weggeschickt und ein paar Minuten danach mein Feed gecheckt. Da führte der /feed/-Link auf eine leere Seite und der ?feed=rss-Link auf den Feed.

    Als ich das feststellte hab ich hier reingeschrieben und du hast dann eben gemeint, dass der Link ja doch geht - in der Zwischenzeit hab ich am Blog nix gemacht.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden