1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Wordpress Admin bereich auf einmal auf Englisch

Dieses Thema im Forum "Installation" wurde erstellt von Dr.Disco, 8. Juni 2011.

  1. Dr.Disco

    Dr.Disco Well-Known Member

    Registriert seit:
    8. Mai 2008
    Beiträge:
    277
    Zustimmungen:
    0
    Hi,

    na meinem letzten Wordpress- Update ist mein kompletter Admin- Bereich auf englisch. Woran kann das liegen? Das Theme ist immer noch das gleiche und ich habe auch eine deutsche Version von Wordpress hochgeladen.

    Grüße
    Dr.Disco
     
  2. maxe

    maxe WPDE-Team
    Mitarbeiter

    Registriert seit:
    1. Mai 2008
    Beiträge:
    18.701
    Zustimmungen:
    117
    Stimmt der Eintrag in der wp-config.php noch ?
    Liegen die 6 Sprachdateien in wp-content/languages/ ?
    Steht der richtige Eintrag in der wp-includes/version.php ganz unten: $wp_local_package = 'de_DE'; ?
     
  3. Dr.Disco

    Dr.Disco Well-Known Member

    Registriert seit:
    8. Mai 2008
    Beiträge:
    277
    Zustimmungen:
    0
    Hi,

    also zu deinen Fragen:

    es liegen sechs Sprachdateien in Languages
    bei wp-confic steht bei Sprachdatei:
    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    in der Version.php stand nicht $wp_local_package = 'de_DE'; habe es unten angefügt, aber leider hat es nichts gebracht.
     
  4. maxe

    maxe WPDE-Team
    Mitarbeiter

    Registriert seit:
    1. Mai 2008
    Beiträge:
    18.701
    Zustimmungen:
    117
    Da haben wir wohl schon den Fehler, der Eintrag ist auskommentiert. Nimm die // raus:
    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
     
  5. Dr.Disco

    Dr.Disco Well-Known Member

    Registriert seit:
    8. Mai 2008
    Beiträge:
    277
    Zustimmungen:
    0
    hey wie cool alles wieder auf deutsch :) Danke für deine Hilfe, darfst dir ein Bienchen eintragen ;)
     
  6. maxe

    maxe WPDE-Team
    Mitarbeiter

    Registriert seit:
    1. Mai 2008
    Beiträge:
    18.701
    Zustimmungen:
    117
    fragt sich nur, wer das wohl falsch in der wp-config.php kommentiert hat :confused:
     
  7. michbeck II

    michbeck II Member

    Registriert seit:
    10. Januar 2014
    Beiträge:
    5
    Zustimmungen:
    0
    Hallo erstmal,

    Ich hoffe Ihr könnt mir weiterhelfen und ich bin hier an der richtigen Forumstelle. Ich habe eben ein Update vollzogen und plötzlich ist auch meine Seite komplett auf Englisch. Ich habe aktuell die Version 4.9.6–de_DE installiert. Da ich unter anderen auch mit WPML arbeite, ist jetzt etwas mühsamer. Ob es an diesem Plugin liegen kann, muss ich erst noch herausfinden. Der "Fehler" trat aber bereits nach dem erfolgreichen Update von Wordpress auf.

    Fogende Einträge habe ich bereits überprüft. Habe ich vielleicht noch etwas übersehen?

    In der version.php steht folgender Eintrag:
    $wp_local_package = 'de_DE';

    und in der config.php:
    define('WPLANG', 'de_DE');

    Und auch alle 6 Sprachdateien liegen in dem Ordner: wp-content/languages/

    Jetzt bin ich etwas ratlos.

    Ich danke im voraus.

    Grüße der michbeck
     
  8. maxe

    maxe WPDE-Team
    Mitarbeiter

    Registriert seit:
    1. Mai 2008
    Beiträge:
    18.701
    Zustimmungen:
    117
    hat sich am Theme was geändert (evtl. auch ein Update)? Welches Theme verwendest du? Von welcher WP Version bist du gekommen?
     
  9. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    4.063
    Zustimmungen:
    264
    Und was ist unter "Einstellungen > Allgemein > Sprache der Website" eingestellt, und welche Sprache im Profil beim angemeldeten Benutzer = Deinem Login?

    Und wird ein Cache-Plugin verwendet?
     
  10. michbeck II

    michbeck II Member

    Registriert seit:
    10. Januar 2014
    Beiträge:
    5
    Zustimmungen:
    0
    Moin,

    vielen Dank der Tipps.

    1.) Also die Sprache bei Allgemein ist auch auf Deutsch eingestellt.
    2.) die vorige Version ist die 4.9.5 gewesen
    3.) und ein Cache-Plugin nutze ich auch nicht

    4.) Als Theme nutze ich DIVI. Als Plugins nutze ich derzeitig noch WPML und WooCommerce am Start. Ich vermute dass sich hier vielleicht was gegenseitig stört. Desweiteren BackWPup & TinyMCE Advanced - die hatte ich aber nicht aktualisiert.

    WPML
    ist aber auch auf Standard Deutsch gestellt. Gut diese Einstellung hat weniger mit dem WP-Dashboard zu tun. Bei WooCommerce kenne ich jetzt keine Einstellung, die solch einen Fehler hervorrufen sollte.

    Ich bin mir auch sicher, nicht auf das Englische Update gedrückt zu haben. Auf dem Bild sagt er mir ja auch, das die deutsche Version installiert ist, zumindest interpretiere ich das so. (update.jpg)

    Ungern möchte ich die ältere Version wieder aufspielen, weil ich in der Zeit schon weitergearbeitet habe. Das Englisch ist jetzt auch nicht so schlimm, ich würde damit klar kommen. Aber die Lösung des "Problems" würde mich schon interessieren.

    Auf dem gleichen Web-Server habe ich eine ähnliche Seite laufen, mit den fast den selben Plugins. Also würde ich auch ein Problem dadurch ausschließen. Aber hier gebe ich zu, das wäre nur "gefährliches Halbwissen". So tief stecke ich dann doch nicht in der Materie.

    Ich orakle weiter.

    Vielen Dank für eure Infos.

    Grüße der michbeck
     

    Anhänge:

  11. maxe

    maxe WPDE-Team
    Mitarbeiter

    Registriert seit:
    1. Mai 2008
    Beiträge:
    18.701
    Zustimmungen:
    117
    hast du mal testweise ALLE Plugins deaktiviert und auf ein Standard-Theme umgestellt?
     
  12. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    4.063
    Zustimmungen:
    264
    Welche Sprache ist im Profil beim angemeldeten Benutzer = Deinem Login eingestellt?

    Welche Sprache ist ganz oben im Admin-Bar bei WPML eingestellt? Der Screenshot ist leider nicht komplett.
     
  13. michbeck II

    michbeck II Member

    Registriert seit:
    10. Januar 2014
    Beiträge:
    5
    Zustimmungen:
    0
    Hallo,

    Ich habe eben alle Plugins einzeln deaktiviert und das Standard-Theme Twenty Seventeen getestet. Keine Veränderung am Dashboard erkennbar, auch nach aus- und einloggen nicht.

    Einfach Phänomenal, ich suche weiter.

    Vielen Dank der michbeck
     
  14. michbeck II

    michbeck II Member

    Registriert seit:
    10. Januar 2014
    Beiträge:
    5
    Zustimmungen:
    0
    Hallo,

    auch hier stimmen meiner Meinung nach alle Einstellungen. Ich hatte auch nach dem Update nichts weiter irgendwo ein- oder umgestellt. Die "Sprachumstellung" am Dashboard war unmittelbar nach dem Update erkennbar.

    Wie gesagt, es ist kein Problem mit dieser englischen Variante zu arbeiten. Ich würde mich auch nicht als WP-Anfänger bezeichnen. Jedoch fehlt mir, wenn es dann tiefer in das Wordpress-Gerüst gehen sollte, ein wenig die Erfahrung. Mich würde das Ergebnis bzw. die Ursache interessieren. Ich versuche weiterhin durch Ausschlussverfahren an´s Ziel zu kommen.

    Vielen Dank der Hilfe.
     

    Anhänge:

  15. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    4.063
    Zustimmungen:
    264
    Welche Sprache ist im Profil beim angemeldeten Benutzer = Deinem Login eingestellt?
     
  16. michbeck II

    michbeck II Member

    Registriert seit:
    10. Januar 2014
    Beiträge:
    5
    Zustimmungen:
    0
    Hallo,

    Jetzt habe ich es geschnallt und auch gefunden was du meintest. An diese Option hatte ich gar nicht gedacht. Hier war auf einmal Englisch eingestellt. Dies hatte ich bisher auch noch nicht gehabt. Der Tip war ein Treffer! Vielen Dank!

    Ich hatte zuvor alle Sprachdateien gesichert und die vom letzten Back-Up hochgeladen. Um dies auch auszuschließen.

    Wieder eine Erfahrung reicher.
     
  17. gunness

    gunness Member

    Registriert seit:
    16. Dezember 2011
    Beiträge:
    8
    Zustimmungen:
    0
    Hallo b3317133,

    hatte das gleiche Problem. Super Tip - Vielen Dank!

    Viele Grüße

    gunness
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden