1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

WordPress in deutscher Sprache

Dieses Thema im Forum "Sprachdatei" wurde erstellt von Olaf, 13. September 2004.

  1. Michi91

    Michi91 Well-Known Member

    Registriert seit:
    8. November 2008
    Beiträge:
    1.740
    Zustimmungen:
    0
    erneutes hochladen der sprachdatei half
     
  2. Horizontis

    Horizontis Member

    Registriert seit:
    19. Oktober 2010
    Beiträge:
    14
    Zustimmungen:
    0
    Alles in Englisch statt Deutsch

    Hallo!

    Ich hab gestern die neueste Version von Wordpress (ich glaube 3.0.1 DE) geladen und in meinen Webspace geladen.

    Obwohl die deutsche Sprachdatei unter wp-content/languages liegt und auch die confi.php entsprechend geändert wurde kriege ich keine deutsche Admin-Oberfläche.

    Wer kann helfen?

    Hab's geschafft! Das Einbinden einer .htaccess hat geholfen.

    Inhalt, wie von Maxe an anderer Stelle (Installations-Support beschrieben:
    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php
     
    #102 Horizontis, 20. Oktober 2010
    Zuletzt bearbeitet: 21. Oktober 2010
  3. dorinight

    dorinight New Member

    Registriert seit:
    18. April 2011
    Beiträge:
    1
    Zustimmungen:
    0
    Deutsch auf Englisch umstellen

    Kann mir jemand helfen.
    Ich habe ein wordpress blog in Deutsch will es aber in Englischer Sprache.
    Meine Auswahl fuer Sprachen besteht nur aus: Dutch, Spanish and French.
     
  4. jottlieb

    jottlieb Well-Known Member
    Ehrenmitglied

    Registriert seit:
    20. August 2005
    Beiträge:
    17.381
    Zustimmungen:
    0
    In Datei wp-config.php deiner WordPress-Installation die Zeile WP_LANG ... löschen. Falls du keine Datei wp-config.php hast, bist du hier im Forum falsch.
     
  5. schubidoo

    schubidoo New Member

    Registriert seit:
    12. August 2011
    Beiträge:
    2
    Zustimmungen:
    0
    Hallo alle zusammen.
    Langsam weiß ich echt nicht mehr weiter. Versuche schon seit Tagen mein Wordpress ins Deutsche zu bekommen. Ich hab die DE Edition draufgespielt.
    Leider war gleich von Anfang an das Backend in Englisch.Dann hatte ich noch ein Speicherproblem bei meinem Anbieter was ich heute erfolgreich lösen konnte, da der Support die Höchstgrenze hochgesetzt hatte.

    So da ich gerne nun alles auf Deutsch hätte, hab ich in der FAQ von wordpress nachgeschaut. da Steht noch von 2006 ein Artikel das man die
    gettext.php ändern soll. Leider kann ich die in der 3.2.1 Version nicht auf meinem Server finden.

    Kann man evtl. den Amninbereich über einen Editor vielleicht ändern?

    Vielleicht hat ja auch jemand ne gute Idee oder Vorschlag.

    Vielen Dank
     
  6. infected

    infected Well-Known Member

    Registriert seit:
    9. Juli 2006
    Beiträge:
    9.816
    Zustimmungen:
    1
    Das sollte eigentlich nicht passieren. Die Dateien wurden vollständig übertragen? Mit welchem FTP Tool? Und in welchem Modus? Ggf. mal ein anderes FTP Programm nehmen und es nochmal probieren. Es kann sein, dass die Sprachdateien fehlerhaft übertragen wurden und deswegen nicht greifen.
     
  7. schubidoo

    schubidoo New Member

    Registriert seit:
    12. August 2011
    Beiträge:
    2
    Zustimmungen:
    0
    Ok danke werd es nochmal probieren. Hatte es mit filezilla hochgeladen
     
  8. maxe

    maxe WPDE-Team
    Mitarbeiter

    Registriert seit:
    1. Mai 2008
    Beiträge:
    19.184
    Zustimmungen:
    180
    Du lädst auch das Paket von hier herunter? Und in der wp-config.php steht in der Sprach-Definition de_DE ?
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
     
  9. hafencity

    hafencity New Member

    Registriert seit:
    5. Januar 2012
    Beiträge:
    4
    Zustimmungen:
    0
    Deutsche Sparachdatei

    Ich hänge mich hier einmal mit rein, ich habe das gleiche Problem. WP DE Version aktuell, Sprachdatei vom empfohlenen Server, alte Sprachdateien im language Verz.gelöscht und neue per Filezilla geladen, ebenso die Theme Twentyeleven language Dateien übertragen,Config wie beschrieben. Gibt mir Rätsel auf. WP bleibt auf Englisch.

    Torsten
     
  10. hafencity

    hafencity New Member

    Registriert seit:
    5. Januar 2012
    Beiträge:
    4
    Zustimmungen:
    0
    Hurra jetzt funktioniert die Sprachumstellung. Nachdem ich die Sprachconfiguration in der config.php von:
    define ('WPLANG', 'de_DE.mo');auf
    define ('WPLANG', 'de_DE'); geändert hatte bekam ich eine Memorysize
    Fehlermeldung. Dann noch die Definition ebenfalls in der config.php ändern:
    define('WP_MEMORY_LIMIT', '64M');

    Hilft eventuell anderen Anfängern weiter.
     
  11. Silvia3000

    Silvia3000 New Member

    Registriert seit:
    27. März 2013
    Beiträge:
    2
    Zustimmungen:
    0
    Hallo,
    ich bin neu hier und gucke mir alles an.
    Wie kann man hilfe bekommen?

    Viele der links gibt es nicht mehr?

    Herzliche Grüße Silvia
     
  12. FrageSelten

    FrageSelten Well-Known Member

    Registriert seit:
    16. April 2013
    Beiträge:
    199
    Zustimmungen:
    0
    mal ganz doof gefragt: warum muss man sich für die Sprachdatei diese erst irgendwo runterladen anstelle die originale zu kopieren, umzubenennen, im sourcecode mit der neuen vermappen und die neue Sprachdatei ist ja die alte englische einfach mit einen Texteditor (Nein, Microsoft Word ist kein Texteditor) manuell so umbauen wie man es gerne hätte?
     
  13. infected

    infected Well-Known Member

    Registriert seit:
    9. Juli 2006
    Beiträge:
    9.816
    Zustimmungen:
    1
    @Silvia3000: Was meinst Du mit
    ??? Konkretisiere bitte Dein Problem. Wohlgemerkt, hier geht es um die deutsche Sprachdatei für WordPress

    @FrageSelten: Auch hier habe ich ein Verständnisproblem. Was ist mit
    gemeint? Die deutsche Sprachdatei für WordPress ist doch bereits im Download enthalten und aktiviert, wenn Du den Download von dieser Seite verwendest?!
     
  14. Silvia3000

    Silvia3000 New Member

    Registriert seit:
    27. März 2013
    Beiträge:
    2
    Zustimmungen:
    0
    Hallo,
    ich brauche hilfe ich möchte in Wordpress die Textschrift kleiner machen....Ich würde mich freuen über eine antwort...
     
  15. swissky

    swissky Member

    Registriert seit:
    25. November 2012
    Beiträge:
    17
    Zustimmungen:
    0
    Wo in WordPress soll die Schrift kleiner sein?
    Du bist immer noch im Thema Sprachdatei wo es darum geht WordPress auf Deutsch zu Übersetzten.
     
  16. mlonetworks

    mlonetworks New Member

    Registriert seit:
    19. Juni 2013
    Beiträge:
    2
    Zustimmungen:
    0
    Auch bei mir alles in Englisch

    Hallo allerseits!

    Ich betreue mehrere WordPress-Installationen und habe jetzt schon zum zweiten Mal das Problem, dass ich das WordPress nicht in Deutsch zum Laufen bekomme.

    Ich habe von http://de.wordpress.org/ das deutsche Installationspaket 3.5.1 DE heruntergeladen und installiert. Trotzdem erhielt ich ein englisches WordPress, schon bei der Einrichtung wurde ein englischer Hinweis zur Erzeugung der Konfigurationsdatei angezeigt.

    Alles eingegeben, abgeschickt, und dann kam die Fehlermeldung „Sorry, but I can’t write the wp-config.php file. You can create the wp-config.php manually and paste the following text into it.“
    Also habe ich die wp-config.php mit Notepad++ manuell angelegt, den Text hineinkopiert, die Datei hochgeladen und anschließend auf „Run the install.” geklickt. In der Folge habe ich ein paar Stunden meines Lebens sinnlos verschwendet. :(

    Die wp-config.php habe ich überprüft: Eintrag lautet wie er soll: define('WPLANG', 'de_DE');

    Dann habe ich die Sprachdateien nochmal von http://wpde.org/download/sprachdateien/ separat heruntergeladen und auf den Webserver kopiert - ohne Erfolg.

    Danach habe ich von http://wpde.org/download/ das komplette Installationspaket WordPress 3.5.1 DE-Edition heruntergeladen, entpackt und auf den Server kopiert. Immer noch alles englisch.

    Übertragen habe ich die Dateien mit dem FTP-Modul des Total Commander, Übertragungsmodus binär.

    Dann habe ich - wie an anderer Stelle beschrieben - eine .htaccess-Datei mit folgendem Inhalt angelegt:
    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php


    Danach konnte allerdings das Login nicht mehr aufgerufen werden, stattdessen gab es reichlich Code zu sehen. Also die .htaccess wieder gelöscht, mit einer leeren ging es auch nicht.

    Als nächstes habe ich die Sprachdateien vom Webserver gelöscht und nochmal separat auf den Webserver kopiert - ohne Erfolg.
    Den empfohlenen 64bit-Fix kann ich nicht anwenden, da es keine gettext.php mehr gibt.

    Jetzt weiß ich nicht mehr weiter. Kann es irgendwie noch an Schreibrechten liegen?
     
  17. mlonetworks

    mlonetworks New Member

    Registriert seit:
    19. Juni 2013
    Beiträge:
    2
    Zustimmungen:
    0
    So, Fehler gefunden. Beim Kopieren der WordPress-Installation auf den Webserver habe ich leider vergessen, die Option "Wandle Dateinamen in Kleinbuchstaben um" zu deaktivieren. Die benötige ich zwischendurch für bestimmte FTP-Transfers.
    Also hat er die Sprachdateien rüberkopiert als z.B. "de_de.mo". Und wenn dann in der wp-config.php der Eintrag define('WPLANG', 'de_DE'); steht, klappt das nicht, weil die Abfrage case-sensitive ist. Nach dem Umbenennen der Dateien habe ich jetzt auch ein komplett deutsches WordPress. Kaum macht man es richtig, schon klappt es.
    Sicherheitshalber habe ich noch mal die komplette Installation rüberkopiert.

    Fazit: zu wenig Schlaf und dann mitten in der Nacht im 27°C warmen Arbeitszimmer WordPress zu installieren birgt ein wenig Fehlerpotential. :)

    Grüße aus Düsseldorf,
    Michael
     
  18. drkmelle

    drkmelle Well-Known Member

    Registriert seit:
    11. August 2008
    Beiträge:
    284
    Zustimmungen:
    0

    Hallo,


    ich habe ebenfalls ein Sprach-Problem!
    Es handelt sich um einen Ubuntu 14.04 LTS Server 64bit + Plesk 12.0 bei Strato.
    Die Wordpress-Installation ist aktuell über http://h2336711.stratoserver.net/ erreichbar.
    Front- und Backend sind in Englisch und waren zuerst über die wp-config.php auf Englisch eingestellt.

    Ich habe nun wie oben die Sprache in der Datei umgestellt und das komplette Wordpress (3.9.1) von wpde.org drüber kopiert!
    Leider alles weiterhin auf Deutsch! Liegt es am 64bit?

    Upload über Filezilla und über sftp.

    Hat jemand eine Idee?


    Viele Grüße
    Jan
     
  19. mensmaximus

    mensmaximus Well-Known Member

    Registriert seit:
    24. Juli 2014
    Beiträge:
    7.738
    Zustimmungen:
    212
    ?? Ist es jetzt Deutsch oder weiterhin Englisch ??

    Und es wäre von Vorteil einen neuen Thread zu eröffnen, anstatt einen 14 Monate alten wieder zu beleben.
     
  20. drkmelle

    drkmelle Well-Known Member

    Registriert seit:
    11. August 2008
    Beiträge:
    284
    Zustimmungen:
    0

    Dieser wird aus der FAQ verlinkt ;)
    Aber mache ich...
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden