1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

WordPress ist bereits installiert.

Dieses Thema im Forum "Installation" wurde erstellt von tanne_der_erste, 23. Juli 2022.

  1. tanne_der_erste

    tanne_der_erste Active Member

    Registriert seit:
    14. September 2021
    Beiträge:
    35
    Zustimmungen:
    0
    Hallo Leute,
    da mein WP schon lange nicht mehr richtig lief habe ich mich heute entschieden das ganze mal neu zu machen.

    Eins vorweg, ich habe die Suchmaschinen benutzt,aber manchmal passt der Wortlaut nicht, oder sonst was passt nicht. Deshalb frage ich hier. !

    Meine WP Vers. 6.0.1
    Runtergeladen, entpackt und per FTP auf mein Webspace hochgeladen.
    Bis hier,alles kein Hexenwerk. Die alte Vers. habe ich vorher gesichert.

    Jetzt also los. Die Installation, ohne Probleme.
    Die DB, Username und PW stehen ja in der gesicherten Vers.

    Jetzt kommt eine Meldung wo ich nicht weiter weiß.!

    " WordPress ist bereits installiert. Für eine Neuinstallation lösche bitte zuerst deine alten Datenbank-Tabellen."

    Welche Tabellen soll ich löschen. Ich bin nicht besonders bewandert mit PhpMyAdmin , aber wenn ich weiß was ich löschen soll.

    Das komische ist ja wenn ich den Tabellenpräfix ändere geht auch mein WP.
    Nur greift es nicht auf die Daten zu, die eigentlich da sein müssten.

    Was also muss ich machen das die frische Installation auch die Daten meiner Homepage wieder findet ?

    Grüße
     
  2. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    10.083
    Zustimmungen:
    1.369
    Keine Tabellen löschen, die wp-config.php aus der alten gesicherten Version hochladen, fertig.

    Natürlich kann die Ursache für Dein "nicht mehr richtig laufen" auch irgendwo in der Datenbank oder im Falle eines Hacks auch in der wp-config.php selbst sein, das wäre dann herauszufinden.
     
    Kurt Singer gefällt das.
  3. tanne_der_erste

    tanne_der_erste Active Member

    Registriert seit:
    14. September 2021
    Beiträge:
    35
    Zustimmungen:
    0
    Danke für dein Antwort.
    Oh ja ,ich hatte mit Hackerangriffen zu tun und das nicht zu knapp.
    Wie kann ich herausfinden ob da Schaden in der DB ist ?
     
  4. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    10.083
    Zustimmungen:
    1.369
    Siehe damaliger Thread:
     
  5. tanne_der_erste

    tanne_der_erste Active Member

    Registriert seit:
    14. September 2021
    Beiträge:
    35
    Zustimmungen:
    0
    Vielen Dank für deine Antwort.
    Na dann werde ich mich mal ans abarbeiten machen, vielen Dank.

    Grüße
     
  6. tanne_der_erste

    tanne_der_erste Active Member

    Registriert seit:
    14. September 2021
    Beiträge:
    35
    Zustimmungen:
    0
    Nachtrag:
    Jetzt wo fast alles wieder ist wie es sein soll.

    WP verschickt keine eMail`s mehr.
    Ich habe die wp-config aus der Sicherung in das Verzeichnis geladen.
    Nun geht der Mail Versand nicht mehr. Da hatte ich noch nie Probleme.
    Hier ein Auszug aus meiner wp-config.

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Da steht eigentlich alles drin. Das Netzt ist voll mit verschiedenen Ansätzen.
    Wie bekomme ich den Mail Versand denn nun wieder zum laufen ?

    Habe jetzt mal unter Werkzeuge - Netzwerk Einrichtung geschaut.
    Da wird mir jetzt folgendes geschrieben.

    Nach Abschluss dieser Schritte ist dein Netzwerk aktiviert und eingerichtet. Dann musst du dich erneut anmelden. Anmelden


    Muss ich das noch alles einfügen ?
    Grüße
     
    #6 tanne_der_erste, 26. Juli 2022
    Zuletzt bearbeitet: 26. Juli 2022
  7. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    10.083
    Zustimmungen:
    1.369
    Entferne diese Zeile aus der wp-config.php, die hat dort gar nichts verloren:
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Diese "Netzwerk" Angaben sind nur dann relevant, wenn Du eine sog. WordPress Multisite Installation einrichten willst.
     
  8. tanne_der_erste

    tanne_der_erste Active Member

    Registriert seit:
    14. September 2021
    Beiträge:
    35
    Zustimmungen:
    0
    Das habe ich mit gedacht, deshalb habe ich da nichts unternommen.

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Ich habe die Zeile entfernt und alles geht wie es soll.
    Vielen Dank b3317133 .
     
  9. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    10.083
    Zustimmungen:
    1.369
    Diese Zeile dürfte dort niemals stehen. Vergleiche daher noch Deine aktuelle Datei wp-config.php mit der Vorlagendatei wp-config-sample.php, gibt es da signifikante Unterschiede (ausser den Datenbankzugangsdaten und ausser den AUTH_KEY Einträgen), z.B. weiterer Code?
     
    tanne_der_erste gefällt das.
  10. tanne_der_erste

    tanne_der_erste Active Member

    Registriert seit:
    14. September 2021
    Beiträge:
    35
    Zustimmungen:
    0
    Vielen Dank für den Hinweis. Es gibt keine Unterschiede zwischen den Dateien außer das die wp-config-sample.php leer ist.
    Die haben beide die gleich Anzahl der Zeilen. Das sollte passen.
     
  11. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    10.083
    Zustimmungen:
    1.369
    Was genau ist leer in der wp-config-sample.php? Die Datenbankzugangsdaten? Etwas anderes?

    Oft wird von Hacks in wp-config.php in irgendeiner Zeile mit vielen Leerzeichen eingerückt Backdoor Code eingefügt. Die Anzahl der Zeilen bleibt dabei gleich.
     
  12. tanne_der_erste

    tanne_der_erste Active Member

    Registriert seit:
    14. September 2021
    Beiträge:
    35
    Zustimmungen:
    0
    Hier meine wp-config-sample.php ,da stehen ja keine Geheimnisse drin.
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Wie gesagt da steht ja nichts drin, muss das so ?

    Mal eine ganz andere Frage. Was ist das für ein Editor. Mein Forum " verso-forum.de " hat eine anderen Editor,ich finde diesen hier besser.
    Da muss ich doch nur wissen wie die Erweiterung heißt.

    Grüße
     
  13. createdwishalladin111

    Registriert seit:
    29. Juli 2022
    Beiträge:
    1
    Zustimmungen:
    0
    Was also muss ich machen das die frische Installation auch die Daten meiner Homepage wieder findet ?

    -falls noch nicht geschehen, in dasselbe Verzeichnis installieren. die Versionen überprüfen
     
  14. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    10.083
    Zustimmungen:
    1.369
    Das trifft hier nicht zu, der frischen Installation fehlten nur die korrekten Datenbank Zugangsdaten.

    Nach dem Hochladen der wp-config.php aus der alten gesicherten Version mit diesen Zugangsdaten war dieses Problem gelöst, siehe oben.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden