1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Wordpress-Multisite mit 3 Domains

Dieses Thema im Forum "Blog-Netzwerk" wurde erstellt von MaBik, 21. August 2019.

  1. MaBik

    MaBik Member

    Registriert seit:
    21. August 2019
    Beiträge:
    6
    Zustimmungen:
    0
    Hallo liebe Wordpress-Mitglieder,

    nachdem ich neben der tagelangen Netzrecherche nun einiges hier im Forum zum Thema "Multisite" gelesen habe, stehe ich immer noch vor meinem ungelösten Problem. Möglicherweise hakt es nur an einer Kleinigkeit. Hier meine Situation:

    1) Ich habe 3 Domains (projekt.net, projekt.at und projekt.ch) bei Strato geordert und aktiviert. Die projekt.net ist dabei ein Hostingpaket, die anderen beiden sind reservierte Domainnamen mit Weiterleitungsfunktion.

    2) Im Hostingpaket [projekt.net] habe ich eine frische Wordpress-Installation im Unterverzeichnis /projekt aufgezogen. Die Mutlitsite-Funktion habe ich mit der Option "Unterverzeichnisse" ausgeführt und die von Wordpress vorgeschlagenen Anpassungen in der wp-config.php und .htaccess wie folgt umgesetzt:

    .htaccess

    # BEGIN WordPress

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) owango/$2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ owango/$2 [L]
    RewriteRule . index.php [L]

    # END WordPress

    wp-config.php (Sektion für WP-Multisite)

    /* Wordpress Multisite-Funktion 20.08.2019 */
    define( 'WP_ALLOW_MULTISITE', true );
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'owango.net');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    define('COOKIE_DOMAIN', '');

    3) In Wordpress selbst habe ich nun 2 weitere Projekteinträge mit folgender Verzeichnissangabe /projekt/at und /projekt/ch angelegt mit folgendem Ergebnis:

    Meine Websites ->

    * projekt1 (Domainpaket) > Website-Adresse (URL) = https://projekt.net/
    * projekt2 > Website-Adresse (URL) = https://projekt.net/at/
    * projekt3 > Website-Adresse (URL) = https://projekt.net/ch/

    4) Bei meinem Hoster habe ich die 3 Domains dann folgendermaßen konfiguriert:

    projekt.net -> Umleitung (Intern - /projekt)
    projekt.at -> Umleitung (Extern | Permanente Weiterleitung 301 ): https://projekt.net/at
    projekt.ch -> Umleitung (Extern | Permanente Weiterleitung 301 ): https://projekt.net/ch

    5) Wenn ich im Browser nun projekt.net aufrufe, erhalte ich die Wordpress-Startseite (also OK). Ich kann auch ins Backend. Wenn ich dagegen projekt.at oder projekt.ch aufrufe, erhalte ich auch eine Startseite, jedoch nur in Textform. Okay, kein Theme eingefügt/aktiviert. Und jetzt kommts.

    6) Wenn ich in Wordpress nun über "Meine Websites - Projekt2 (oder Projekt3) - Dashboard" (URL im Browser wäre https://projekt.net/at/wp-admin/ bzw. https://projekt.net/ch/wp-admin/) ein Theme einhängen möchte, kommt die folgende Fehlermeldung:

    >>-------------------
    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator at service@webmailer.de to inform them of the time this error occurred, and the actions you performed just before this error.

    More information about this error may be available in the server error log.
    -------------------<<

    Ich kann somit weder im Wordpress-Backend als auch nicht im Browser über die entsprechende URL (https://projekt.net/(at oder ch)/wp-admin) auf die beiden Domains zugreifen um bspw. ein Theme zu aktivieren oder Beiträge anzulegen.

    Möglicherweise liegt ein Fehler in der .htaccess oder in der Pfadeinstellung bei den beiden Doamins projekt.at und projekt.ch vor. Ich finde einfach keine Lösung für das Problem. Eventuell ist es nur ein Kleinigkeit.

    Ich wäre für jeden kleinen Tipp oder Lösungsvorschlag sehr dankbar und hoffe auf eure Mitwirkung.

    Herzlichen Dank vorab und Grüße,
    Manfred
     
  2. B-52

    B-52 Well-Known Member

    Registriert seit:
    16. März 2008
    Beiträge:
    1.134
    Zustimmungen:
    4
    Fix das mal, dann versuche ich Dein Problem zu verstehen und helfe gerne!

    [​IMG]

    LG B-52
     
  3. MaBik

    MaBik Member

    Registriert seit:
    21. August 2019
    Beiträge:
    6
    Zustimmungen:
    0
    Hallo B-52,

    Danke für deine rasche Rückmeldung. Anstelle von "projekt" (diente nur als Platzhalter) handelt es sich hier um die folgenden registrierten Domains:

    * https://owango.net
    * https://owango.at
    * https://owango.ch

    Beim Hoster sind serverseitig entsprechende Weiterleitungen auf Wordpress konfiguriert (siehe Bild owango-domains-weiterleitungen.jpg).

    In Wordpress selbst habe ich die Websites unter "Meine Websites - Netzwerkverwaltung - Websites - [Website] - Bearbeiten" wie folgt konfiguriert:

    * owango.net
    -> [Register Info] Website-Adresse (URL): https://owango.net/
    -> [Register Einstellungen] Siteurl: https://owango.net
    -> [Register Einstellungen] Home: https://owango.net

    * owango.at
    -> [Register Info] Website-Adresse (URL): https://owango.net/at/
    -> [Register Einstellungen] Siteurl: https://owango.net
    -> [Register Einstellungen] Home: https://owango.net/at

    * owango.ch
    -> [Register Info] Website-Adresse (URL): https://owango.net/ch/
    -> [Register Einstellungen] Siteurl: https://owango.net
    -> [Register Einstellungen] Home: https://owango.net/ch

    Die Inhalte der .htaccess und wp-config.php habe ich im Startbeitrag oben aufgelistet.

    Dashboards

    Klicke ich auf Websites, bekomme ich die 3 angelegten URLs. Wenn ich dort nun bei jeder Site auf "Dashboard" klicke, öffnet sich dieses. Ich lande aber immer im Dashboard der Hauptdomain (owango.net) und nich in den dazugehörigen (owango.at oder owango.ch). Siehe hierzu auch das Bild (owango-websites-dashboard.jpg)

    Aufruf der Domains


    Wenn ich nun owango.net aufrufe, erhalte ich korrekterweise die Startseite der 1.Domain mit aktiven Theme (twentyseventeen). Bei Aufruf von owango.at lande ich korrekterweise auf der URL https://owango.net/at aber im Textmodus ohne Theme (obwohl es dort auch aktiv geschalten ist). Gleiches bei owango.ch, wo ich korrekt auf https://owango.net/ch im Textmodus lande.


    Ich hoffe sehr dass mir (bzw. der Website-Konfiguration) geholfen werden kann ;) Andere haben es ja auch geschafft und freue mich auf jeden noch so kleinen Hinweis.

    Ganz herzlichen Dank vorab und liebe Grüße,
    Manfred
     

    Anhänge:

  4. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    6.123
    Zustimmungen:
    538
    • Hier erscheint bei .at eine Strato Platzhalterseite, offenbar ist die Domainverknüpfung nicht korrekt.
    • Und bei .ch erscheint eine 404 nicht gefunden Seite der Hauptseite im korrekten Twenty Seventeen Theme Layout.
    Tipp am Rande: Bei allen Änderungen, die mit Redirects usw. zu tun haben zwischen allen Versuchen unbedingt den Browser Cache leeren...
     
  5. MaBik

    MaBik Member

    Registriert seit:
    21. August 2019
    Beiträge:
    6
    Zustimmungen:
    0
    Hallo b3317133,

    Danke für deine Info. Ich habe nun ein paar Anpassungen dahingehend durchgeführt. Der aktuelle Stand ist derzeit:

    Strato Hosting

    Domain owango.at und auch owango.ch wurde auf (intern)/owango/ umgeleitet, da liegt die Wordpress-Installation.

    Wordpress

    In Wordpress-Multisite wurden bei den beiden Domains die Pfade kontrolliert und wie folgt über "Bearbeiten" angepasst:

    * Site OwangO Österreich (.at)

    Register [Info] Website-Adresse (URL) = https://owango.at
    Register [Einstellungen] Site-URL = https://owango.net und Home = https://owango.at

    * Site OwangO Schweiz (.ch)

    Register [Info] Website-Adresse (URL) = https://owango.ch
    Register [Einstellungen] Site-URL = https://owango.net und Home = https://owango.ch

    Ergebnis!

    Es lassen sich nun alle 3 Seiten im Browser korrekt aufrufen. Bei allen 3 Sites wird jedoch zunächst kein SSL verwendet und die Information "Unsichere Seite" angezeigt. Ich denke das kann man in der .htaccess einfügen. Hierhabe ich ein Schnippsel wie folgt gefunden.

    .htaccess

    RewriteEngine On
    RewriteCond %{HTTPS} !=on
    RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=3

    Ist das auf diese Weise zu empfehlen oder gibt es bessere Lösungen hierfür?

    Nach wie vor ein PROBLEM!

    Ich komme im Browser bei den beiden Webseiten owango.at und owango.ch beispielsweise über den Link "Anmelden" bei [META] in der Seitenleiste nicht in den Login-Dialog der Seiten. Ich lande immer in owango.net und auch dort kann ich über Sites - Dashboard nur noch das Dashboard der "Hauptseite" owango.net öffnen. Klicke ich bei der AT-Site auf Dashboard komme ich zur NET-Site, so auch bei der CH-Site.

    Trage ich direkt im Bowser beispielsweise https://owango.at/wp-admin ein, so erhalte ich sofort wieder die "Hauptseite" owango.net mit einem redierct-Parameter in der URL wie folgt:

    https://owango.net/wp-login.php?redirect_to=https%3A%2F%2Fowango.at%2Fwp-admin%2F&reauth=1

    Lieben Dank für eure bisherigen Tipps und ich hoffe weiter auf Hilfe.

    Liebe Grüße,
    Manfred
     
  6. mensmaximus

    mensmaximus Well-Known Member

    Registriert seit:
    24. Juli 2014
    Beiträge:
    7.704
    Zustimmungen:
    208
    In einem Subfolder Setup sind die wp-admin Seiten nicht über die umgeleiteten Domains erreichbar. Falls SSL später gewünscht wird sollte es idealerweise bereits bei der Einrichtung aktiv sein, sonst hast Du nach der Umstellung gleich die nächste(n) Frage(n) im Forum.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden