1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

WP 4.5 Wordpress-Tabellen in der falschen Datenbank

Dieses Thema im Forum "Installation" wurde erstellt von Microprofessor, 28. April 2016.

  1. Microprofessor

    Microprofessor New Member

    Registriert seit:
    28. April 2016
    Beiträge:
    4
    Zustimmungen:
    0
    Hallo,

    vor einiger Zeit habe ich ein neues Wordpress-Blog aufgesetzt. Dazu habe ich dummerweise die config.php eines bereits bestehenden Blogs benutzt und modifiziert. Dabei ist es mir nun passiert, dass ich unter DB_NAME den Datenbank-Namen des alten Blogs stehen lassen habe. Zum Glück habe ich die Tabelle anders genannt (sonst wäre die Datenbank des anderen Blog sicherlich beschädigt worden). Nun habe ich aber zwei Blogs in derselben Datenbank.

    Das ist im Prinzip zwar kein Problem, ich möchte der Übersicht wegen und weil ich verhindern möchte, dass es zu irgendwelchen Konflikgen bei Installationen und Updates kommt, das neue Blog in eine eigene Datenbank migrieren. Ich habe dazu bereits die Tabellen mit phpmyadmin aus der alten Datenbank exportiert und in eine leere Datenbank importiert. Die config.php habe ich ebenfalls bei DB_NAME mit der Namen der neuen Datenbank angepasst.

    Leider hat das nicht funktioniert. Der Bildschirm bleibt bei Aufruf des Blogs weiß. Ich habe mittlerweile zu viel Zeit in die Gestaltung und die Inhalte des neuen Blogs investiert, so dass ich das Blog ungern löschen und neu aufbauen möchte.

    Was muss ich tun, um die Tabellen aus der einen Datenbank in eine neue zu transferieren?

    Stefan
     
  2. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.965
    Zustimmungen:
    8
    Weißer Bildschirm bedeutet meistens PHP Error. Poste mal deine wp-config.php (ohne Passwort).
     
  3. JABA-Hosting

    JABA-Hosting Well-Known Member

    Registriert seit:
    29. März 2016
    Beiträge:
    2.465
    Zustimmungen:
    98
    Bei einem weißen Bildschirm bitte den Debug Modus einschalten.

    -> Debug Modus einschalten (ganz unten unter Wordpress)
     
  4. Microprofessor

    Microprofessor New Member

    Registriert seit:
    28. April 2016
    Beiträge:
    4
    Zustimmungen:
    0
    An der wp-config kann es nicht liegen. Darin habe ich ausschließlich den Namen der alten Datenbank durch den der neuen ersetzt. Die liegen auf dem selben Server, haben denselben Nutzer und dasselbe Passwort.

    Ich vermute das Problem liegt daran, dass es in der Datenbank selbst Einträge gibt, die auf die alte Datenbank verweisen bzw. den alten Datenbank-Namen verwenden und die Blogsoftware deshalb ein Problem bekommt, mit den alten Datenbank-Tabellen in der neuen Datenbank zu arbeiten.
     
  5. maxe

    maxe Well-Known Member
    Ehrenmitglied

    Registriert seit:
    1. Mai 2008
    Beiträge:
    19.357
    Zustimmungen:
    226
    bist du dir 100% sicher, dass es nicht an der wp-config liegen kann? Oft ist es nur ein falsches Hochkomma o.ä.
     
  6. chrismuller82

    chrismuller82 Well-Known Member

    Registriert seit:
    8. April 2016
    Beiträge:
    66
    Zustimmungen:
    0
    Schaue einfach mal in das error_log des Webservers. Dort steht im Klartext drin, was nicht funktioniert. Falls du nicht weißt, wo Du das error_log findest, frage Deinen Hoster.
     
  7. Microprofessor

    Microprofessor New Member

    Registriert seit:
    28. April 2016
    Beiträge:
    4
    Zustimmungen:
    0
    Ich habe das Problem gefunden und beheben können: Es lag daran, dass Hosteurope mittlerweile für jede Datenbank einen eigenen Datenbank-User und ein eigenes Passwort generiert. Das war früher nicht so (meine alten Blogs laufen alle mit demselben User und demselben Passwort). Außerdem hatte mein Texteditor netterweise noch in Latin-1 statt UTF-8 gespeichert, was zu einer interessanten Variantenbreite an Hochkommas/Anführungszeichen in der wp-config.php geführt hat.

    Danke für die Tipps!
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden