1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

WP Statistics defekt ?

Dieses Thema im Forum "Plugins und Widgets" wurde erstellt von speefak, 24. März 2023.

  1. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    11.833
    Zustimmungen:
    1.822
    Ok, das ist wieder eine andere 403 Meldung.
    • Evtl. stimmen interne Rewrite Regeln nicht, versuche es mit Einstellungen > Permalinks > ohne Änderungen speichern, ändert das etwas?
    • Wurde ggf. in der Vergangenheit an Benutzerrechten herumgebastelt?
    Von aussen kann man ansonsten kaum noch weiterhelfen, es wäre ein Login erforderlich, um Dingen weiter auf den Grund gehen zu können.
     
  2. speefak

    speefak Well-Known Member

    Registriert seit:
    22. Januar 2014
    Beiträge:
    50
    Zustimmungen:
    0
    Permalinkeinstelungen speichern bringt auch nichts, an Benutzerrechten wurde nichts geändert.

    Ein Login via Teamviewer / Andydesk ist kein Thema, nur heute schaffe ich das nicht mehr da ich gleich einen Termin habe.

    Es ist wirklich verdammt nochmal verzwickt ;/

    Danke an dieser Stelle für den bisherigen Support ;)
     
  3. threadi

    threadi Well-Known Member

    Registriert seit:
    9. Oktober 2020
    Beiträge:
    2.133
    Zustimmungen:
    424
  4. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    11.833
    Zustimmungen:
    1.822
    Direkte Hilfe ist hier im Forum nur über die Jobbörse möglich.
    Es ist eine andere Stelle. Die eigentliche Ursache könnte ähnlich sein. Er schreibt aber auch, dass andere Wordpressinstallationen auf dem gleichen Server das Problem nicht haben.
     
  5. speefak

    speefak Well-Known Member

    Registriert seit:
    22. Januar 2014
    Beiträge:
    50
    Zustimmungen:
    0
    Das Modul mod_security ist auf dem Server nicht aktiv. Andere Wordpress ( 4 weitere ) Installationen auf dem gleichen Server laufen ohne Probleme. Daher denke ich wirds nicht am Server liegen. Ich habe die Webseite auf einem anderen Testserver einmal installiert und auch dort hat die statistics API kein Zugriff.
     
  6. r23

    r23 Well-Known Member

    Registriert seit:
    9. Dezember 2006
    Beiträge:
    7.405
    Zustimmungen:
    600
    Man kann auch mit der .htaccess den Zugriff verhindern. Evtl. zeigst du (bitte nicht als Bild) deine htaccess.
     
  7. speefak

    speefak Well-Known Member

    Registriert seit:
    22. Januar 2014
    Beiträge:
    50
    Zustimmungen:
    0
    # BEGIN WordPress
    # Die Anweisungen (Zeilen) zwischen „BEGIN WordPress“ und „END WordPress“ sind
    # dynamisch generiert und sollten nur über WordPress-Filter geändert werden.
    # Alle Änderungen an den Anweisungen zwischen diesen Markierungen werden überschrieben.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /www.oss_lifestyle/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /www.oss_lifestyle/index.php [L]
    </IfModule>

    # END WordPress​

    Ich habe die htaccess mit Der einer funktionierenden Installation vergleichen und festgestellt, dass da noch menge alter Code drin war. Mit der o.g. htacess sehe ich die "Blankos" der Grafen , habe keine der vorigen Fehler mehr - allerdings wird die Statistik nicht aufgebaut bzw. angezeigt: https://speefak.spdns.de/mycloud/index.php/s/ntdjfMoW8TJGQf6
     
  8. speefak

    speefak Well-Known Member

    Registriert seit:
    22. Januar 2014
    Beiträge:
    50
    Zustimmungen:
    0
  9. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    11.833
    Zustimmungen:
    1.822
    Nach manuellen Anpassungen in .htaccess versuche es mit Einstellungen > Permalinks > ohne Änderungen speichern, ändert das etwas?
    Öffne diese 404 Meldung in der Konsole, was wird als Detail "Antwort" angezeigt?

    metabox-json.png

    Ergänzung: Hast Du die o.g. .htaccess manuell erstellt/bearbeitet oder wurde die von WordPress so geschrieben? Das www. sollte da wohl eher nicht sein. Im Zweifel lösche die .htaccess Datei und speichere dann die Permalinks, das erzeugt die Datei passend neu.
     
    #29 b3317133, 25. März 2023
    Zuletzt bearbeitet: 25. März 2023
  10. r23

    r23 Well-Known Member

    Registriert seit:
    9. Dezember 2006
    Beiträge:
    7.405
    Zustimmungen:
    600
    und wie kommst du auf ein RewriteBase /www.oss_lifestyle/ nach deinen Bildchen hier (wie nervig) ist oss_lifestyle etwas richtiger...
     
  11. speefak

    speefak Well-Known Member

    Registriert seit:
    22. Januar 2014
    Beiträge:
    50
    Zustimmungen:
    0
    ich habe nun alles im zusammenhang mit der .htaccess versucht ( löschen, manuell neu erstellen, löschen und via permalinks update neu erstellen mit Pfad oss_lifestyle und www.oss_lifestyle )

    ich verstehe es einfach nicht woran es liegen könnte und wie man vorgehen könnte/sollte/müsste

    der Datenpfad ist unter /var/www/www.oss_lifestyle und die site-available/www.oss_lifestyle.conf nutz oss_lifestyle

    root@D11-Webserver:/var/www/www.oss_lifestyle> cat /etc/apache2/sites-available/www.oss_lifestyle.conf
    Alias /oss_lifestyle /var/www/www.oss_lifestyle

    <Directory /var/www/www.oss_lifestyle>
    Options FollowSymLinks
    AllowOverride ALL
    </Directory>

    root@D11-Webserver:/var/www/www.oss_lifestyle> ​

    Gehe ich richtig in der Annahme, wenn Ausgaben bei dem Link https://speefak.spdns.de/oss_lifestyle/wp-json/ erscheinen funktioniert die REST API schon mal

     

    Anhänge:

  12. speefak

    speefak Well-Known Member

    Registriert seit:
    22. Januar 2014
    Beiträge:
    50
    Zustimmungen:
    0
    Keine Ahnung wie ich drauf komme, ich versuche seit Tagen einfach alles was ich im Netz dazu finde, da ich keine Ahnung habe ich wie ich dabei analytisch vorgehen soll. Es wär schon schön zu wissen, ob es an einem Rewrite liegt, falschen API keys. Apache Config Fehler kann ich ausschließen denn andere Webseiten auf dem selben Server laufen ohne Probleme.
     
  13. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    11.833
    Zustimmungen:
    1.822
    Der einzig richtige Weg.
    Dieser Teil der REST API funktioniert(e) bereits die ganze Zeit, andere Teile der REST API von WP Statistics waren/sind wegen Deiner REST API Plugins (siehe Meldungen oben) bzw. aus sonstigen Gründen (noch zu ermitteln) beschränkt oder waren heute (siehe 404 Meldung) nicht mehr verfügbar.

    Beantworte noch die Frage zur 404 Meldung in Deinem Screenshot.
     
  14. speefak

    speefak Well-Known Member

    Registriert seit:
    22. Januar 2014
    Beiträge:
    50
    Zustimmungen:
    0
    Beantworte noch die Frage zur 404 Meldung in Deinem Screenshot.=> s. Anhang
     

    Anhänge:

  15. speefak

    speefak Well-Known Member

    Registriert seit:
    22. Januar 2014
    Beiträge:
    50
    Zustimmungen:
    0
    Ich hatte zwischenzeit auch ALLE Plugins bis auf das WP statistics Plugin deinstalliert - das hat auch nicht geholfen. Werden Änderungen mit der Deinstallation eines Plugins ggf. nicht wieder Rückgängig gemacht und verbleiben im System ? ( Windows Style )
     
  16. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    11.833
    Zustimmungen:
    1.822
    Dieser Screenshot ist a) eine 403 Meldung (nicht die 404 Meldung aus Deinem o.g. Screenshot) und b) nicht das Tab "Antwort".

    Wenn Du ständig parallel andere Dinge versuchst, kann man nur sehr schwer sinnvoll helfen.

    Was/ob ein Plugin beim Deinstallieren aus WordPress löscht/rückgängig macht oder nicht, weiss am besten der jeweilige Plugin Autor bzw. Plugin Support. Es gibt dazu keine allgemeingültige Aussage.
     
  17. speefak

    speefak Well-Known Member

    Registriert seit:
    22. Januar 2014
    Beiträge:
    50
    Zustimmungen:
    0
    Gibt es den irgendwo eine Config Datei in der man Keys/APIs der REST Schnittstelle konfigurieren kann ? Gibt es eine Möglichkeit wie in der Shell mit set -x genau zu verfolgen wo der Code hängt bzw. bei welche Zeile in welcher Datei Ärger macht ?
     
  18. speefak

    speefak Well-Known Member

    Registriert seit:
    22. Januar 2014
    Beiträge:
    50
    Zustimmungen:
    0
    der 404 ist ein falsches FAVicon. Wenn ich das über den Customizer neu setze ist kein 404 mehr vorhanden.

    OK ich spiele das backup nun wieder ein. Poste die configs und werde dann nichts weiter machen.
     
  19. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    11.833
    Zustimmungen:
    1.822
    Eine Config Datei gibt es nicht. Die Rewrite-Regeln sind in der Datenbank und manchmal in .htaccess. WordPress ist eine PHP Anwendung. Du kannst beliebige PHP IDEs zum Debugging verwenden.

    Der angefrage 404 ist ein REST API Aufruf des WP Statistic Plugins, schau Deinen eigenen Screenshot nochmal an:

    [​IMG]

    Ergänzung: Wenn Du ein Backup einspielst, gehe den ganzen Thread mit allen Problemen und Rückfragen und daraus folgenden Änderungen und Erzeugen .htaccess über Einstellungen > Permalinks und Anzeigen von "Antwort" bei Fehlern nochmal von Anfang an durch bevor Du weitere Fragen stellst, sonst dreht sich das im Kreis.
     
    #39 b3317133, 25. März 2023
    Zuletzt bearbeitet: 25. März 2023
  20. speefak

    speefak Well-Known Member

    Registriert seit:
    22. Januar 2014
    Beiträge:
    50
    Zustimmungen:
    0
    Alles zurück auf Anfang :

    Server: Debian 11 | PHP 7.4.33 | WP Version 6.1.1
    Client Debian 10 | Firefox 111.01 | FF ESR | Midori | Chrome
    WP: Custon Theme / Child Theme


    Konsolenausgabeüberblick:
    [​IMG]

    Fehler im Detail:
    [​IMG]
    Antwort der Konsole:
    [​IMG]

    /var/www/www.oss_lifestyle/.htaccess

    # BEGIN WordPress
    # Die Anweisungen (Zeilen) zwischen „BEGIN WordPress“ und „END WordPress“ sind
    # dynamisch generiert und sollten nur über WordPress-Filter geändert werden.
    # Alle Änderungen an den Anweisungen zwischen diesen Markierungen werden überschrieben.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /oss_lifestyle/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /oss_lifestyle/index.php [L]
    </IfModule>

    # END WordPress

    /etc/apache2/sites-available/www.oss_lifestyle.conf

    Alias /oss_lifestyle /var/www/www.oss_lifestyle

    <Directory /var/www/www.oss_lifestyle>
    Options FollowSymLinks
    AllowOverride ALL
    </Directory>​


    /etc/apache2/sites-available/000-default.conf


    <VirtualHost *:80>
    # The ServerName directive sets the request scheme, hostname and port that
    # the server uses to identify itself. This is used when creating
    # redirection URLs. In the context of virtual hosts, the ServerName
    # specifies what hostname must appear in the request's Host: header to
    # match this virtual host. For the default virtual host (this file) this
    # value is not decisive as it is used as a last resort host regardless.
    # However, you must set it for any further virtual host explicitly.
    #ServerName www.example.com

    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/html

    # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
    # error, crit, alert, emerg.
    # It is also possible to configure the loglevel for particular
    # modules, e.g.
    #LogLevel info ssl:warn

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

    # For most configuration files from conf-available/, which are
    # enabled or disabled at a global level, it is possible to
    # include a line for only one particular virtual host. For example the
    # following line enables the CGI configuration for this host only
    # after it has been globally disabled with "a2disconf".
    #Include conf-available/serve-cgi-bin.conf

    RewriteEngine on
    RewriteCond %{SERVER_NAME} =speefak.spdns.de
    RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]

    </VirtualHost>

    # vim: syntax=apache ts=4 sw=4 sts=4 sr noet
    Das ist der Ursprungszustand wie beim erstellen des Threads

    Was ich dann gemacht habe :

    - /var/www/www.oss_lifestyle/.htaccess gelöscht und über Permalinks/Beiträge neu erstellt ( gleicher Dateiinhalt wie vorher )
    - Deaktivieren aller Plugins und Themes bis auf WP Statistic und das 20203 Theme => Kein Erfolg => Plugins wieder aktiviert

    Sollte ich die Plugins komplett deinstallieren ?

    Ich werde jetzt nicht weiter an der Installation oder den Configs etwas ändern.

    Was ist jetzt der nächste Schritt ?
     

    Anhänge:

    #40 speefak, 25. März 2023
    Zuletzt bearbeitet: 25. März 2023
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden