1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

wp-style-switcher zeigt nicht den standard-style an

Dieses Thema im Forum "Plugins und Widgets" wurde erstellt von spacefrog, 30. Mai 2005.

  1. spacefrog

    spacefrog Well-Known Member

    Registriert seit:
    10. Mai 2005
    Beiträge:
    228
    Zustimmungen:
    0
    hallo,
    ich nutze ziemlich begeistert das style-switcher-plugin,
    und habe jetzt zwei styles.
    ich habe in der wp-style-switcher.php folgendes geändert:

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    "shd.pink" soll also standard-style sein.
    leider wird aber trotzdem, wenn man zum ersten mal auf die site (sfrog.de) kommt, und den style noch nicht gewechselt hat, der andere angezeigt.

    was muss ich noch ändern?

    thx,

    spacefrog
     
  2. Christof

    Christof Well-Known Member

    Registriert seit:
    14. März 2005
    Beiträge:
    122
    Zustimmungen:
    0
    Geh mal in deine Adminoberfläche.
    Dort beim Punkt Themes kannst du deinen Standarttheme (Aktives Theme) auswählen... (Ich wusste garnet, dass man das auch in dem entsprechenden Code machen kann.)
     
  3. spacefrog

    spacefrog Well-Known Member

    Registriert seit:
    10. Mai 2005
    Beiträge:
    228
    Zustimmungen:
    0
    Nein, das meine ich nicht...
    ich verwende den Styleswitcher, mit dem man zw. verschiedenen .css wechseln kann, also das aktive theme anders dargestellt wird.
     
  4. kinjin

    kinjin Well-Known Member

    Registriert seit:
    19. Februar 2005
    Beiträge:
    124
    Zustimmungen:
    0
    Leere mal den Cache!
    Evtl hast du deswegen das Problem!

    Ich benutze den Styleswitcher auch auf meiner Seite und der zeigt mir alle Templates an die im Ordner Templates vorhanden sind, und wechselt Sie auch schön durch!

    Timo
     
  5. spacefrog

    spacefrog Well-Known Member

    Registriert seit:
    10. Mai 2005
    Beiträge:
    228
    Zustimmungen:
    0
    bei mir selbst zeigt er ja den richtigen style an..bloss besucher die zum ersten mal auf die site kommen, bekommen den falschen angezeigt.
    sonst funktioniert das plugin prima (mein absolutes lieblingsplugin).

    aber ich habe das problem jetzt auf andere art und weise gelöst...
    die verlinkung meiner domain habe ich umgeleietet auf
    .../blog/?wpstyle=shd.pink
    ich hoffe es geht jetzt...kann das mal jemand für mich testen?

    danke!
     
  6. ratterobert

    ratterobert Well-Known Member
    Ehrenmitglied

    Registriert seit:
    1. Januar 2005
    Beiträge:
    1.237
    Zustimmungen:
    0
    verlink doch den pink-style standardmässig in der header.php
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden