1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

WP 4.5 WYsIWYG - Editor - keine Funktion

Dieses Thema im Forum "Konfiguration" wurde erstellt von MisterSecond, 25. April 2016.

  1. MisterSecond

    MisterSecond Member

    Registriert seit:
    25. April 2016
    Beiträge:
    9
    Zustimmungen:
    0
    Hallo liebe Communuity,
    Es wird oft darüber berichtet das Wordpress V 4.5 starke Probleme jeglicher Art verursacht.

    Allerdings habe ich festgestellt, dass alles bestens funktioniert... Naja, "fast" alles!
    Ich habe derzeit das Problem das der WYSIWYG -Editor (TinyMCE Advanced) nicht funktioniert.

    Hat da jemand einen Tipp für mich? Der Standard Editor sowie die Gallerie, die scheinbar auch Probleme mit WP4.5 hat, funktionieren bei mir.
    Einzigst ist wie gesagt der WYSIWYG. Aktiviert in meinem Profil ist dieser auch. Es wird mir aber nix angezeigt sobald ich einen Beitrag schreiben möchte :(.

    Oder hat jemand einen Ausweicheditor?!? Laut den Specs von TinyMCE Advanced soll dieser mit WP4.5 kompatibel sein.

    Für Tipps wäre ich sehr sehr dankbar!
    Es Handelt sich dabei um meine "private-wordpress Seite" www.Mister-Second.de
     
  2. maxe

    maxe Well-Known Member
    Ehrenmitglied

    Registriert seit:
    1. Mai 2008
    Beiträge:
    19.445
    Zustimmungen:
    243
    hast du mal testweise alle anderen Plugins deaktiviert? Ich vermute da irgendeine Inkompatibilität.
     
  3. MisterSecond

    MisterSecond Member

    Registriert seit:
    25. April 2016
    Beiträge:
    9
    Zustimmungen:
    0
    Ja das war das erste was ich bereits vor einer Wochen gemacht habe.
    Nur Mittlerweile habe ich es aufgegeben und frage mich nun mal hier durch, bevor ich was falsches mache.
    Mir kommt es bald so vor als ob ich den Wald vor lauter Bäumen nicht sehe
     
  4. maxe

    maxe Well-Known Member
    Ehrenmitglied

    Registriert seit:
    1. Mai 2008
    Beiträge:
    19.445
    Zustimmungen:
    243
  5. helix

    helix Well-Known Member

    Registriert seit:
    28. Juli 2011
    Beiträge:
    1.808
    Zustimmungen:
    27
    Die allgemeine-Problemlösungs-Vermutungs-Strategie sagt, dass das WordPress-Update zu 4.5 deswegen mit Tiny MCE, Visual Composer und anderen Probleme macht, weil WP 4.5 jQuery neu einbindet. Das heißt, alle Funktionen, die irgendwie jQuery benötigen, können (nicht müssen!) nach dem Update Probleme machen und rumzicken.

    Deswegen gab es auch den Tipp, bei der Aktualisierung auf 4.5 zuerst die PlugIns und Themes zu aktualisieren und dann erst WordPress selber (ich weiß nicht, ob das grundsätzlich bei Aktualisierungen ein sinnvolles Vorgehen ist. Jedenfalls ist mir vorher so ein Hinweis noch nie aufgefallen).

    Wenn jetzt die Aktualisierungen eigentlich schon gemacht sind, ist ja-auch-alles-gut. Allerdings: nochmal checken, ob wirklich alle PlugIns und das Theme auf dem neuesten Stand sind. Es kommt auch vor, dass es Aktualisierungen gibt, diese aber im Admin-Bereich nicht angezeigt werden.

    Wenn das alles durch ist: Alle Caches leeren und aktualisieren. Könnte ja sein, dass irgendwo noch Altlasten rumhängen.

    Wenn es jetzt immer noch Probleme gibt, kommt die Übung mit „Kompatibilität der PlugIns testen“. Im nervigsten Fall muss man alle Kombinationen durchtesten (theoretisch).
    Ich würde dann so „abkürzen“: Alle PlugIns deaktivieren bis auf den Tiny MCE (den willste ja mit den anderen kompatibel haben). Dann PlugIn für PlugIn dazu, immer testen.
    Wenn das keine Ergebnisse / Erkenntnis bringt, würde ich zuerst hier eine Liste meiner verwendeten PlugIns (+ Theme) posten, bevor ich anfange, Kombinationen zu testen. Vielleicht fällt dann jemand konkret was ein …

    Gruß
    helix
     
  6. SirEctor

    SirEctor Well-Known Member
    Ehrenmitglied

    Registriert seit:
    28. Oktober 2008
    Beiträge:
    12.329
    Zustimmungen:
    412
    Das ist bei mir immer schon Standard gewesen, aber ich meine es gab vorher von WP keinen Hinweis. Besser war es aber schon immer.
     
  7. MisterSecond

    MisterSecond Member

    Registriert seit:
    25. April 2016
    Beiträge:
    9
    Zustimmungen:
    0
    Ich habe das jetzt mal so gemacht wie es Helix vorgeschlagen hat.
    Leider brachte dies keine Änderung :(

    Auch wenn ich ein Standard-Theme wähle und alle Plugins ausschalte bis auf den Tiny MCE und ich in meinem Profil den haken bei "Beim Schreiben den WYSIWYG-Editor nicht benutzen" entferne.
    Dann wird mir weder der normale Editor noch der Tiny MCE angezeigt
     
  8. helix

    helix Well-Known Member

    Registriert seit:
    28. Juli 2011
    Beiträge:
    1.808
    Zustimmungen:
    27
    Und auch immer brav alle verfügbaren Caches geleert?

    Dann solltest du
    1.) mal ganz ohne PlugIn testen: funktioniert dann der (Standard-) visuelle Editor von WordPress?

    Wenn nein: das würde ich als Indiz werten, dass da insgesamt an der Installation was nicht sauber ist.
    => In der wp-config.php Debugging auf true setzen.
    Was gibt es für Fehlermeldungen?

    Gruß
    helix
     
  9. MisterSecond

    MisterSecond Member

    Registriert seit:
    25. April 2016
    Beiträge:
    9
    Zustimmungen:
    0
    Der Standard Visuelle Editor funktioniert bei mir auch nicht.
    Sobald ich den einschalte und nutze, sehe ich über den Textfeld nix, im Editorbereich ist zwar der Text drin, allerdings in weißer Schrift.
    Der Schaltbutton |Visuell|Text| funktioniert generell nicht

    Nachdem ich den debugmodus auf true gestellt habe, erscheint bei mir folgendes:

    Im Frontend steht oben:

    "Notice: get_currentuserinfo ist seit Version 4.5 veraltet! Benutze stattdessen wp_get_current_user(). in /var/www/vhosts/web1443.freeweb.webhoster.ag/httpdocs/Mister-Second/wp-includes/functions.php on line 3658"

    Im Backend steht dann oben folgendes:

    Notice: add_utility_page ist seit Version 4.5 veraltet! Benutze stattdessen add_menu_page(). in /var/www/vhosts/web1443.freeweb.webhoster.ag/httpdocs/Mister-Second/wp-includes/functions.php on line 3658

    Notice: get_currentuserinfo ist seit Version 4.5 veraltet! Benutze stattdessen wp_get_current_user(). in /var/www/vhosts/web1443.freeweb.webhoster.ag/httpdocs/Mister-Second/wp-includes/functions.php on line 3658
     
    #9 MisterSecond, 27. April 2016
    Zuletzt bearbeitet: 27. April 2016
  10. helix

    helix Well-Known Member

    Registriert seit:
    28. Juli 2011
    Beiträge:
    1.808
    Zustimmungen:
    27
    Rückfrage: erhältst du diese Fehlermeldung bei null aktivierten PlugIns und aktiviertem Standard-Theme Twenty Irgendwas?

    (Ist jetzt natürlich Unterstellung, aber die Fehlermeldungen „sehen eher so aus“, als ob dafür das Theme oder ein PlugIn verantwortlich wäre. Bei einem Standard-Theme relativ unwahrscheinlich … )

    Gruß
    helix
     
  11. helix

    helix Well-Known Member

    Registriert seit:
    28. Juli 2011
    Beiträge:
    1.808
    Zustimmungen:
    27
    Update: Mal abgesehen von den Fehlermeldungen, denen man dann schon auch nachgehen sollte –
    .
    .
    .
    .
    .
    .
    … arbeitest du vielleicht mit Chrome?

    => WordPress meldet zum neuen Release 4.5.1: „[…] behebt – unter anderem […] eine Inkompatibilität zwischen Chrome und dem visuellen Editor […]“
    Also „einfach mal“ aktualisieren.

    Gruß
    helix
     
  12. MisterSecond

    MisterSecond Member

    Registriert seit:
    25. April 2016
    Beiträge:
    9
    Zustimmungen:
    0
    So der debugmodus sagt mir im frontend:
    Warning: include(/var/www/vhosts/web1443.freeweb.webhoster.ag/httpdocs/Mister-Second/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /var/www/vhosts/web1443.freeweb.webhoster.ag/httpdocs/Mister-Second/wp-settings.php on line 74

    Warning: include(/var/www/vhosts/web1443.freeweb.webhoster.ag/httpdocs/Mister-Second/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /var/www/vhosts/web1443.freeweb.webhoster.ag/httpdocs/Mister-Second/wp-settings.php on line 74

    Warning: include(): Failed opening '/var/www/vhosts/web1443.freeweb.webhoster.ag/httpdocs/Mister-Second/wp-content/advanced-cache.php' for inclusion (include_path='.:/opt/plesk/php/5.6/share/pear') in /var/www/vhosts/web1443.freeweb.webhoster.ag/httpdocs/Mister-Second/wp-settings.php on line 74


    Backend sagt er dann dies hier:

    Warning: include(/var/www/vhosts/web1443.freeweb.webhoster.ag/httpdocs/Mister-Second/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /var/www/vhosts/web1443.freeweb.webhoster.ag/httpdocs/Mister-Second/wp-settings.php on line 74

    Warning: include(/var/www/vhosts/web1443.freeweb.webhoster.ag/httpdocs/Mister-Second/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /var/www/vhosts/web1443.freeweb.webhoster.ag/httpdocs/Mister-Second/wp-settings.php on line 74

    Warning: include(): Failed opening '/var/www/vhosts/web1443.freeweb.webhoster.ag/httpdocs/Mister-Second/wp-content/advanced-cache.php' for inclusion (include_path='.:/opt/plesk/php/5.6/share/pear') in /var/www/vhosts/web1443.freeweb.webhoster.ag/httpdocs/Mister-Second/wp-settings.php on line 74
     
  13. MisterSecond

    MisterSecond Member

    Registriert seit:
    25. April 2016
    Beiträge:
    9
    Zustimmungen:
    0
    Zum Browser:
    Ich habe getestet mit:
    Chrome (Nach Update auf 4.5.1)
    Firefox ist mein Hauptbrowser
    und mit dem IE (Edge) hatte ich immer nochmal gegen getestet
    Aktualisiert hatte ich heute morgen auf 4.5.1, lief auch durch. Hatte gehofft das es nun richtig geht.
     
    #13 MisterSecond, 27. April 2016
    Zuletzt bearbeitet: 27. April 2016
  14. helix

    helix Well-Known Member

    Registriert seit:
    28. Juli 2011
    Beiträge:
    1.808
    Zustimmungen:
    27
    „Deaktiviere“ mal deine Datei advanced-cache.php, direkt im Ordner wp-content – sprich: benenne sie mal um, z.B. indem du dem Dateinamen einen Unterstrich voranstellst oder sowas – oder per FTP auf deinem Rechner sichern und in wp-content löschen …

    Meinem Verständnis nach müsste dann dein System diese Datei neu – aktualisiert – da rein schreiben.

    Eventuell auch, wenn das nicht zielführend ist, in der wp-config.php mal den WP_CACHE auf false setzen.

    Wenn du damit auch nicht weiter kommst, würde ich drüber nachdenken, einen neuen Thread anzufangen, in dem WP_CACHE im Threadtitel steht … es gibt hier im Forum bestimmt Leute, die darüber besser Bescheid wissen als ich und vielleicht auch als maxe und SirEctor … (ist immer ein Problem, je länger ein Thread wird, desto weniger lesen mit).

    Gruß
    helix
     
  15. MisterSecond

    MisterSecond Member

    Registriert seit:
    25. April 2016
    Beiträge:
    9
    Zustimmungen:
    0
    Ich verstehe jetzt nur noch Bahnhof :(
    Also diese advanced-cache.php wird bei mir nicht erstellt. egal ob ich in der WP_Config - wp_cache auf true oder false stelle
    lasse ich die debug meldung mir auslesen, dann steht nun bei mir im Backend:

    Warning: include(/var/www/vhosts/web1443.freeweb.webhoster.ag/httpdocs/Mister-Second/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /var/www/vhosts/web1443.freeweb.webhoster.ag/httpdocs/Mister-Second/wp-settings.php on line 74

    Warning: include(/var/www/vhosts/web1443.freeweb.webhoster.ag/httpdocs/Mister-Second/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /var/www/vhosts/web1443.freeweb.webhoster.ag/httpdocs/Mister-Second/wp-settings.php on line 74

    Warning: include(): Failed opening '/var/www/vhosts/web1443.freeweb.webhoster.ag/httpdocs/Mister-Second/wp-content/advanced-cache.php' for inclusion (include_path='.:/opt/plesk/php/5.6/share/pear') in /var/www/vhosts/web1443.freeweb.webhoster.ag/httpdocs/Mister-Second/wp-settings.php on line 74

    Notice: add_utility_page ist seit Version 4.5 veraltet! Benutze stattdessen add_menu_page(). in /var/www/vhosts/web1443.freeweb.webhoster.ag/httpdocs/Mister-Second/wp-includes/functions.php on line 3658

    Notice: get_currentuserinfo ist seit Version 4.5 veraltet! Benutze stattdessen wp_get_current_user(). in /var/www/vhosts/web1443.freeweb.webhoster.ag/httpdocs/Mister-Second/wp-includes/functions.php on line 3658
     
  16. helix

    helix Well-Known Member

    Registriert seit:
    28. Juli 2011
    Beiträge:
    1.808
    Zustimmungen:
    27
    Dann guck doch einfach mal, wo die Abfahrtstafel hängt …

    Sorry, aber wenn du dauernd irgendetwas anderes einstellst und irgendwie hinfrickelst, ist es schwierig bis unmöglich, eine sinnvolle Fehlersuche zu betreiben. (Und da stellt sich mir dann schon die Frage: wer will denn hier eigentlich Hilfe? Mit anderen Worten: viel ist jetzt nicht mehr übrig von meiner Geduld.)

    Die Fehlermeldungen, die du in Post #12 gepostet hast, sagen alle sehr eindeutig, wo der Hund sein Grab hat: in der advanced-cache.php, direkt im Ordner wp-content.
    Bei mir gibt es so eine Datei nicht, weil ich nie in meiner wp-config.php WP_CACHE auf true gesetzt habe.
    Dass die Datei daher kommt, hat mir eine kurze Recherche bei Google verraten.

    Wenn der Eintrag zu WP_CACHE nicht standardmäßig in der wp-config.php drin ist, muss sie ja irgendwann mal irgendjemand reingeschrieben haben. Meine Hoffnung im Sinne von „Hilfe zur Selbsthilfe“ wäre gewesen, dass du dich an der Stelle daran erinnerst, diesen Eintrag vorgenommen zu haben – und vielleicht auch, was du damit bezweckt hast? Und vielleicht warst du ja intelligent genug, damals, dich soweit kundig zu machen, wie du denn diesen Cache aktualisieren kannst. – Darauf hatte ich dich schon in den Posts #5 und #8 hingewiesen.

    Jetzt postest du wieder neue Fehlermeldungen, die ähnlich wie in Post #9 darauf hindeuten, dass du wieder ein anderes als ein Twenty-irgendwas-Standardtheme ausgewählt hast und/oder deine PlugIns wieder aktiviert hast.

    Gruß
    helix
     
  17. MisterSecond

    MisterSecond Member

    Registriert seit:
    25. April 2016
    Beiträge:
    9
    Zustimmungen:
    0
    Was soll das denn jetzt? Ich habe hier nur das getan was du mir vorgeschlagen hast. Und bei jeder Änderung das Ergebnis hier gepostet.
    Ausserdem habe Ich von dem was du da von dir gegeben hast keine blassen Schimmer

    Edit:
    Jetzt habe ich nochmal nen standard Theme genommen und die Plugins alle ausgeschaltet. Nun sehe ich keine Debugmeldungen mehr.
    Editor, geht immer noch nicht!
     
    #17 MisterSecond, 27. April 2016
    Zuletzt bearbeitet: 27. April 2016
  18. MisterSecond

    MisterSecond Member

    Registriert seit:
    25. April 2016
    Beiträge:
    9
    Zustimmungen:
    0
    Da man ja hier mit WP Neulingen und nicht Programmieren gleich mit dem Vorschlaghammer bearbeitet, bin ich nun selber zu einer Lösung gekommen.
    Ich habe mich hierbei an diese Anleitung gehalten und einfach den Eintrag:

    meine wp_config.php hinzugefügt.
    Nun geht wieder alles wunderbar.
     
  19. helix

    helix Well-Known Member

    Registriert seit:
    28. Juli 2011
    Beiträge:
    1.808
    Zustimmungen:
    27
    … nicht Puderzucker, sondern Hilfe zur Selbsthilfe.
    Schön, dass wir dir ein Damaskuserlebnis verschaffen konnten.

    Gruß
    helix
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden