1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

WYSIWYG Editor

Dieses Thema im Forum "Allgemeines" wurde erstellt von kim88, 2. April 2008.

  1. kim88

    kim88 Member

    Registriert seit:
    16. Dezember 2007
    Beiträge:
    9
    Zustimmungen:
    0
    Hallo zusammen,

    Hab ein Upgrade auf WP 2.5 hinter mir (nach der Upgrade Anleitung). Nun funktioniert der visuelle Editor nicht mehr. An den Plugins liegt es nicht, er funktioniert auch nicht wenn ich die alle deaktiviere...

    Ich denke nicht, dass ein Screenshot was bringt aber trotzdem:
     
  2. Keiran

    Keiran Well-Known Member

    Registriert seit:
    3. Januar 2007
    Beiträge:
    472
    Zustimmungen:
    0
    Hast du die aktuelle Java-Version installiert?
     
  3. kim88

    kim88 Member

    Registriert seit:
    16. Dezember 2007
    Beiträge:
    9
    Zustimmungen:
    0
    Ja habe ich. funktionierte ja auch bis vor dem Update.
     
  4. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.823
    Zustimmungen:
    1
    Es könnte mit der Kompression der TinyMCE-Javascript-Daten zusammenhängen. Zum Abschalten der Kompression kann man folgendes Plugin verwenden:
    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Oder hier als Download: plw123_mce_no_compress_0_10.zip


    Gruß
    Ingo
     
  5. Alphawolf

    Alphawolf Well-Known Member
    Ehrenmitglied

    Registriert seit:
    31. Mai 2005
    Beiträge:
    3.315
    Zustimmungen:
    0
    Zusätzlich: Browser-Cache geleert? Vor allem im Header eingebundene dokument-externe JS-Dateien werden sehr gerne mal gecashed (Tipp 2). Vielleicht holt er noch die alten Daten, findet aber ggf. einige nicht mehr...
     
  6. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.823
    Zustimmungen:
    1
    Noch zwei Hinweise:
    1. Wordpress legt im Uploads-Verzechnis ein Unterverzeichnis 'js_cache' an und speichert dort den gesamten Inialisierungsteil für dem TinyMCE in einer Datei entweder als .gz oder .js ab. Alle Dateien in dem Verzeichnis sollten gelöscht werdern. Sonst werden Änderungen möglicherweise nicht wirksam.
    2. Achtung! diesen Hinweis nicht beachten.
      Bei mir hat es nicht gereicht, die Kompression abzuschalten, zudem werden die letzten drei Zeichen der Initialisierungsdaten "verschluckt", wodurch ein Javascritp-Error entsteht und der TinyMCE nicht geladen wird. Dies kann leider nicht durch ein Plugin behoben werden. Hierzu muß die Datei 'tiny_mce_config.php' im Verzeichnis '/wp-includes/js/tinymce' gepatcht werden. Im Quelltext folgende Zeilen suchen:
      PHP:
      Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
      Darunter muß ein String mit drei Leerzeichen hinzugefügt werden:
      PHP:
      Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
      Ende Achtung!
    Ich weiß zwar nicht, wie das Problem zustande kommt und es wird nur an den Symptomen rumgedoktert, aber so funktioniert bei mir der TinyMCE unter Wordpress 2.5.

    Derzeit Passiert das alles noch in meinem loakalen Testsystem. Vielleicht zur Info: Windows 2000, Apache/1.3.33 (Win32) mod_gzip/1.3.26.1a PHP/5.2.4

    Hinweis 2 ist falsch, falls schon etwas an der Datei geändert wurde, diese wieder durch das Original aus der Installtion ersetzen.
    Das Problem liegt an falsch kodierten PHP-Dateien (siehe Hinweis weiter unten). Das können Plugins oder auch die my-hacks.php sein.
    Nachtrag: Es kann auch die wp-config.php sein. Entweder ist die falsch kodiert oder es stehen da Leerzeichen oder Leerzeilen außerhalb das umrahmenden <?php ... ?>. Meist gehen dann auch RSS-Feeds nicht bzw. wenn man sich den HTML-Text der Seite anschaut, stehen da ganz am Anfang Leerzeichen oder Leerzeilen.

    Gruß
     
    #6 Putzlowitsch, 3. April 2008
    Zuletzt bearbeitet: 3. April 2008
  7. codestyling

    codestyling WPD-Team

    Registriert seit:
    30. März 2008
    Beiträge:
    1.904
    Zustimmungen:
    0
    Wenn in einer Datei, die ein PHP System verarbeitet, das auf UNICODE Basis arbeitet, 3 Zeichen verschwinden, hängt das damit zusammen, dass der UNICODE Kodierungsmarker, der normalerweise immer an Anfang einer Datei steht und 3 Byte groß ist, fehlt.

    Diese passiert immer dann, wenn mein eine Datei, die UNICODE ist, mit einem Editor bearbeitet, der diese zwangsweise in ANSI konvertiert.

    Wenn du z.B. ein PHP File, das selbst UNICODE ist, mit z.B. TextPad öffnest, weißt dich dieser Editor darauf hin, das UNICODE konvertiert wird. Dieser Editor kann aber auch UNICODE bearbeiten, wenn man es will.

    Nur nicht alle Texteditoren können UNICODE. Und ich habe schon einige Plugins gesehen, bei denen Release Infos oder Greeting Links als UNICODE drin waren und somit das ganze Plugin PHP Unicode ist.

    Fazit: Wenn man einen Editor benutzt, um Files zu ändern, sollte man auch einen nehmen, der UNICODE erhält, falls es drin ist.
     
  8. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.823
    Zustimmungen:
    1
    Ich verwende NotePad++, da habe ich bisher angenommen, das der mit Unicode umgehen kann. Wenn ich die Datei 'tiny_mce_config.php' öffne, wird mir als Format ANSI angezeigt.

    [del]Gut, dann ist das ein wichtiger Hinweis für die WP-Entwickler
    Zumindest tritt das Problem mit den originalen, unbearbeiteten Dateien der WP-Installation auf.[/del]

    Gruß
    Ingo
     
    #8 Putzlowitsch, 3. April 2008
    Zuletzt bearbeitet: 3. April 2008
  9. kim88

    kim88 Member

    Registriert seit:
    16. Dezember 2007
    Beiträge:
    9
    Zustimmungen:
    0

    Tut mir Leid, dass ich erst jetzt antworte (ich hab in meinen Ferien wieder mal mein RL Leben an der Sonne genossen =)) ). Daaaanke..

    Das Plugin funktioniert super. Danke euch allen =)

    MFG

    kim88
     
  10. Janshi

    Janshi Well-Known Member

    Registriert seit:
    11. Februar 2007
    Beiträge:
    98
    Zustimmungen:
    0
    Ich hab wordpress 2.5 mittlerweile zum 15. Mal installiert und nun geht plötzlich der visuelle Editor :confused:
     
  11. marcolino75

    marcolino75 New Member

    Registriert seit:
    5. März 2008
    Beiträge:
    1
    Zustimmungen:
    0


    Danke Ingo das hat mir endlich die neue Version zum laufen gebracht.
     
  12. bluemel-eu

    bluemel-eu Well-Known Member

    Registriert seit:
    29. März 2007
    Beiträge:
    45
    Zustimmungen:
    0
    Danke auch von meiner Seite. TinyMCE klappt jetzt super.
     
  13. piri

    piri Member

    Registriert seit:
    19. März 2006
    Beiträge:
    14
    Zustimmungen:
    0
    Klappt nicht ...

    ...Klappt, klappt nicht!

    Die Navigationsleiste (oder wie die Button nun heißen mögen) sind mal da und mal nicht. Aus unerfindlichen Gründen verschwinden sie ohne mein Zutun. Unterverzeichnis /js_cache habe ich geleert, das Plugin installiert und trotzdem ist nix da!

    Was kann ich jetzt noch machen? Ich muss dazu sagen, ich habe nicht viel Ahnung und möchte natürlich mein Weblog auch nicht zerschießen. Auf Blogdesk umzusteigen nützt auch nichts, denn das kriege ich erst gar nicht installiert!

    Ich bitte um Hilfe!
     
    #13 piri, 10. April 2008
    Zuletzt bearbeitet: 10. April 2008
  14. dalclitch

    dalclitch New Member

    Registriert seit:
    6. Mai 2008
    Beiträge:
    1
    Zustimmungen:
    0
    Ich habe ein sehr ähnliches Problem. Die Buttons über meinem visuellen Editor sind von heute auf morgen vollständig verschwunden, der Text wird im Editorfenster jetzt nur noch in Form winziger roter Punkte dargestellt. Markiere ich den "Text" mit der Maus, erscheint der HTML-Code.

    Ich habe mehrere Blogs - alle auf 2.51 upgedatet, das Problem taucht nur bei einem davon auf.

    Ich habe - wie hier im Thread beschrieben - den js-cache im Ordner Uploads gelöscht und das Plugin plw123 ... installiert. Hat nichts am Problem geändert.

    Ich habe TinyMCE Advance deinstalliert und neu installiert. Hat nichts geändert.

    Ich habe 2.51 erneut installiert - hat nichts geändert.

    Auch den Browser-Cache habe ich x-mal geleert.

    Was kann ich jetzt noch ausprobieren? :(
     
  15. decx

    decx New Member

    Registriert seit:
    12. Mai 2008
    Beiträge:
    1
    Zustimmungen:
    0
    hatte das selbe Problem -> gelöst

    Hatte das selbe Problem mit dem nicht mehr nutzbaren wysiwyg-editor
    ich brauch ihn zwar nicht aber unbedarfte Leute denen ich wp aufgezwungen hab sehen das natürlich nicht so locker
    das plugin hat bei mir nichts gebracht

    im endeffekt war die .htaccess datei in meinem wp-include verzeichnis schuld die hatte nämlich ausversehen verhindert das auf php-dateien zugegriffen werden konnte

    ich blödmann :)
     
    #15 decx, 12. Mai 2008
    Zuletzt bearbeitet: 12. Mai 2008
  16. JonnyX

    JonnyX Well-Known Member

    Registriert seit:
    5. November 2006
    Beiträge:
    107
    Zustimmungen:
    0
    also ich hatte das Problem beim Absichern meiner WP installation, da ich die .htaccess zu stark eingestellt habe ...

    Also same Fehler wie decx ^^
     
  17. Alphawolf

    Alphawolf Well-Known Member
    Ehrenmitglied

    Registriert seit:
    31. Mai 2005
    Beiträge:
    3.315
    Zustimmungen:
    0
    Von einem Ossi hätte ich eigentich mehr erwartet. :mrgreen: ;)
     
    #17 Alphawolf, 13. Mai 2008
    Zuletzt bearbeitet: 13. Mai 2008
  18. Neomania

    Neomania Member

    Registriert seit:
    14. Mai 2008
    Beiträge:
    6
    Zustimmungen:
    0
    Hallo zusammen.
    Ich bin seit zwei Tagen nur diesem Phänomen auf der Spur und es funktioniert absolut keiner der ganzen Tipps, die ich hier und im amerikanischen Forum gefunden habe.
    Ich bin Designer und kein Coder, habe für eine Kundin ein WP-Blog eingerichtet und die kommt natürlich mit der reinen HTML Darstellung ohne Wysiwyg Vorschau gar nicht zurecht. Ich persönlich finde es auch recht anstrengend.

    Ich habe Tiny MCE neu installiert
    Cachefiles gelöscht, Browsercache gelöscht.
    Plugins deaktiviert
    Das Antikomprimierungs Plugin installiert.
    Tiny MCE Advanced installiert
    Ich habe auch keine htaccess Files im root liegen.

    Seit dem Update auf 2.51 funktioniert der visuelle Texteditor nicht mehr.
    Manchmal zeigt er nach dem Klick auf den HTML Button auch den gesamten Text in weißer Schrift auf weißem Grund an. Erst sichtbar, wenn man in dem Fenster etwas selektiert. Danach kommt man auch nicht zurück zur "Normal-Darstellung". Erst wenn man einen neuen Artikel auswählt habt man wenigstens die Code-Ansicht.

    Wie schon gesagt, ich bin kein Programmierer und wäre über jeden weiteren Tipp dankbar. Vielen Dank im voraus.
     
  19. codestyling

    codestyling WPD-Team

    Registriert seit:
    30. März 2008
    Beiträge:
    1.904
    Zustimmungen:
    0
    Mal eine Frage: benutzt das Theme, mit dem der(die) Kund(e/in) öffentlich ist, weiße Schrift auf dunklem Grund ?
    Es wird u.U. das Theme Stylesheet für die Vorschau benutzt nur ist das Admin Stylesheet nicht "hart" genug gegen Überladungen durch Userstyles.
    Somit kann es zu einer Mischung aus Kundenstyle und Admin Style kommen, der weisse Schrift (Kundenstyle) auf weissem Grund(Admin Style) darstellt.
     
  20. Neomania

    Neomania Member

    Registriert seit:
    14. Mai 2008
    Beiträge:
    6
    Zustimmungen:
    0
    @codestyling Danke für die schnelle Reaktion.
    Das ist jetzt eigentlich auch nur ein zusätzliches Problem, denn im Theme wird nur schwarzer und etwas farbiger Text auf Weiß verwendet. Wo diese Stilzuweisung herkommt, weiß ich allerdings auch nicht.

    Das Hauptproblem bleibt der fehlende visuelle Editor.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden