1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

WYSIWYG Editor

Dieses Thema im Forum "Allgemeines" wurde erstellt von kim88, 2. April 2008.

  1. marX

    marX Well-Known Member
    Ehrenmitglied

    Registriert seit:
    5. Oktober 2006
    Beiträge:
    12.943
    Zustimmungen:
    0
    Welche? Speziell die JS-Fehler.

    :shock: Die haben da ja gar nichts verloren! Welche sind das?

    Gibts noch mehr PHP-Fehler im error.log?
    Wie gehe ich am besten vor, wenn Fehler in meinem Blog auftreten? « WordPress Deutschland FAQ

    Hast und alle Daten noch mal vollständig (d.h. inkl. vorherigem Löschen) neu hochgeladen? Übertragungsfehler sind nicht so selten wie man vielleicht denkt... ;)

    Läuft auf dem 1&1-Server PHP5 oder PHP4?

    Welche Plugins etc.?
     
  2. Hansi10

    Hansi10 Member

    Registriert seit:
    18. November 2008
    Beiträge:
    5
    Zustimmungen:
    0
    Hallo marX,

    wenn ich die Fehlerkonsole im Firefox leere und dann aus dem funktionierenden Frontend in den Adminbereich gehe, dann werden gleich wieder über 30 css-Warnungen angezeigt.

    Die sehen ungefähr so aus:
    oder so:
    Hier wird wohl die CSS-Datei nicht richtig geladen.

    Dann habe ich zwei Javascript-Fehler die lauten so:

    und so:
    Dies hat vermutlichmit PHP zu tun. Kommt auch zweimal vor:
    Wenn ich jetzt zu "Schreiben" wechsle, dann gehts mit den Fehlermeldungen weiter: Am besten hier gleich als Bild:

    http://www.dauercamperweb.com/ebay/fehler_wordpress.gif

    Das Frontend wird übrigens fehlerfrei angezeigt.

    Es handelt sich um die Standardinstallation ohne eigene Änderungen. Als Plugins hatte ich 123 TinyMCE No Compress und TinyMCE Advanced installiert, aber ohne Erfolg.
     
  3. marX

    marX Well-Known Member
    Ehrenmitglied

    Registriert seit:
    5. Oktober 2006
    Beiträge:
    12.943
    Zustimmungen:
    0
    Eigentlich eindeutig. jQuery ist eine JavaScript-Bibliothek. Ohne die geht im Backend fast nichts.

     
  4. Hansi10

    Hansi10 Member

    Registriert seit:
    18. November 2008
    Beiträge:
    5
    Zustimmungen:
    0
    Ja, Ja ich habe mehrmals vollständig gelöscht (auch die Datenbank) und dann vollständig übertragen und neu installiert. In der Tat hatte ich aber jedesmal unterschiedliche Ergebnisse. Teilweise wurde auch das Frontend nicht richtig angezeigt.

    Ich habe auch die Original-Zip Datei nochmals entpackt und auch die wp_config.php neu erstellt. Vielleicht sollte ich in Filezilla noch etwas besonderes einstellen? Ich kann ja mal versuchen, die Daten mit dem internen FTP-Programm von 1und1 zu übertragen.
     
  5. marX

    marX Well-Known Member
    Ehrenmitglied

    Registriert seit:
    5. Oktober 2006
    Beiträge:
    12.943
    Zustimmungen:
    0
    Dateirechte ( chmod ) würde mir spontan noch einfallen, da gabs gerade erst in einem Thread nebenan Probleme.
     
  6. Hansi10

    Hansi10 Member

    Registriert seit:
    18. November 2008
    Beiträge:
    5
    Zustimmungen:
    0
    Ich versteh wirklich die Welt nicht mehr. Jetzt habe ich alles durchprobiert, was irgendwie möglich ist. Ich habe sogar WordPress bei einem anderen Provider installiert. Dies ist ein Typo3-Provider (J-Weiland.net). Dort läuft ein CMS von mir und ein PHP-Internetshop. Aber ich bekomm auch dort dieses WordPress nicht so zum laufen, dass die Fehler im Editor verschwinden.

    Ich habe Wordpress nochmals frisch heruntergeladen, nicht mit 7-zip, sondern mit einem anderen Programm entzippt. Ich habe die wp-config.php verglichen ob irgendwo Leerzeilen sind. Ich weiß jetzt wirklich nicht mehr weiter. Bin ich denn so blöd :confused:. Vielleicht sollte ich es doch wieder mit Joomla versuchen.

    Also nochmal: Ich habe genau nach Anleitung bei zwei verschiedenen Providern es nicht geschafft, die Standardinstallation von WordPress so hinzubekommen, dass es ohne Scriptfehler arbeitet. Es sieht bei beiden Providern identisch aus. Ich habe Wordpress neu heruntergeladen und mit einem anderen Zip-Programm entpackt. Ich habe alle Caches geleert und mit verschiedenen Browsern und Rechnern gearbeitet. Nur auf meinem XamPP-Bereich läuft es einwandfrei.

    Nur eines war immer gemeinsam: Der Upload mit Filezilla. Vielleicht sollte ich es doch mit einem anderen Programm versuchen.
     
  7. Hansi10

    Hansi10 Member

    Registriert seit:
    18. November 2008
    Beiträge:
    5
    Zustimmungen:
    0
    Ich glaub ich hab was gefunden. Anscheinend hat Filezilla nicht alles übertragen. Zum Beispiel sind im js-Ordner nur die Dateien vorhanden und nicht die Unterordner.

    Da ich meinen Rechner frisch aufgesetzt habe und auch eine neue Version von Filezilla installiert, habe ich wohl irgendwo in den Einstellungen etwas übersehen und es werden nicht alle Ebenen übertragen. Natürlich will ich auch die Unterordner übertragen. Aber für alle, die dieses Problem auch haben, ist die vielleicht ein Hinweis.

    Gruß, Hansi

    PS. Habe gerade rausgefunden, dass wohl in der Version Filezilla 3.1.5.1 ein Bug vorliegt. Auch andere User berichten von Problemen mit fehlenden Ordnern.
     
    #47 Hansi10, 19. November 2008
    Zuletzt bearbeitet: 19. November 2008
  8. harry22

    harry22 Well-Known Member

    Registriert seit:
    29. Oktober 2008
    Beiträge:
    179
    Zustimmungen:
    0
    Ich würd dasgen das TinyMCE-Problem (WYSIWYG) muß man hier im Forum irgenwie als Spezail darstellen. Ich lese auch überall, dass Leut Probelme damit haben. Ich auch. Inzwichen bin ich auf das Plugin FCK... umgestiegen und bin soweit zufrieden. Aber ich würde gerne TinyMce nutzen. Mich nervt es auch schon lange, dass das nicht so zuverlässig klappt.

    _____________________
    Einfach was für die Umwelt tun.
    WordPress › Meine CO2 Kampagne WordPress Plugins
     
  9. Memorandum

    Memorandum Member

    Registriert seit:
    26. April 2008
    Beiträge:
    24
    Zustimmungen:
    0
    Ich habe das selbe Problem mit dem Editor und aufgrund der beiden Threads hier im Forum auch vermutet, dass es an der aktuellen Version von FileZilla lag...
    Ein Wechsel zum Nightly Build mit erneutem Update hat allerdings nichts gebracht. Ich bin ratlos :confused:

    [Update:]
    Okay, ich habe jetzt einfach nochmal manuell alle Ordner und Dateien in wp-includes/js auf Vorhandensein überprüft. Folgende sollten da sein, dann geht es wieder:
    Ordner: crop, jquery, scriptaculous, swfupload, thickbox and tinymce.
    Dateien: autosave.js, colorpicker.js, prototype.js, quicktags.js, tw-sack.js, wp-ajax-response.js and wp-lists.js.
     
    #49 Memorandum, 30. November 2008
    Zuletzt bearbeitet: 30. November 2008
  10. detlefhinrichs

    Registriert seit:
    11. Juli 2008
    Beiträge:
    8
    Zustimmungen:
    0
    @Putzlowitsch

    Hallo!
    Da hat Ingo ja das Plugin hier vorgeschlagen.
    In welches Verzeichnis soll das Plugin geladen werden. Frage vom Anfänger!:roll:
     
  11. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.823
    Zustimmungen:
    1
    Naja, ins Pluginverzeichnis halt, üblicherweise /wp-content/plugins. :)

    Ich bin aber nicht sicher, ab das Plugin überhaupt noch funktioniert, es war mal für WP 2.5 gemacht worden. Seitdem hat sich beim TinyMCE einiges geändert, meine ich.

    Gruß
    Ingo
     
  12. ff-webdesigner

    Registriert seit:
    19. Februar 2007
    Beiträge:
    10
    Zustimmungen:
    0
    und wieder einer... hab jetzt restlos alle tipps durch, nichts bringt mir den tiny mce wieder her, in keinem browser.

    wordpress nervt. zum ersten mal, aber richtig.
     
  13. Boombatze

    Boombatze Member

    Registriert seit:
    29. Dezember 2008
    Beiträge:
    13
    Zustimmungen:
    0
    Also ich hab Wordpress runtergeschmissen und das aktuelle drauf und dann ging wieder alles ...
     
  14. Indraa

    Indraa Member

    Registriert seit:
    19. April 2009
    Beiträge:
    15
    Zustimmungen:
    0
    Ich hol das Thema mal wieder hoch. Genau wie oben beschrieben, geht es mir auch. Kann jemand helfen????
     
  15. Indraa

    Indraa Member

    Registriert seit:
    19. April 2009
    Beiträge:
    15
    Zustimmungen:
    0
    Einen kleinen Schritt bin ich weiter. Ich habe einen Hinweis zum Fehler gefunden:

    tinyMCE ist undefiniert
    post-new.php

    Das Objekt unterstützt diese Eigenschaft oder Methode nicht.
    Code: 0

    Hat vielleicht jetzt jemand eine Idee, woran es liegt und was ich tun kann? Bin über jeden Tipp dankbar.
     
  16. onlinevergleich

    onlinevergleich Active Member

    Registriert seit:
    4. Juni 2011
    Beiträge:
    37
    Zustimmungen:
    0
    Hey, wie bekomme ich das Plugin von Putzlowitsch zum laufen? Ich kann es irgendwie nicht downloaden und ich weiß net, wohin dann mit dem php-code...
     
  17. infected

    infected Well-Known Member

    Registriert seit:
    9. Juli 2006
    Beiträge:
    9.816
    Zustimmungen:
    1
    Herunterladen, entpacken und ins Pluginverzeichnis kopieren. Danach über den Menüpunkt Plugins aktivieren.
     
  18. onlinevergleich

    onlinevergleich Active Member

    Registriert seit:
    4. Juni 2011
    Beiträge:
    37
    Zustimmungen:
    0
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden