1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

WYSIWYG und Smilie Buttons?

Dieses Thema im Forum "Plugins und Widgets" wurde erstellt von LastOne, 11. März 2006.

  1. LastOne

    LastOne Well-Known Member

    Registriert seit:
    17. Oktober 2005
    Beiträge:
    157
    Zustimmungen:
    0
    Hallo!

    Nach intensiver Board + Google suche bin ich leider nicht fündig geworden. Gibt es irgendwo eine Plugin Lösung wenn man den WYSIWYG benutzt und auch da smilies "reinklicken" will? Oder gehen alle Plugins nur bei ausgeschaltetem WYSIWYG?

    :(

    Ein inzwischen recht müder
    LastOne
     
  2. melina

    melina Active Member

    Registriert seit:
    6. Mai 2005
    Beiträge:
    37
    Zustimmungen:
    0
    Hallo, LastOne,

    der WYSIWYG (welcher auch immer) ist normal tinyMCE. Nun kommt es auf die Version an, die Du benutzt. Für WP 2.0 habe ich eine Anleitung zur Änderung der Optionen des WYSIWYG-Editors geschrieben: http://expertinnen-web.de/2006-86/wordpress-editor-anpassen/. emotions ist hier Dein Freund. Es sollte als Plugin vorhanden sein. Wenn nicht, geh in die Kommentare zum Beitrag, da hat Franziska den Link auf alle tinyMCE-Optionen eingefügt.
    melina
     
  3. Waldscheisser

    Waldscheisser Well-Known Member

    Registriert seit:
    1. August 2005
    Beiträge:
    145
    Zustimmungen:
    0
    Ich wollte nicht einen neuen Thread für mein Anliegen aufmachen, da ich auch probleme mit dem WYSIWYG Editor habe.

    Frage: Wie kann ich den Editor deaktivieren? In den Optionen unter Schreiben hab ich die Checkbox bereits deaktiviert, unter Benutzer auch.

    Nur leider ist der immer noch da...
     
  4. madru

    madru Well-Known Member

    Registriert seit:
    4. Februar 2006
    Beiträge:
    69
    Zustimmungen:
    0
    Ich möchte für das Blog von 2 Freundinnen gern im mitgelieferten tinyMCE die Smilies zum laufen bringen. Das emotions-PlugIn ist nun nicht dabei... Ich habe mir also die aktuelle Version von tinyMCE runtergeladen und daraus den emotions-Ordner in den PlugIn-Ordner von tinyMCE in der Installation von WordPress geladen. Dann natürlich in der Button-Array 'emotions' eingefügt. Leider passiert nun noch gar nichts... Wenn ich dann in der tiny_mce_gzip.php in diesem Abschnitt
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    noch das 'emotions' einfüge, dann geht der Editor gar nicht mehr und die Quiktacks erscheinen...

    Hat Irgendwer schon mal das PlugIn eingebaut und zum Laufen bekommen? Wenn ja, dann wie?
     
  5. LastOne

    LastOne Well-Known Member

    Registriert seit:
    17. Oktober 2005
    Beiträge:
    157
    Zustimmungen:
    0
    Hi!

    Also, nach nem bissel probieren habe ich es nun hinbekommen mit dem "emotions" plugin. Das dürfte auch dir helfen madu:

    Anleitung um Klickbare Smilies im WYSIWYG in WP 2.0.2 zu intgrieren:

    Zu erst muß man dort:
    http://sourceforge.net/tracker/index.php?func=detail&aid=1084076&group_id=103281&atid=635684

    Das Archive Herunterladen und den Ordner "Emotions" dann unter wp-includes/js/tinymce/plugins/ ablegen.

    Dann muß folgende Datei verändert werden:

    wp-includes/js/tinymce/tiny_mce_gzip.php

    Es betrifft die Zeilen 84 & 110:

    Original 84:
    $plugins = apply_filters('mce_plugins', array('wordpress', 'autosave', 'wphelp'));

    Geändert 84:
    $plugins = apply_filters('mce_plugins', array('wordpress', 'autosave', 'wphelp', 'emotions'));

    Original 110:
    $mce_buttons = apply_filters('mce_buttons', array('bold', 'italic', 'strikethrough', 'separator', 'bullist', 'numlist', 'outdent', 'indent', 'separator', 'justifyleft', 'justifycenter', 'justifyright' ,'separator', 'link', 'unlink', 'image', 'wordpress', 'separator', 'undo', 'redo', 'code', 'wphelp'));

    Geändert 110:
    $mce_buttons = apply_filters('mce_buttons', array('bold', 'italic', 'strikethrough', 'separator', 'bullist', 'numlist', 'outdent', 'indent', 'separator', 'justifyleft', 'justifycenter', 'justifyright' ,'separator', 'link', 'unlink', 'image', 'wordpress', 'separator', 'undo', 'redo', 'code', 'emotions', 'wphelp'));


    Damit sollte das Emotions Plugin dann auch in der Leiste des WYSIWYG auftauchen. Mit dem Austausch/Erweiterung der Smilies beschäftige ich mich dann morgen. ;)

    Hoffe ich konnte damit auch anderen helfen.....
     
  6. madru

    madru Well-Known Member

    Registriert seit:
    4. Februar 2006
    Beiträge:
    69
    Zustimmungen:
    0
    Genau so hatte ich es gemacht und bei mir ist das Icon im Editor nicht aufgetaucht... Ich habe das Problem jetzt anders gelöst. Ich habe das PlugIn EditorMonkey eingebaut und habe dann TinyMCE vollständig zur Verfügung.
     
  7. LastOne

    LastOne Well-Known Member

    Registriert seit:
    17. Oktober 2005
    Beiträge:
    157
    Zustimmungen:
    0
    hmm.... wie genau hast du es eingebaut? bei mir funzt es net
     
  8. madru

    madru Well-Known Member

    Registriert seit:
    4. Februar 2006
    Beiträge:
    69
    Zustimmungen:
    0
    Script editormonkey.php und Ordner editormonkey incl. Inhalt in den PlugIn-Ordner vom Wordpress geschoben und dann dem Ordner mitsammt seinem Inhalt die Dateirechte 777 gegeben. Dann im WordPress das PlugIn aktiviert und unter Optionen - EditorMonkey die Einstellungen getätigt. Läuft in 2 Blogs einwandfrei! Der eine Blog ist bei www.canhost.de (meiner www.michael.draegerhof.de) und der andere ist bei www.allincl.com (von 2 Freundinnen www.summse.net). Meiner läuft unter php4.4.2, der andere unter php5.1.2. Bei beiden laufen unterschiedliche Thems une unterschiedliche PlugIns...
     
  9. LastOne

    LastOne Well-Known Member

    Registriert seit:
    17. Oktober 2005
    Beiträge:
    157
    Zustimmungen:
    0
    Versteh ich nicht. Ist praktisch das gleiche was ich auch gemacht habe. Kannst du mir mal sagen wie du die verschiedenen Einstellungen gesetzt hast?

    Hmm, solang ich den anderen Editor nehm gehts, stell ich in den Optionen aber auf TinyMCE um gehts nimmer.... kein Menü zu sehen.....
     
    #9 LastOne, 14. März 2006
    Zuletzt bearbeitet: 14. März 2006
  10. madru

    madru Well-Known Member

    Registriert seit:
    4. Februar 2006
    Beiträge:
    69
    Zustimmungen:
    0
    EditorMonkey

    System Settings
    • Automatically use the EditorMonkey interface? aktiv
    • Automatically disable WordPress from loading the built-in WYSIWYG editor by default? aktiv
    • Override user preferences? aktiv
    Basic Interface Settings
    • Default WYSIWYG interface: TinyMCE
    • Default editing area height: 250
    • Default language: German
    • Editor toolbar button set: WordPress Controls
    File Browser/Uploader Settings
    • Allow uploads and file browsing? deaktiviert
    Spell Checker Settings
    • Spell Checker: No Spell Checker
    FCKeditor Settings
    • Graphical skin: Default
    TinyMCE Settings
    • Use Cached? deaktiviert (als ich es Testweise aktiviert hatte, wurde der Editor nicht mehr angezeigt...)
    • Use Custom Valid HTML Elements List? deaktiviert
    • Allow resizing? deaktiviert
    Bei PlugIns hab ich nichts verändert.
    Das sind alle Einstellungen und damit läuft es in beiden Blogs...
     
  11. fpechmann

    fpechmann New Member

    Registriert seit:
    13. Februar 2006
    Beiträge:
    2
    Zustimmungen:
    0
    Hallo,

    ich habe mir auch das PlugIn EditorMonkey eingebaut und beide Editoren sind jetzt nutzbar, nur die Schrift direkt im Editor ist leider sehr klein, wie kann ich diese vergößern?

    --
    Mfg
    Frank
     
  12. LastOne

    LastOne Well-Known Member

    Registriert seit:
    17. Oktober 2005
    Beiträge:
    157
    Zustimmungen:
    0
    also ich hab das jetzt auch so eingestellt wie du, es geht. auch wenn ich die optionen verändere, es geht. weiß der geier warum er gestern nicht wollte.....


    EDIT//
    das soll/muß in einer der css dateien stehen. leider ist mir bisher nicht geglückt zu identiefizieren in welcher :(
     
    #12 LastOne, 15. März 2006
    Zuletzt bearbeitet: 16. März 2006
  13. caschy

    caschy Well-Known Member

    Registriert seit:
    17. März 2006
    Beiträge:
    108
    Zustimmungen:
    0
    Vielen Dank für diesen guten Tipp!