1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

404 Fehler nach Relaunche

Dieses Thema im Forum "Allgemeines" wurde erstellt von weswesx, 16. Januar 2014.

  1. weswesx

    weswesx Member

    Registriert seit:
    12. September 2013
    Beiträge:
    14
    Zustimmungen:
    0
    Hallo Wordpressler,

    ich habe vor 4 Wochen einen Website relaunche unserer Website vollzogen, leider ohne davor die 301 redirects zu setzen :lol:

    Hinzu kommt, dass nun das Tool Qtranslate durch Wpml ersetzt werden soll.
    Aktuell bekomme ich in den Webmastertools 1200 404 Fehler Angezeigt und habe große Bedenken, dass nach dem Plugin wechsel sich diese noch steigern.

    Einen 301 redirect über die .htaccess habe ich schon versucht
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Leider passiert nach dieser Methode NICHTS:(

    Hat vill jemand eine Lösung wie ich das am besten lösen könnte ?

    Vielen Dank im Voraus
     
  2. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.879
    Zustimmungen:
    7
    Wo stehen denn die Regeln in der .htaccess-Datei, vor oder nach den Wordpress-Regeln?
    Sie müssen vor den Wordpress-Regeln stehen!

    Gruß
    Ingo
     
  3. weswesx

    weswesx Member

    Registriert seit:
    12. September 2013
    Beiträge:
    14
    Zustimmungen:
    0
    Ja die stehen vor der Wordpress-regel.
    Mir ist mittlerweile aufgefallen das die rewrite Regel ohne den languagekey am ende funktioniert..also ohne das "?lang=en$"
    Jedoch benötige ich diesen ja da die Url so heißt..

    Jemand eine Idee wie das auch mit diesem Key in der Url funktionier ?

    Grüße
    Weswesx
     
  4. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.879
    Zustimmungen:
    7
  5. weswesx

    weswesx Member

    Registriert seit:
    12. September 2013
    Beiträge:
    14
    Zustimmungen:
    0
    Ich komme hier leider nicht weiter...
    Wie muss ich den Query string denn verarbeiten ?

    Ich habe zum Beispiel 100 Seiten wo nun alle anstatt : www.url.de/ordner/seite?lang=en$ nun www.url.de/en/seite heißen..

    Kann mir jemadn Sagen wie ich diese 301 redirect Regel nun schreiben muss ?
    Und weis evtl. jemand wie lange Google braucht um die Redirects zu erkennen und meine Fehler löscht ?

    bin hier noch am verzweifeln :sad::(
     
  6. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.879
    Zustimmungen:
    7
    Könnte in etwa so funktionieren:
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Gruß
    Ingo
     
  7. weswesx

    weswesx Member

    Registriert seit:
    12. September 2013
    Beiträge:
    14
    Zustimmungen:
    0
    Ahh jetzt verstehe ich das langsam besser.
    Gehe ich richtig in der Annahme, dass ich auch einfach das so schreiben kann ?

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Weil ich muss das für mehrere Sprachen machen das heißt auch noch für

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Und vill noch als ganz blöde Frage, wo ist hier die 301 Deklarierung damit Google auch weis das da dauerhaft so geregelt ist ?

    Vielen Dank für deine super Hilfe :D
     
    #7 weswesx, 27. Januar 2014
    Zuletzt bearbeitet: 27. Januar 2014
  8. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.879
    Zustimmungen:
    7
    Nicht ganz. :)

    Also die erste Zeile wertet den Query-String aus und merkt sich die Sprache in der Variable %1. Das heißt, du mußt da nicht explizit en, it oder ru angeben. Es funktioniert mit allen Sprachen.

    Die zweite Zeile ist die eigentliche Umsetzung. Dort muß der Aufruf zum Muster der alten Seiten (aber ohne Query-String) passen, also /ordner/seite. Wobei seite wieder als Variable in $1 gespeichert wird. Aus den beiden Variablen wird dann das Ziel zusammengesetzt, also /%1/$1.

    Was ich noch vergessen habe, das sind die Parameter bei der RewriteRule. Es mußte also so aussehen:
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    L heißt, es ist die letzte Regel und R=301 bewirkt die permanente Weiterleitung.

    Ist /ordner/ in der alten Struktur immer gleich? Oder muß der in der neuen Struktur auch mit auftauchen?

    Gruß
    Ingo
     
  9. weswesx

    weswesx Member

    Registriert seit:
    12. September 2013
    Beiträge:
    14
    Zustimmungen:
    0
    Alles klar, man lernt also nie aus =)
    Ich glaube mit dem /Ordner habe ich mich falsch ausgedrückt...

    Die neue Ordnerstruktur ist zu 99,9 % die gleiche wie davor also die einzige Änderung ist von :

    www.url.de/irgendeinOrdner/irgendeineSeite/?lang=en$

    zu

    www.url.de/en/irgendeinOrdner/irgendeineSeite
    (Anstatt dem "en" kann auch it,pl stehen)

    Leider musste ich zusätzlich einen Ordner entfernen, dass heißt das aus:

    www.url.de/alterOrdner/seiten
    nun
    www.url.de/seiten geworden ist, die anderen Ordner sind jedoch vorhanden.
    Welches ich auch noch redirecten muss.

    Wirkt sich der erste redirect dann auch auf den darauf folgenden Redirect aus ? (Im Bezug auf den Sprachwechsel)


    Vielen Vielen Dank für deine Hilfe:D
     
  10. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.879
    Zustimmungen:
    7
    Ich frage einfach nochmal nach.

    Es gibt einen Sonderfall /alterOrdner/seite der jetzt nur noch /seite heißt, für den auch die Auflösung der Sprache mit ?lang=ln -> /ln/seite funktionieren soll, aber auch ohne Sprache umgeleitet werden muß.

    Ansonsten soll für alle anderen alten Ordner mit Seiten die Sprache jetzt anstelle als Parameter davor stehen, also /ln/Ordner/Seite.

    Richtig so?

    Dann könnte es so funktionieren:
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Eventuell mußt Du bei den RewriteRules den ersten Schrägstrich nach dem ^ rausnehmen.

    Gruß
    Ingo
     
  11. weswesx

    weswesx Member

    Registriert seit:
    12. September 2013
    Beiträge:
    14
    Zustimmungen:
    0
    Genau so ist der Plan, habe es gleich einmal ausprobiert und tada ein erster Erfolg :p

    Aber 2 Sachen stimmen leider noch nicht ganz, aber ich glaube das liegt an meiner ersten falschen Beschreibung:
    Er soll mir von www.url.de/ordner/alterOrdner/seite auf www.url.de/ordner/seite weiterleiten.

    Da habe ich mich leider in meinem vorherigen Post vertippt :(:oops:

    Und der Sprach Redirect funktioniert, jedoch lässt er das "?Lang=en" am Ende der Url auch noch mit stehen, dass beeinflusst zwar nicht die Funktionalität, sieht aber verwirrend aus.

    Hättest du mir hierzu evtl noch eine Lösungsvorschlag ?

    Vielen Vielen Dank ohne dich wäre ich wohl aufgeschmissen :grin:
     
  12. weswesx

    weswesx Member

    Registriert seit:
    12. September 2013
    Beiträge:
    14
    Zustimmungen:
    0
    Im nach hinein stellt sich auch heraus, dass der Sprach redirect bei :

    www.url.de/irgendwas/?lang=en funktioniert

    ABER bei

    www.url.de/irgendwas/2tesIrgendwas/?lang=en

    nicht.. an was könnte das liegen ?:cry:
     
  13. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.879
    Zustimmungen:
    7
    So, neue Version :)
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Das Fragezeichen am Ende der neuen URL entfernt den Query-String.
    Ansonsten habe ich das bei mir eben mal getestet, es funktioniert so wie es soll, auch mit
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Gruß
    Ingo
     
  14. weswesx

    weswesx Member

    Registriert seit:
    12. September 2013
    Beiträge:
    14
    Zustimmungen:
    0
    Super, damit funktioniert das ganze einwandfrei =)
    Leider ist mir nun nun aufgefallen, dass bei der alten Seiten (statisch) die seiten z.B. ordner/ordner/seitenname.html hießen.

    Nun haben diese Seiten jedoch keinen "richtigen Namen" mehr (cms = wordpress) sondern es heißt nur noch ordner/ordner/seitenname/
    (hinter dem letzten / würde eig. index.php stehen, welches ich jedoch durch rewrite entferne):
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Gibt es hierfür auch eine Weiterleitungsregel welche ich anwenden kann?
    Da Google mir natürlich jetzt den Fehler meldet, dass diese Seite nicht mehr da wäre.. ?
     
  15. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.879
    Zustimmungen:
    7
    Also die Startseite hieß index.html und alle anderen Seiten z.B. /ordner/ordner/irgendwas.html, ggf. mit Sprache dann /ordner/ordner/irgendwas.html?lang=de, richtig?

    Dann könnte es so funktionieren:
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Gruß
    Ingo
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden