1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Automatisches Update bringt Fehlermeldung

Dieses Thema im Forum "Installation" wurde erstellt von thor.sten, 10. September 2012.

  1. thor.sten

    thor.sten New Member

    Registriert seit:
    10. September 2012
    Beiträge:
    2
    Zustimmungen:
    0
    Wollte heute endlich von 3.0.4 auf 3.4.2 upgraden.
    Jedes mal bekomme ich folgende Fehlermeldung:

    Fatal error: Out of memory (allocated 29622272) (tried to allocate 3675644 bytes) in /homepages/20/d29115392/htdocs/wp-includes/class-http.php on line 1402

    Nachdem immer auf eine zu kleinen PHP-Memory hingewiesen wird, hab ich WP-Memory-Usage installiert. Dies zeigt mir folgende Werte an:


    • PHP Version : 5.2.17 / 32Bit OS
    • Memory limit : 90 MByte
    • Memory usage : 24.37 MByte
    Hat jemand ne Idee?
     
  2. Marcus[IS]

    Marcus[IS] Well-Known Member

    Registriert seit:
    23. August 2009
    Beiträge:
    5.066
    Zustimmungen:
    20
    Hi,

    du könntest versuchen, während des Updatevorgang die Plugins alle zu deaktivieren und nach Abschluss des Updates die Plugins wieder zu aktivieren.
    Meistens hilft das und ist auch sicherer, da aktive Plugins auch schon mal ein Automatisches Update daneben gehen lassen.
    war zumindest bei älteren WordPress Versionen immer so und ich denke diese Regel sollte man auch Heute noch beherzigen. ;)

    Zu dem Problem an sich;
    Ich hatte meine Blogs früher bei 1und1 gehostet und dort sollte ich angeblich auch immer 90M im memory Limit zur Verfügung haben.
    Doch aus irgend einem Grund konnte ich diese nicht nutzen und meine Blogs knickten bei 30M auch immer ein.
    Ich könnte mir denken, dass es bei dir ähnlich ist.
    Du solltest dies bezüglich mal deinen Provider fragen, warum WordPress bei deinem Webspace bei 30M einknickt und die Systeminformation aber sagt, du hast 90.
     
  3. Marcus[IS]

    Marcus[IS] Well-Known Member

    Registriert seit:
    23. August 2009
    Beiträge:
    5.066
    Zustimmungen:
    20
    Nachtrag;

    Ich sehe gerade, dass du eine recht alte WordPress Version fährst.
    Mache vorher zur Sicherheit ein Backup von der Datenbank und vom Blog, falls es doch daneben geht.
    Anleitungen dazu sind in der FAQ zu finden. ;)
     
  4. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.822
    Zustimmungen:
    0
    Die Frage ist bezüglich 1&1 recht einfach zu beantworten. Es gibt für alle Hosting-Pakete nur eine php.ini-Datei, welche die maximalen Werte (die von den teuren Paketen) enthält. Die eigentliche Begrenzung der Ressourcen erholgt dann auf Betrienssystemebene.
    Hier findest Du eine Übersicht der Limits:
    http://hosting.1und1.de/FeaturePerformance

    Diese gelten für die aktuellen Hostingpakete. In früheren Hostingpaketen war die Begrenzung immer mit 30M wirksam, egal wie teuer das Paket war.

    Eventuell wäre ein Paketwechsel in ein aktuelles Paket (ab Dual Basic) eine Option, um das Problem zu beheben.

    Gruß
    Ingo
     
  5. Diandra

    Diandra Well-Known Member

    Registriert seit:
    8. August 2009
    Beiträge:
    83
    Zustimmungen:
    0
    Hallo,

    ich bekomme nach dem automatischen Update diese Fehlermeldung:

    Fatal error: Call to a member function add_rewrite_tag() on a non-object in /home/www/0000/html/xxxx/wp-includes/rewrite.php on line 51

    Kann mir jemand sagen, was das bedeutet?

    LG Iris
     
  6. Marcus[IS]

    Marcus[IS] Well-Known Member

    Registriert seit:
    23. August 2009
    Beiträge:
    5.066
    Zustimmungen:
    20
    Back from east for weekend... :)

    @putzlowitsch;
    Ja das Problem bei mir war, dass ich ja laut Vertrag 90M haben sollte, da mein paket damals aufgewertet wurde.
    Doch als ich den Support damals damit konfrontierte, sah man sich nicht in der Lage mir zu helfen.
    War dann verständlich, dass ich mich nach einer Alternative umsehen musste. ;)

    @diandra;
    Variante Eins;
    es könnte eventuell sein, dass ein Plugin quer schießt.
    Als ich die Fehlermeldung Fatal error: Call to a member function add_rewrite_tag() on a non-object in Google eingab, hatte ich ein paar Einträge im englischen Forum von WordPress.org gefunden, die sich auf ein podcast Plugin bezogen, das plötzlich mit WordPress 3.0 nicht mehr klar kam.

    Du könntest versuchen per FTP Programm den Plugin Ordner umzubenennen, damit WordPress erst mal die Plugins deaktiviert.
    Sollte die Fehlermeldung dann nicht mehr auftauchen, ist es definitiv ein Plugin.
    Gehst dann einfach hin und benennst den Ordner wieder plugins und aktivierst dann im backend ein Plugin nach dem anderen.
    Taucht dann die Fehlermeldung wieder auf, hast du den Übeltäter.

    Variante Zwei;
    ich rate mal, aber du hast die Plugins während des Auto Update nicht deaktiviert?
    Gut möglich das etwas daneben gegangen ist.
    Also auch hier der Tipp, die Dateien per Hand über das FTP Programm nochmals auf den Webspace schieben.
     
  7. Diandra

    Diandra Well-Known Member

    Registriert seit:
    8. August 2009
    Beiträge:
    83
    Zustimmungen:
    0
    Hi Marcus,

    hab vielen Dank für deinen Tipp ... nun hat es geklappt :)

    LG Iris
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden