1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

WP 5.6 Chart wird in verbindung mit DB nicht angezeigt

Dieses Thema im Forum "Plugins und Widgets" wurde erstellt von roemi2, 8. Oktober 2022.

  1. roemi2

    roemi2 Member

    Registriert seit:
    8. Oktober 2022
    Beiträge:
    10
    Zustimmungen:
    0
    Hallo,

    ich habe ein funktionierendes Script (geklaut und) eingebaut. Mit diesem erstelle ich erfolgreich ein Liniendiagramm.
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Sobald ich aber das Array Wert per SQL (hier nun auskommentiert) füllen will, wird das Diagramm nicht mehr angezeigt.
    Selbst wenn ich nur
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    schreibe kommt schon der Alt-Text "...kann nicht angezeigt werden".

    Ich bin mir sicher irgendwo nur einen Denkfehler zu machen ... aber Wald | Bäume ... ich sehe ihn nicht.

    Danke

    roemi2 (weil sich roemi nicht mehr anmelden kann :)
     
  2. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    10.551
    Zustimmungen:
    1.489
    $wpdb und alles was darauf aufbaut existiert nicht, weil WordPress in Deinem Code nicht läuft. Siehe auch Error Log Deines Servers.

    Ergänze das hier mit passendem Pfad am Beginn der Datei, das startet den WordPress Code (ohne Theme Templates zu laden):
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
     
  3. roemi2

    roemi2 Member

    Registriert seit:
    8. Oktober 2022
    Beiträge:
    10
    Zustimmungen:
    0
    Hallo und Danke,

    aber... selbst wenn ich den Pfad so
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    vorgebe, wird das Script nicht ausgeführt.
    Kommentiere ich den Aufruf aus, läuft's :(

    Römi
     
  4. r23

    r23 Well-Known Member

    Registriert seit:
    9. Dezember 2006
    Beiträge:
    6.371
    Zustimmungen:
    415
    Vermutlich verlinkst du auf deine chart grafik mit
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!

    Hier fehlt dann in deinem PHP alles was mit WordPress zu tun hat. Auch deine Datenbankverbindung steht dir nicht zur Verfügung.

    https://www.php-einfach.de/mysql-tutorial/komplexere-datenabfrage/
     
  5. roemi2

    roemi2 Member

    Registriert seit:
    8. Oktober 2022
    Beiträge:
    10
    Zustimmungen:
    0
    Jo :oops: ... das war die Lösung :)

    Danke Euch.
     
  6. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    10.551
    Zustimmungen:
    1.489
    Was genau war die Lösung?
     
  7. roemi2

    roemi2 Member

    Registriert seit:
    8. Oktober 2022
    Beiträge:
    10
    Zustimmungen:
    0
    Hallo und Sorry,
    Du hast Recht. Hier wie ich es nun gemacht habe

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Römi
     
  8. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    10.551
    Zustimmungen:
    1.489
    Ok, das ist jetzt ein Ansatz komplett ausserhalb von WordPress. Danke für die Aufklärung, evtl. hilft es auch anderen weiter.

    Über WordPress $wpdb würde es es wie oben beschrieben funktionieren, wenn der Pfad passt.
     
  9. roemi2

    roemi2 Member

    Registriert seit:
    8. Oktober 2022
    Beiträge:
    10
    Zustimmungen:
    0
    Hallo b3317133,

    das mit $wpdb glaube ich auch, aber ... mein immer wieder gern genommenes Problem mit den Pfaden ;)
    Ich hab das Diagramm wo ich es haben wollte, bin mir aber momentan nicht sicher ob mir das so hilft :cool:

    Römi
     
  10. roemi2

    roemi2 Member

    Registriert seit:
    8. Oktober 2022
    Beiträge:
    10
    Zustimmungen:
    0
    Hallo,

    ein kleines Erfolgserlebnis zur Info: Nachdem ich die "wp-blog-header.php" per "relativer Pfad" eingebunden habe, klappt es auch.

    Danke

    Römi
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden