1. Herzlich Willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Codestyling Localization: Problem mit den Textdomains

Dieses Thema im Forum "Plugins und Widgets" wurde erstellt von endur, 9. Februar 2011.

  1. endur

    endur New Member

    Registriert seit:
    31. März 2010
    Beiträge:
    2
    Zustimmungen:
    0
    Hi, ich bins mal wieder.

    Also: Ich habe mir das Theme "striking" bei themeforest gekauft. Vorher hab ich dem netten herrn da ne Mail geschrieben und gefragt ob es übersetzt war. Er meinte dem wäre so, es ist aber reell so, dass nur das Frontend übersetzt ist, das Admin-Interface nicht. Also hab ich mich dranmachen wollen und habe mir das codestyling localization - Plugin heruntergeladen. Das funktioniert aber nicht ganz so wie es soll. Hier mein Problem:

    Die Textdomains (es sind 2, striking_admin und striking_front) werden angezeigt. Das Plugin findet sie also. Aber: Wenn ich nun Änderungen mit dem Plugin vornehme, sagt es, dass die .mo-Datei erfolgreich geschrieben wurde, zeigt mir die Übersetzungen aber nicht an, lässt quasi alles auf Englisch. Ich tippe darauf, dass es daran liegt, dass ich 2 pot-files habe.

    Einmal im "normalen" theme-ordner, dort ist die striking_front.pot mitsamt de_DE.mo und po, einmal im Unterordner /framework/admin/languages. Dort liegt die striking_admin.pot. Verschiebe ich jetzt die mo/po-Dateien vom front- zum admin-Ordner verhält sich das ganze Problem umgekehrt: Der Adminbereich ist übersetzt, der Frontbereich aber nicht. Auch das verschieben der .pot-Dateien bringt keinen Unterschied, genauso wenig wie das Kopieren der mo/po/pot-Dateien so dass sie quasi "doppelt" vorhanden(bzw. die pot einfach so verschoben) sind.

    Problem ist halt, dass immer nur ein Teil übersetzt wird, der andere nicht. Kann mir bitte jemand helfen? Ich würde zu gern beides übersetzt haben ;)
    Liegts vielleicht auch am Plugin und ich sollte ein anderes dafür nehmen?

    Naja, ich hoffe mal, dass ihr mir helfen könnt.

    Grüße, Dominik

    edit: Ach ja, WP-Version ist 3.0.5 falls das jemand wissen will, läuft auf nem hostingpaket von all-inkl.
     
    #1 endur, 9. Februar 2011
    Zuletzt bearbeitet: 9. Februar 2011
  2. Ammaletu

    Ammaletu Well-Known Member
    Ehrenmitglied

    Registriert seit:
    14. Juli 2007
    Beiträge:
    4.694
    Zustimmungen:
    0
    Kann es sein, dass das Theme die Textdomain für das Admin-Interface gar nicht lädt? Dabei müsste doch angegeben werden, von wo die Dateien geladen werden sollen.

    Die pot- und po-Dateien sollten auf das Ergebnis in WP jedenfalls keinen Einfluss haben. Die sind ja nur für den Übersetzer da, WP liest nur die mo-Dateien, soweit ich weiß. Sind die neuen Dateien richtig benannt?
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden