1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Datenbankfehler nach Migration von Strato auf lokalen Server (MAMP).

Dieses Thema im Forum "Installation" wurde erstellt von Hildanus, 29. November 2017.

  1. Hildanus

    Hildanus Member

    Registriert seit:
    25. August 2015
    Beiträge:
    23
    Zustimmungen:
    0
    Ich habe eine Wordpress Installation (morgenward.net, bei STRATO gehostet) per FTP auf meinen lokalen Server (MAMP auf MacBook) runtergeladen und die dazugehörige Datenbank importiert. Die Fehlermeldung lautet: Fehler beim Aufbau einer Datenbankverbindung. Ich komme einfach nicht darauf was da falsch läuft. Ich habe neulich meinen LapTop neu aufgesetzt und im Zuge dessen ein BackUp von htdocs und den zugehörigen DB-Sätzen gemacht. War anschließend überhaupt kein Problem die zu den einzelnen WP-Installationen gehörenden DB-Sätze wieder zu importieren und die Installationen zum laufen zu bringen. Jemand 'ne Idee dazu?
     
  2. JABA-Hosting

    JABA-Hosting Well-Known Member

    Registriert seit:
    29. März 2016
    Beiträge:
    2.450
    Zustimmungen:
    98
    Ändere deine wp-config.php. Beim Datenbankserver sollte localhost stehen.
     
  3. Hildanus

    Hildanus Member

    Registriert seit:
    25. August 2015
    Beiträge:
    23
    Zustimmungen:
    0
    Hmm... Das hat mir sofort eingeleuchtet. Also hab ich die wp_config.php geändert wie vorgeschlagen:
    /** MySQL hostname */
    define('DB_HOST', 'localhost');
    Ändert aber nichts, es kommt immer noch: Fehler beim Aufbau einer Datenbankverbindung.
    'localhost:8888' (MAMP Konfiguration) funzt auch nicht. Komisch...
     
  4. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.965
    Zustimmungen:
    8
    Läuft denn der MySQL Server überhaupt?
     
  5. Hildanus

    Hildanus Member

    Registriert seit:
    25. August 2015
    Beiträge:
    23
    Zustimmungen:
    0
    Ja, der Server läuft. Hab ich mit einer anderen (lokalen) WP-Installation getestet. Muss jetzt offline gehen, danke für euer Mitdenken, morgen geht's weiter.
     
  6. Hildanus

    Hildanus Member

    Registriert seit:
    25. August 2015
    Beiträge:
    23
    Zustimmungen:
    0
    MoinMoin. Wie gesagt, der Server läuft. So sieht die vom Strate-Server runtergeladene wp-config.php aus:
    .
    .
    .
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', '-------------');


    /** MySQL database username */
    define('DB_USER', '-------------');


    /** MySQL database password */
    define('DB_PASSWORD', '-------------');


    /** MySQL hostname */
    define('DB_HOST', 'rdbms.strato.de');


    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');


    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
    .
    .
    .
    Den hostname habe ich zu 'localhost' geändert. Mein lokaler MAMP-Server verwendet für DB_USER eigentlich 'root' und für DB_PASSWORD ebenfalls 'root'. Also habe ich das ebenfalls so geändert. Jetzt kommt die Meldung "Safari kann keine Verbindung zum Server aufnehmen".
     
    #6 Hildanus, 30. November 2017
    Zuletzt von einem Moderator bearbeitet: 30. November 2017
  7. Hildanus

    Hildanus Member

    Registriert seit:
    25. August 2015
    Beiträge:
    23
    Zustimmungen:
    0
    Moin. Beim Datenbankserver hab ich wie gesagt localhost eingetragen, ohne Erfolg. Zum Vergleich, so sieht eine bei mir lokal funktionierende wp-config.php (Auszug) aus:
    .
    .
    define('DB_NAME', 'archaeomare');


    /**
    * Ersetze benutzername_hier_einfuegen
    * mit deinem MySQL-Datenbank-Benutzernamen.
    */
    define('DB_USER', 'root');


    /**
    * Ersetze passwort_hier_einfuegen mit deinem MySQL-Passwort.
    */
    define('DB_PASSWORD', 'root');


    /**
    * Ersetze localhost mit der MySQL-Serveradresse.
    */
    define('DB_HOST', 'localhost');
    .
    .
    Und so die von Strato runtergeladene:
    .
    .
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', '-------------');


    /** MySQL database username */
    define('DB_USER', '-------------');


    /** MySQL database password */
    define('DB_PASSWORD', '-------------');


    /** MySQL hostname */
    define('DB_HOST', 'rdbms.strato.de');


    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');


    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');

    DB_HOST hatte ich zu 'localhost' geändert und DB_USER und DB_PASSWORD zu 'root'.
    Ohne Erfolg...

    Auffällig ist das die URL einer funktionierenden lokalen Installation so aussieht:

    http://localhost:8888/archaeomare_wp4.8/ :)8888!)

    und die ohne Serververbindung so:

    http://localhost/WordPress_01/ (ohne :8888 )
     
    #7 Hildanus, 30. November 2017
    Zuletzt von einem Moderator bearbeitet: 30. November 2017
  8. danielgoehr

    danielgoehr Well-Known Member

    Registriert seit:
    13. Juli 2016
    Beiträge:
    2.445
    Zustimmungen:
    64
    Versuch mal, das Passwort leer zu lassen. Je nach Version kann es entweder "root" oder leer sein. Benutzername bleibt in beiden Fällen root.

    Edit: Wie sieht denn die URL von phpmyadmin aus? Ist dort auch ein Port angehängt? Falls ja, musst du beim Host ggf. auch diesen Port anhängen.
     
    #8 danielgoehr, 30. November 2017
    Zuletzt bearbeitet: 30. November 2017
  9. JABA-Hosting

    JABA-Hosting Well-Known Member

    Registriert seit:
    29. März 2016
    Beiträge:
    2.450
    Zustimmungen:
    98
    Vielleicht hilft auch statt localhost auch 127.0.0.1. Benutzernamen und Passwort gehe ich mal davon aus das die richtig sind.
     
  10. Hildanus

    Hildanus Member

    Registriert seit:
    25. August 2015
    Beiträge:
    23
    Zustimmungen:
    0
    Hab alles durchprobiert: PW root, PW leer, localhost mit Port / ohne Port, localhost oder 127.0.0.1. Nix geht.


    Hier nochmal die URL:
    localhost:8888/WordPress_01/


    Und die wp-config.php Einstellungen:
    /** The name of the database for WordPress */
    define('DB_NAME', 'DB2928345');


    /** MySQL database username */
    define('DB_USER', 'root');


    /** MySQL database password */
    define('DB_PASSWORD', 'root');


    /** MySQL hostname */
    define('DB_HOST', '127.0.0.1.'); /* 'localhost' und 'localhost:8888' hab ich auch probiert */


    Zum Vergleich hier eine andere lokale Installation die funktioniert:
    define('DB_NAME', 'archaeomare');
    /**
    * Ersetze benutzername_hier_einfuegen
    * mit deinem MySQL-Datenbank-Benutzernamen.
    */
    define('DB_USER', 'root');


    /**
    * Ersetze passwort_hier_einfuegen mit deinem MySQL-Passwort.
    */
    define('DB_PASSWORD', 'root');


    /**
    * Ersetze localhost mit der MySQL-Serveradresse.
    */
    define('DB_HOST', 'localhost');
     
  11. Hildanus

    Hildanus Member

    Registriert seit:
    25. August 2015
    Beiträge:
    23
    Zustimmungen:
    0
    Hab ich probiert. Kein Unterschied. Die URL wird ja auch richtig angezeigt: http://localhost:8888/WordPress_01/
    Trotzdem immer noch 'Fehler beim Aufbau einer Datenbankverbindung'.
     
  12. Hildanus

    Hildanus Member

    Registriert seit:
    25. August 2015
    Beiträge:
    23
    Zustimmungen:
    0
    Habe eben nochmal die Angaben bei STRATO angeschaut.

    Da steht:
    Datenbank: DB2928345
    Benutzername: U2928345
    Kommentar: Datenbank für morgenward.net

    Außer dem Datenbanknamen ist nichts relevant, oder?
     
  13. prox42

    prox42 Member

    Registriert seit:
    30. November 2017
    Beiträge:
    9
    Zustimmungen:
    1
    Kannst du dich bei phpMyAdmin anmelden und siehst dann die importierte Datenbank auch mit allen gewünschten Tabellen?
     
  14. Hildanus

    Hildanus Member

    Registriert seit:
    25. August 2015
    Beiträge:
    23
    Zustimmungen:
    0
    Ja klar. Ich hatte die Datenbank von Strato auf meinen Rechner exportiert und dann den Server und phpMyAdmin gestartet und die Datenbank importiert.
     
  15. Hildanus

    Hildanus Member

    Registriert seit:
    25. August 2015
    Beiträge:
    23
    Zustimmungen:
    0
    Ich hab es eben nochmal wiederholt. Also die Datenbank gelöscht, neu angelegt und die Daten importiert.
    Der Import wurde erfolgreich abgeschlossen, 89 Abfragen wurden ausgeführt. (DB2928345.sql)
    Datenbank ist da, aber keine Verbindung.

    Hier nochmal die wp-config.php Einstellungen:

    ('DB_NAME', 'DB2928345');


    ('DB_USER', 'root');


    ('DB_PASSWORD', 'root');


    ('DB_HOST', '127.0.0.1.');


    ('DB_CHARSET', 'utf8');


    ('DB_COLLATE', '');
     
  16. SEpp55

    SEpp55 Well-Known Member

    Registriert seit:
    3. Februar 2016
    Beiträge:
    1.824
    Zustimmungen:
    225
    Hier der Original-Auszug aus einer Lokalen WP-Installation bei mir!!

    /**
    * Ersetze datenbankname_hier_einfuegen
    * mit dem Namen der Datenbank, die du verwenden möchtest.
    */
    define('DB_NAME', 'wp_test');

    /**
    * Ersetze benutzername_hier_einfuegen
    * mit deinem MySQL-Datenbank-Benutzernamen.
    */
    define('DB_USER', 'root');

    /**
    * Ersetze passwort_hier_einfuegen mit deinem MySQL-Passwort.
    */
    define('DB_PASSWORD', '');

    /**
    * Ersetze localhost mit der MySQL-Serveradresse.
    */
    define('DB_HOST', 'localhost');

    /**
    * Der Datenbankzeichensatz, der beim Erstellen der
    * Datenbanktabellen verwendet werden soll
    */
    define('DB_CHARSET', 'utf8');

    /**
    * Der Collate-Type sollte nicht geändert werden.
    */
    define('DB_COLLATE', '');

    Demnach habe ich kein Passwort in der lokalen Version!!
     
  17. Hildanus

    Hildanus Member

    Registriert seit:
    25. August 2015
    Beiträge:
    23
    Zustimmungen:
    0
    Hab ich vorher auch schon versucht und jetzt eben nochmal eingestellt wie bei dir:
    /** The name of the database for WordPress */
    define('DB_NAME', 'DB2928345');


    /** MySQL database username */
    define('DB_USER', 'root');


    /** MySQL database password */
    define('DB_PASSWORD', '');


    /** MySQL hostname */
    define('DB_HOST', 'localhost');

    Ergebnis: Fehler beim Aufbau einer Datenbankverbindung...

    Dein Motto gefällt mir. Trifft den Nagel auf den Kopf.
     
  18. JABA-Hosting

    JABA-Hosting Well-Known Member

    Registriert seit:
    29. März 2016
    Beiträge:
    2.450
    Zustimmungen:
    98
    Dann versuch mal ...

    localhost:3306
     
  19. SEpp55

    SEpp55 Well-Known Member

    Registriert seit:
    3. Februar 2016
    Beiträge:
    1.824
    Zustimmungen:
    225
    Ich habe XAMPP anstatt MAMP - sollte von der Struktur ähnlich sein!
    In XAMPP gibts das Verzeichnis xampp > mysql > data!
    Darin befindet sich bei mir ein Ordner wp_test, also die Datenbank - ist das bei dir auch so??

    Soeben gefunden! LINK
    [h=3]4.8 Wo finde ich die Datenbank Dateien?[/h]Ihre Datenbanken Dateien finden Sie in c:\MAMP\db\mysql
     
    #19 SEpp55, 30. November 2017
    Zuletzt bearbeitet: 30. November 2017
  20. SEpp55

    SEpp55 Well-Known Member

    Registriert seit:
    3. Februar 2016
    Beiträge:
    1.824
    Zustimmungen:
    225
    Ggf hier lesen - LINK - und systematisch abarbeiten!
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden