1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Eigenes Template übernimmt Bloginhalte nicht!

Dieses Thema im Forum "Design" wurde erstellt von banban, 19. August 2012.

  1. banban

    banban Member

    Registriert seit:
    18. August 2012
    Beiträge:
    10
    Zustimmungen:
    0
    ...ich schon wieder. gehe ich euch schon auf den Sack? :???:

    Wie auch immer - ich finde ich mache Fortschritte. Habe mir jetzt ein simples Grundgerüst gebastelt, das aus header, sidebar-left, main Content, sidebar-right und footer bestehen sollte.

    soweit so gut, ob das mit den ganzen Anpassungen in der style.css so geht bzw. sinnvoll ist, bleibt noch herauszufinden. Darum gehts mir aber nicht im Moment.

    Ich verstehe jetzt gerade nur eines nicht: Wieso, übernimmt, er meine Bloginhalte nicht in das Template?! Also z. B. Artikel? Bin ratlos und kann auch (Anfänger, der ich nunmal bin) bisher keinen Fehler im Code finden. :confused:

    Das Ergebnis sieht so aus: http://banban.bplaced.net/wordpress/
    das ist ja soweit auch erstmal grundsätzlich in Ordnung, außer die fehlenden Inhalte eben...

    Ich habe das Ganze so aufgebaut:

    index.php:

    <head>
    <meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php bloginfo('charset'); ?>" />

    <title><?php wp_title(); ?> - <?php bloginfo('name'); ?></title>

    <link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen" />
    <link rel="pingback" href="<?php bloginfo('pingback_url'); ?>" />

    <?php wp_head(); ?>

    </head>

    <body>
    <div id="background">

    <div id="header"></div>
    <!-- header -->

    <div id="sidebar-left"></div>
    <!-- sidebar-left -->

    <div id="main"></div>
    <!-- main -->

    <div id="sidebar-right"></div>
    <!-- sidebar-right -->

    <div id="footer"></div>
    <!-- footer -->



    </div>
    <!-- background -->

    </body>
    </html>


    Demnach sieht die style.css folgendermaßen aus:

    /*
    Theme Name: banban Test1
    Theme URI:
    Description: Test Template 3 Spalten clean
    Author: banban
    Author URI: http://banban.bplaced.net/wordpress
    */

    body

    {
    background-color:#888282;
    }

    #background {
    width: 100%;
    margin: auto;
    text-align: left;
    background: white;
    }

    #header {
    width: 90%;
    height: 150px;
    padding-top: 50px;
    }

    #sidebar-left {
    width: 12%;
    padding-left: 5%;
    padding-top: 200px;
    float: left;
    }

    #main {
    width: 60%;
    padding-left: 18%;
    padding-top: 200px;
    float: left;
    }

    #sidebar-right {
    width: 22%;
    padding-right: 5%;
    padding-top: 200px;
    float: left;
    }

    #footer {
    clear: both;
    height: 120px;
    padding: 20px
    }





    a
    {

    }

    a:hover
    {

    }

    a img
    {

    }


    ...Weiter bin ich zum jetzigen Zeitpunkt ja noch garnicht. Aber müsste das Theme nicht in jedem Fall die Bloginhalte übernehmen?!? Check ich nicht...
     
  2. banban

    banban Member

    Registriert seit:
    18. August 2012
    Beiträge:
    10
    Zustimmungen:
    0
    nicht wundern, habe in der zwischenzeit n paar DInge an der style.css geändert... aber der Fehler muss ja so oder so iwo in der index.php versteckt sein?!
     
  3. banban

    banban Member

    Registriert seit:
    18. August 2012
    Beiträge:
    10
    Zustimmungen:
    0
    Sooo, ich habe die Zeit genutzt und meine style.css ein wenig umgebaut, wie man unschwer erkennen kann.

    Das Problem mit dem nicht angenommenen Inhalt bleibt bestehen es hat sich auch direkt noch ein neues Problem ergeben: Am Anfang hatte ich die sidebar-left, main und sidebar-right schön nebeneinander auf der gleichen Höhe, wie es sein soll, seit ich den footer nachgeschoben habe, passt das nicht mehr.

    kann mir das auch einer erklären? habe mittlerweile glaube ich jeden existierenden Anordnungsbefehl für die sidebar-right durchprobiert mit unterschiedlichen Werten und allem drum und dran, aber er will einfach nicht, die Sau! Selbes gilt auch für den footer. Wenn ich nen alten Stand lade, liegen die 3 COntainer auch wieder exakt auf gleicher Höhe etc. Aber sobald der Footer dazukommt ist es aus damit. Warum nur :?:

    sieht jetzt so aus: http:banban.blaced.net/wordpress

    style.css wie folgt:

    /*
    Theme Name: banban Test1
    Theme URI:
    Description: Test Template 3 Spalten clean
    Author: banban
    Author URI: http://banban.bplaced.net/wordpress
    */

    body

    {
    background:url(images/refused_background.jpg);}


    #header {
    width: 90%;
    height: 150px;
    margin-left: 5%;
    margin-right: 5%;
    margin-top: 20px;
    background:url(images/Header.jpg) no-repeat;
    background-position: center;
    float: center;

    }

    #sidebar-left {
    width: 12%;
    height: 500px;
    margin-left: 5%;
    margin-top: 20px;
    border-style: dotted;
    border-width: thin;
    float: left;
    background-color: white;

    }

    #main {
    width: 63%;
    height: 500px;
    margin-top: 20px;
    margin-left: 8%;
    border-style: dotted;
    border-width: thin;
    float: center;
    background-color: white;
    }

    #sidebar-right {
    width: 23%;
    height: 500px;
    margin-top: 30px;
    margin-right: 5%;
    border-style: dotted;
    border-width: thin;
    float: right;
    background-color: white;
    }

    #footer {
    width: 90%;
    height: 120px;
    margin-left: 5%;
    margin-right: 5%
    border-style: dotted;
    border-width: thin;
    background-color: #DEDEDE;
    float: center;
    }





    a
    {

    }

    a:hover
    {

    }

    a img
    {

    }

     
  4. banban

    banban Member

    Registriert seit:
    18. August 2012
    Beiträge:
    10
    Zustimmungen:
    0
    OKAY OKAY! ich habs verstanden. war vermutlich saudämlich, aber immerhin hab ich selber gemerkt das ohne "the loop" das nicht funktionieren kann... aber das mit der sidebar nervt immernoch, vermutlich finde ich den fehler auch noch wenn ich erstmal geschlafen habe, aber evtl. konnte mir bis dahin auch schon jemand helfen?!