1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

WP 5.6 Elementor hartnäckig unfunktional

Dieses Thema im Forum "Plugins und Widgets" wurde erstellt von Wordpress-Hill, 6. April 2021.

  1. Wordpress-Hill

    Registriert seit:
    6. April 2021
    Beiträge:
    7
    Zustimmungen:
    0
    Hallo Zusammen,

    seit ein paar Wochen hält sich Elementor hartnäckig zickig und will einfach
    nicht öffnen, wenn ich eine Seite mit Elementor bearbeiten will. Auch die abgesicherte
    Version funktioniert nicht.

    Seit wann herrscht dieses Problem?

    - Seit ich Smart Slider 3 installiert habe - nach Deaktivierung und schlussendliche Deinstallation
    funktioniert Elementor immer noch nicht

    - Ich habe durch Definieren des Memory-Limits in der wp-config.php den Working-Memory auf 256M erhöht
    (ist nunmehr mit 38% ausgelastet, vorher zu 95%) - funktioniert immer noch nicht.

    - Probeweise Plug-Ins einzeln deaktiviert, um zu testen, ob andere PI´s nachteilhaft Einfluss nehmen,
    jedoch ohne Ergebnis, außer dass z.B. durch bestimmte Deaktivierungen natürlich die Erscheinung
    und Funktionen der betreffenden Website verfremden bzw. außer Kraft treten.

    - Derweil wurde Wordpress aktualisiert, von späten 4.9-Versionen über 5.0.
    Ich dachte da an einen Degrade-Vorgang von WP, welches aber schon vorab gewarnt verheerende
    Zerwürfnisse des Frontends und Funktionalität bewirken kann. Dies würde ich nur im alleräußersten
    Notfall in Betracht ziehen, wenn keine andere Möglichkeit mehr bestünde.

    Was kann ich noch unternehmen, um dieses Elementor-Problem zu fixen?
    Vielen Dank im Voraus für Eure geschätzte Hilfe.

    Beste Grüße, Marc
     
  2. Henk1060

    Henk1060 Well-Known Member

    Registriert seit:
    4. September 2014
    Beiträge:
    3.403
    Zustimmungen:
    243
    was sagt die error log und Debug modus für einen fehler?
     
  3. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    8.595
    Zustimmungen:
    979
    Neben den bereits angefragen Fehlereinträgen noch ergänzen: Welches Theme und Version? Welche Plugins und Versionen? Welche genaue WordPress Version? Link zur Seite? Siehe auch Forenregeln, Punkt II.

    Tipp am Rande: Das Einfügen von Konstanten in wp-config.php erhöht nicht den verfügbaren Speicher beim Hostinganbieter, siehe dazu auch hier (wordpress.org):
     
  4. Wordpress-Hill

    Registriert seit:
    6. April 2021
    Beiträge:
    7
    Zustimmungen:
    0
    Hi Henk1060,

    Folgende Meldung wird angezeigt:

    Deprecated: Function create_function() is deprecated in /www/htdocs/w00fcd8a/kiddy-box.de-2019/wp-content/themes/elementor-hello-childtheme/functions.php on line 27

    Notice: Constant WP_POST_REVISIONS already defined in /www/htdocs/w00fcd8a/kiddy-box.de-2019/wp-content/themes/elementor-hello-childtheme/functions.php on line 124

    Warning: Cannot modify header information - headers already sent by (output started at /www/htdocs/w00fcd8a/kiddy-box.de-2019/wp-content/themes/elementor-hello-childtheme/functions.php:27) in /www/htdocs/w00fcd8a/kiddy-box.de-2019/wp-includes/pluggable.php on line 1329

    Warning: Cannot modify header information - headers already sent by (output started at /www/htdocs/w00fcd8a/kiddy-box.de-2019/wp-content/themes/elementor-hello-childtheme/functions.php:27) in /www/htdocs/w00fcd8a/kiddy-box.de-2019/wp-includes/pluggable.php on line 1332
     
  5. Henk1060

    Henk1060 Well-Known Member

    Registriert seit:
    4. September 2014
    Beiträge:
    3.403
    Zustimmungen:
    243
    Hy,

    dann schau mal in das child Theme vom hello elementor was in der zeile 27 und 124 steht.

    Welche PHP Version ist im einsatz?
     
  6. Wordpress-Hill

    Registriert seit:
    6. April 2021
    Beiträge:
    7
    Zustimmungen:
    0
    Hallo b3317133,

    Entschuldigung. Wäre hilfreich, ja! :)
    Beim Host ist der Limit selbst auch auf 256MB gesetzt in einer user.ini.

    Zur Wordpress-Seite:
    www.kiddy-box.de

    WP-Info:
    Wordpress V. 5.7
    Child Elementor Theme (Elementor Hello Theme 2.2)
    gegenwärtig PHP 7.0 (laut PHP-Checker)

    Plug-Ins:
    All-in-One WP Migration
    Version 7.40

    Breadcrumb NavXT auswählen Breadcrumb NavXT
    Version 6.6.0

    Classic Editor
    Version 1.6

    Compress JPEG & PNG
    Version 3.2.1

    Cookiebot | GDPR/CCPA Compliant Cookie Consent and Control
    Version 3.10.0

    Elementor
    Version 3.1.4
    Elementor Pro
    Version 3.2.1

    PHP Compatibility Checker
    Version 1.5.0

    Pods - Custom Content Types and Fields
    Version 2.7.26

    WooCommerce (derzeit deaktiviert)
    Version 5.1.0

    WP Downgrade (derzeit deaktiviert)
    Version 1.2.2

    WP Memory
    Version 2.3

    WPML Multilingual CMS
    Version 4.4.10

    WPML String Translation
    Version 3.1.8

    WPML Translation Management
    Version 2.10.6

    Yoast Duplicate Post
    Version 4.1.2

    Yoast SEO
    Version 16.1.1

    YYDevelopment - Tag Manager - Header, Body And Footer
    Version 2.3.1
     
  7. Wordpress-Hill

    Registriert seit:
    6. April 2021
    Beiträge:
    7
    Zustimmungen:
    0
    Ich checke grad per PHP-Checker-Plugin ab, ob alle Plugins und Themes kompatibel mit PHP 7.3 sind.
    Ich kann leider den Script von Hello Elementor Theme nicht aufrufen.

    SCAN PROCEEDING ....

    Ergebnis: Elementor Theme wirft mir bei PHP-Checker-Plugin folgende Meldung aus:

    27 | WARNING | Function create_function() is deprecated since PHP 7.2; Use an anonymous function instead

     
    #7 Wordpress-Hill, 7. April 2021
    Zuletzt bearbeitet: 7. April 2021
  8. Henk1060

    Henk1060 Well-Known Member

    Registriert seit:
    4. September 2014
    Beiträge:
    3.403
    Zustimmungen:
    243
    ja dann hast du im child theme etwas stehen das nicht mit der neueren PHP version arbeiten kann.
    Daher per ftp auf die datei zugreifen und schauen was dort steht ,)
     
  9. Wordpress-Hill

    Registriert seit:
    6. April 2021
    Beiträge:
    7
    Zustimmungen:
    0
    Line 27: add_filter('login_errors',create_function('$a', "return null;"));
     
    #9 Wordpress-Hill, 7. April 2021
    Zuletzt bearbeitet: 7. April 2021
  10. Henk1060

    Henk1060 Well-Known Member

    Registriert seit:
    4. September 2014
    Beiträge:
    3.403
    Zustimmungen:
    243
    versuch es mal durch das zu ersetzen
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    achte auf die richtige formatierung
     
  11. Wordpress-Hill

    Registriert seit:
    6. April 2021
    Beiträge:
    7
    Zustimmungen:
    0
    Das hat leider auch keinen Effekt erzielt.
    Ich muss versuchen, mit dem Ursprungscodeschnipsel beim Host die PHP-Version schrittweise
    von 7.2 an zurückzusetzen. Vielleicht bewirkt das etwas. Was anderes fällt mir grad echt nicht ein.

    Danke bis hierhin für Deine Hilfe, Henk!
    Beste Grüße, Marc
     
  12. Henk1060

    Henk1060 Well-Known Member

    Registriert seit:
    4. September 2014
    Beiträge:
    3.403
    Zustimmungen:
    243
    die frage ist brauchst die code schnippsel auch?

    was steht eine zeile oberhalb?
    function ?????

    kannst auch zum testen das einmal rauslöschen

    function dein code

    und bis
    );
     
  13. Wordpress-Hill

    Registriert seit:
    6. April 2021
    Beiträge:
    7
    Zustimmungen:
    0
    Nun, das ist der Befehl einen fehlerhaften eingegebenen Zugang nicht in einer Fehlermeldung anzuzeigen,
    was im anderen Fall ein gefundenes Fressen für jeden Hacker macht. Ich sollte es auf jeden Fall drinlassen.
    Drüber steht nichts zu dieser besagten Line 27, außer ein paar Remarkzeilen.
     
  14. mensmaximus

    mensmaximus Well-Known Member

    Registriert seit:
    24. Juli 2014
    Beiträge:
    8.707
    Zustimmungen:
    401
    :( sterben anonyme Funktionen nie aus? Macht das nicht! Bitte, bitte, bitte.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden