1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Falsche Darstellung Umlaute seit V2.6

Dieses Thema im Forum "Allgemeines" wurde erstellt von userwk1985, 20. August 2008.

  1. userwk1985

    userwk1985 Member

    Registriert seit:
    17. August 2008
    Beiträge:
    16
    Zustimmungen:
    0
    Falsche Darstellung Umlaute

    Weiß mir langsam und nach vielen Recherchen an diesem Ort keinen Rat mehr bezüglich der Darstellung der Umlaute:

    Es kommt zur falschen Darstellung der Umlaute mit lauter Fragezeichen > siehe Untersuhler iZeitung

    Das ist nicht bei allen Artikeln/Seiten so, weil ich es auch schon mit einem Plugin zum "Suchen & Ersetzen" probiert habe > manuelles Austauschen von Umlauten mit named entities.

    Schreibt man neue Blogs/Seiten, werden Umlaute wieder falsch dargestellt (nicht in den Artikel-, Seiten-Überschriften, aber im Text).

    Ich habe:
    1. Von Beginn an (2.5er Version) meine Datenbank mit UTF8 "gefahren"
    2. In meiner wp-config UTF8 steht von Beginn an
    define('DB_CHARSET', 'utf8');
    3. Unter meinen WP-Admin-Einstellungen ebenfalls von Beginn an UTF8 gewählt.

    Wenn ich mich nicht irre, hatte ich das Problem erstmalig, als ich meinen Blog auf die Version 2.6 umstellte.

    UTF8 - gut und schön - wenn es funktioniert. Nur was läuft hier denn falsch?

    Vielen Dank für Hinweise
     
    #1 userwk1985, 20. August 2008
    Zuletzt bearbeitet: 20. August 2008
  2. Design-Maker

    Design-Maker Well-Known Member

    Registriert seit:
    7. Juli 2006
    Beiträge:
    285
    Zustimmungen:
    0
    Erstereinmahl würde ich mal schauen.

    denn ganz am anfangs der header.php muß in der ersten Zeile vor dem Quelltext ein sonderbares Zeichen sein, denn dieses wird auf der Webseite als Viereck im Quelltext ausgegeben.

    Dann würde ich mal ein

    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

    entfernen, denn nicht immer ist doppelt besser.

    Dann musst du schauen in welcher Version deine Datenbank läuft ich würde ballt vermuten das es iso ist.
    Also heißt es von hand alle umlaude in utf umzuschreiben und dann bei neuen Themen darauf achten das diese gleich in utf erstellt werden.

    Wenn du gar nicht klar kommst kann ich ja mal schauen.
     
  3. bgeissler

    bgeissler Well-Known Member

    Registriert seit:
    6. August 2006
    Beiträge:
    4.404
    Zustimmungen:
    0
    Ich musste bei mir in der wp-config.php das rein schreiben, damit die Umlaute korrekt kommen:
    define('DB_CHARSET', 'utf-8');
     
  4. Ammaletu

    Ammaletu Well-Known Member
    Ehrenmitglied

    Registriert seit:
    14. Juli 2007
    Beiträge:
    4.694
    Zustimmungen:
    0
    Damit man nicht suchen muss, kaputte Umlaute finden sich z.B. hier:
    Hallo Welt!

    Wenn man im Browser auf ISO-8859-1 umschaltet, sind die Umlaute korrekt. Ausgeliefert wird die Seite ansonsten korrekt als UTF-8, HTTP-Header stimmt, Meta-Angabe stimmt. Und Du sagst ja, dass die DB auch immer schon UTF-8 war.

    Es kann vorkommen, dass Plugins die Umlaute zerstören, wenn sie z.B. PHP-Funktionen benutzen, die UTF-8 nicht unterstützen. Wenn es daran liegt, müsste das Problem verschwinden, wenn Du alle Plugins ausschaltest und auf das Standard-Theme umschaltest.

    Andererseits gehen dabei normalerweise die Umlaute komplett kaputt, während hier ja nur irgendwas die Umlaute in der falschen Codierung ausgibt. Da wird im Theme aber nicht etwa eine komplett eigene Query unter Umgehung der WP-Dateien aufgemacht oder? Ansonsten würde ich an Deiner Stelle nochmal sicherstellen, dass die Datenbank tatsächlich UTF-8 benutzt. Welche MySQL-Version ist es eigentlich?
     
  5. userwk1985

    userwk1985 Member

    Registriert seit:
    17. August 2008
    Beiträge:
    16
    Zustimmungen:
    0
    Plugin "ContuttoPDF" verursachte das Problem

    MySQL-version 5.0.32
    Habe einen Plugin-Check durchgeführt - Alles deaktiviert und nach & nach wieder zugeschalten. Tatsächlich hat das Plugin "ContuttoPDF" das Problem verursacht. Muss jetzt erstmal checken, wie ich das Plugin vielleicht doch weiter nutzen kann.
    Danke für Eure Hilfe
     
  6. Ammaletu

    Ammaletu Well-Known Member
    Ehrenmitglied

    Registriert seit:
    14. Juli 2007
    Beiträge:
    4.694
    Zustimmungen:
    0
    Falls der Plugin-Autor kein Interesse daran hat, das zu beheben (frag ruhig mal nach), kannst Du auch selber mal schauen, was für Funktionen da so verwendet werden. PHP ist ursprünglich nicht für Multibyte-Zeichensätze wie UTF-8 ausgelegt. Einige Funktionen können damit einfach nicht umgehen, andere muss man richtig einsetzen.

    Folgende Seite finde ich zu diesem Thema höchst informativ, falls Du selber mal schauen magst, ob sich das beheben lässt (manchmal muss man nur einen Parameter für die Encoding ergänzen z.B.):
    Character Sets / Character Encoding Issues [Web Application Component Toolkit]
     
  7. Rockhardt

    Rockhardt Active Member

    Registriert seit:
    30. Oktober 2006
    Beiträge:
    27
    Zustimmungen:
    0
    Hatte das Problem auch gerade.
    Bei mir stand in der wp-config

    das

    define('DB_CHARSET', 'utf8');


    ich habe es geändert auf

    define('DB_CHARSET', 'utf-8');


    und siehe da alles geht wieder und meine ä,ö,ü sind wieder da.
     
  8. Segler

    Segler Well-Known Member

    Registriert seit:
    30. April 2006
    Beiträge:
    45
    Zustimmungen:
    0
    tolle Idee

    tolle Idee - das mit dem umstellen der Schreibweise. Danke! Hab schon gedacht, ich müßte alles von Hand ändern (nach dem Upgrade von WP 2.0 auf WP 2.6.3)

    Aaber ... nun kommt das Problem bzw. deren 2e!

    Was mag das denn nun wieder sein? uff.
     
    #8 Segler, 29. Oktober 2008
    Zuletzt bearbeitet: 29. Oktober 2008
  9. marX

    marX Well-Known Member
    Ehrenmitglied

    Registriert seit:
    5. Oktober 2006
    Beiträge:
    12.943
    Zustimmungen:
    0
    Das ist korrekt (die Schreibweise mein ich).

    Das nicht, wird also ignoriert. Die Umlaute werden nicht doppelt codiert und alles passt.

    Zu debug_backtrace() gibts mehrere Threads hier im Forum, einfach mal suchen. Liegt sicher an den "Sicherheits"einstellungen deines Freehosters (Glaskugel-Modus aus)
     
  10. Segler

    Segler Well-Known Member

    Registriert seit:
    30. April 2006
    Beiträge:
    45
    Zustimmungen:
    0
    Ah, danke! Verstehe ... (vielleicht :)

    PS: dank Monika hab ich mein Problem gelöst! Freu.
    Es lag daran und gut wars.
     
    #10 Segler, 30. Oktober 2008
    Zuletzt bearbeitet: 30. Oktober 2008
  11. Lucy

    Lucy Active Member

    Registriert seit:
    18. September 2008
    Beiträge:
    35
    Zustimmungen:
    0
    Bei mir ist im Blog alles richtig. Aber bei den Sucherergenissen bei Google nicht! Hilfe!

    www.einradnews.de

    Google: Ankündigung einradnews
     
  12. believer

    believer Well-Known Member

    Registriert seit:
    11. November 2008
    Beiträge:
    327
    Zustimmungen:
    0
    Habe ähnliches Problem und komme einfach nicht weiter. :(
    Habe den thread und auch andere gelesen + befolgt, aber es haut bei mir nicht hin.

    Nutze WP 2.6.3
    Seite lautet: Gospel Life

    G, believer
     
  13. marX

    marX Well-Known Member
    Ehrenmitglied

    Registriert seit:
    5. Oktober 2006
    Beiträge:
    12.943
    Zustimmungen:
    0
    believer: deine Umlaute werden doch korrekt angezeigt. Was funktioniert wo nicht, und was hast du wie versucht?
     
  14. believer

    believer Well-Known Member

    Registriert seit:
    11. November 2008
    Beiträge:
    327
    Zustimmungen:
    0
    Bei Einträgen über WP-Downloadmanager wird nach wie vor statt z.B. Umlaut "ä" ein Fragezeichenkästchen abgebildet. Habe gerade mal unter Einstellungen den Zeichensatz auf UTF8 (obwohl ja nicht empfohlen) umgestellt. Bisher steht er auf UTF-8. Nachdem ich das aber gemacht habe, zeigte mit der Downloadlink eine korrekte Schreibweise der Umlaute aber darüber hatte ich dann eine Errormeldung.
     
  15. marX

    marX Well-Known Member
    Ehrenmitglied

    Registriert seit:
    5. Oktober 2006
    Beiträge:
    12.943
    Zustimmungen:
    0
    Die Zeichencodierung heißt "UTF-8", nur in MySQL (also auch in den wp-config-Konstanten) wird das "utf8" geschrieben.

    PS: Bitte nicht crossposten! Ich hab deine Beitrag im anderen Thread gelöscht.
     
  16. believer

    believer Well-Known Member

    Registriert seit:
    11. November 2008
    Beiträge:
    327
    Zustimmungen:
    0
    Ok, danke. Die Fehlermeldung gibt folgendes aus:

    Warning: htmlentities() [function.htmlentities]: charset `UTF8' not supported, assuming iso-8859-1 in /homepages/32/d13560472/htdocs/wp-content/plugins/wp-downloadmanager/wp-downloadmanager.php on line 331

    Was soll ich machen?Kenn mich nicht genug aus?
     
  17. marX

    marX Well-Known Member
    Ehrenmitglied

    Registriert seit:
    5. Oktober 2006
    Beiträge:
    12.943
    Zustimmungen:
    0
    Wie gesagt, an dieser Stelle gehört "UTF-8" (mit Bindestrich!) hin.
     
  18. believer

    believer Well-Known Member

    Registriert seit:
    11. November 2008
    Beiträge:
    327
    Zustimmungen:
    0
    Da steht aber nur

    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Wo trage ich hier genau UTF-8 ein?
     
  19. marX

    marX Well-Known Member
    Ehrenmitglied

    Registriert seit:
    5. Oktober 2006
    Beiträge:
    12.943
    Zustimmungen:
    0
    Du sollst nicht im Plugin-Quellcode herumschreiben. Wenn das Plugin eine Option für die Zeichencodierung anbietet, dann trägst du dort UTF-8 ein. Wenn's keine Option gibt, dann ist vermutlich das Plugin kaputt, und du solltest das dem Autor melden:
    WP-DownloadManager
     
  20. believer

    believer Well-Known Member

    Registriert seit:
    11. November 2008
    Beiträge:
    327
    Zustimmungen:
    0
    mmmm ... im plugin gibt es nirgendwo eine Möglichkeit der Umstellung auf UTF-8. Würde mal vermuten, daß ich auch nicht der einzige bin, der dieses Problem hat/ hatte. :-?
    Werde mich dann ggf. an den Autor wenden müssen. Danke für die Hilfe.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden