1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Upgrade Fotos werden nach Upgrade nicht angezeigt

Dieses Thema im Forum "Installation" wurde erstellt von Robbi, 13. November 2019.

  1. Robbi

    Robbi Well-Known Member

    Registriert seit:
    12. September 2005
    Beiträge:
    307
    Zustimmungen:
    1
    Hallo,
    ich habe eben das Upgrade auf Wordpress 5.3 gemacht. Es lief zwar ohne Probleme, aber jetzt werden die Grafiken/Fotos nicht mehr angezeigt.
    Und schlimmer noch: Selbst wenn man sie direkt aufruft, kommt nur eine Fehlermeldung, die Datei würde nicht existieren. Per FTP sehe ich aber, dass sie natürlich doch noch da sind (siehe Screenshot).
    Beispiel:
    https://pinoxx.de/wp-content/uploads/2013/05/davidstern.jpg
    Eigentlich müssten die Dateien doch unabhängig von Wordpress trotzdem aufgerufen werden können.
    Hat jemand eine Idee, was da passiert ist?
    Ich habe hier mehrere Projekte, eines davon mit 20.000 Fotos. Da will ich jetzt natürlich kein Upgrade machen, solange die Ursache nicht klar ist.

    [​IMG]
     
  2. mensmaximus

    mensmaximus Well-Known Member

    Registriert seit:
    24. Juli 2014
    Beiträge:
    8.297
    Zustimmungen:
    316
    Entweder Du hast eine Plugin für die Verwaltung von Medien installiert oder Dein Theme kommt mit der geänderten Behandlung von Medien in WordPress 5.3 nicht zurecht. Bitte einmal in das PHP error.log schaun.
     
    SuMu gefällt das.
  3. SirEctor

    SirEctor Well-Known Member
    Ehrenmitglied

    Registriert seit:
    28. Oktober 2008
    Beiträge:
    12.343
    Zustimmungen:
    417
    Man könnte ja vorher ein Backup der Seite inkl. Datenbank machen. Da empfiehlt sich übrigens immer vor einem Update.
     
    SuMu gefällt das.
  4. SuMu

    SuMu Well-Known Member

    Registriert seit:
    5. Januar 2006
    Beiträge:
    6.103
    Zustimmungen:
    28
    oder man wartet einfach mal ein paar Tage, bevor man ein WP update macht, oft kommt kurz darauf eine weitere kleines update ...
     
  5. Robbi

    Robbi Well-Known Member

    Registriert seit:
    12. September 2005
    Beiträge:
    307
    Zustimmungen:
    1
    @mensmaximus
    Nein, es gibt kein eigenes Plugin dafür. Und es ist auch unabhängig vom Theme.
    Was das error.log betrifft verstehe ich das nicht.
    Was mich wie gesagt völlig veriwrrt ist die Tatsache, dass die Dateien auch nicht direkt aufgerufen werden können :(

    @SuMu
    Das werde ich wohl tun.

    Ich danke Euch!
     
  6. mensmaximus

    mensmaximus Well-Known Member

    Registriert seit:
    24. Juli 2014
    Beiträge:
    8.297
    Zustimmungen:
    316
    Hast Du mal in die htaccess gesehen ob dort eine Restriktion für Bilddateien enthalten ist?
     
  7. Robbi

    Robbi Well-Known Member

    Registriert seit:
    12. September 2005
    Beiträge:
    307
    Zustimmungen:
    1
    Tatsächlich sind dort einige Zeilen "AAM Media Access Control" vorhanden. Nach dem Auskommentieren funktierts wieder.
    Mir ist nicht bewusst, wieso die da drin standen. Vielleicht durch das genutzt Foto-Theme?

    Aber ich danke Dir sehr!
     
  8. mensmaximus

    mensmaximus Well-Known Member

    Registriert seit:
    24. Juli 2014
    Beiträge:
    8.297
    Zustimmungen:
    316
  9. Robbi

    Robbi Well-Known Member

    Registriert seit:
    12. September 2005
    Beiträge:
    307
    Zustimmungen:
    1
    Ah, ok. Das hatte ich zwar gelöscht, aber der Eintrag war dann in der htaccess natürlich noch enthalten. Merci!
     
  10. mensmaximus

    mensmaximus Well-Known Member

    Registriert seit:
    24. Juli 2014
    Beiträge:
    8.297
    Zustimmungen:
    316
    Womit die Theorie des Plugins für Medienverwaltung bestätigt wäre ;) Schön das es wieder funktioniert.
     
  11. Robbi

    Robbi Well-Known Member

    Registriert seit:
    12. September 2005
    Beiträge:
    307
    Zustimmungen:
    1
    Es war mir gar nicht mehr bewusst, das war schon ein paar Jahre her. Muss jetzt mit der neuen WP-Version zusammen hängen.
     
  12. Kurt Singer

    Kurt Singer Well-Known Member

    Registriert seit:
    28. Mai 2017
    Beiträge:
    1.149
    Zustimmungen:
    116
    Das ist ja wie bei Microsoft o_O

    Ich habe nach Aktualisierung der Plugins und dem Backup die Aktualisierung auf WP 5.3 durchgeführt, danach waren einige Plugins erstmals oder erneut zu aktualisieren, vielleicht die, die schon auf 5.3 vorbereitet waren.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden