1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Fragen zu: HTTPS mit SSL-Zertifikat einrichten

Dieses Thema im Forum "Konfiguration" wurde erstellt von Johannes108, 7. Oktober 2016.

  1. Johannes108

    Johannes108 Well-Known Member

    Registriert seit:
    18. Januar 2016
    Beiträge:
    99
    Zustimmungen:
    0
    (Gleich zu Beginn: Ist mein Beitrag richtig hier?)

    Ich habe begonnen die Seite https://indmarkt.de/ mit SSL-Zertifikat zu versehen und die Umstellung funktioniert bis dato gut. Dennoch hätte ich diesbezüglich noch eine Frage:

    In den beiden Anleitungen https://www.webongo.de/wordpress-https-umstellen/ und http://pressengers.de/sicherheit/wordpress-https-mit-ssl-zertifikat-einrichten/ wird beide Male erwähnt, dass man noch einen Weiterleitung in der .htaccess -Datei anlegen soll. Diese Datei existiert in meinem Falle aber nicht. Führe ich jedoch den Test unter https://www.ssllabs.com/ssltest/ durch, sagt dieser "A".

    Auch die Änderung in der wp-config.php (define( 'WP_CONTENT_URL', 'https://Ihre Webseite/wp-content' );) habe ich nicht vorgenommen.

    Ist die Seite trotz den 2 ausstehenden Maßnahmen als sicher einzustufen, bzw. die Umstellung ausreichend vollständig?

    Danke für die Hilfe!
     
  2. Marcus[IS]

    Marcus[IS] Well-Known Member

    Registriert seit:
    23. August 2009
    Beiträge:
    5.573
    Zustimmungen:
    90
    Hi,

    Das Certifikate wird als Sicher ausgegeben, also scheint ja soweit alles richtig zu laufen.
    Würde nur ein Inhalt noch per http angesteuert werden, würde der Browser das mit einer entsprechenden Meldung quittieren.

    Die Datei existiert (noch) nicht, da du scheinbar die Funktion Permalinks nicht verwendest.
    Wenn man den Über Uns Link anklickt sieht man in der Adresszeile des Browser das hier die Original Formatierung von WP verwendet wird.
    Da du ja Inhaltlich gesehen einen Onlineshop betreiben möchtest, wäre allerdings nicht verkehrt die Permalinkfunktion zu verwenden, da Google deine Seiten dann besser indizieren kann.

    Ach ja und mache dich bitte ein wenig mit der Rechtslage vertraut. Deine Seite wird als Kommerziell angesehen und daher bist du verpflichtet ein Impressum zu veröffentlichen. Ich denke eine AGB bezüglich des Shops wäre auch nicht verkehrt. Also falls du einen Anwalt zur Hand hast, besser beraten lassen, bevor du böse Post bekommst. ;)
     
    #2 Marcus[IS], 7. Oktober 2016
    Zuletzt bearbeitet: 7. Oktober 2016
  3. Johannes108

    Johannes108 Well-Known Member

    Registriert seit:
    18. Januar 2016
    Beiträge:
    99
    Zustimmungen:
    0
    Hey Marcus!
    Danke dir für die Hilfestellung! Auch für den Hinweis wegen AGB etc. Habe mich extra bei einem Kurs der IHK angemeldet um das Thema nachhaltig zu behandeln.

    Natürlich habe ich Deinen Tip bzgl. der Permalink Funktion umgesetzt. (Evtl. kannst du kurz checken ob es jetzt passt...?)

    Die ".htaccess" ist dann auch erschienen. Nur ist nun das Problem, dass wenn ich den empfohlenen Eintrag:
    RewriteEngine On
    RewriteCond %{HTTPS} !=on
    RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

    ...in ihr vornehme, meine Seite nicht mehr geöffnet werden kann!!! "
    [FONT=&quot]ERR_TOO_MANY_REDIRECTS" [/FONT]kommt als Fehlermeldung.

    Weißt du oder jemand anderes was da los ist?

    Merci im Voraus!
     
  4. Marcus[IS]

    Marcus[IS] Well-Known Member

    Registriert seit:
    23. August 2009
    Beiträge:
    5.573
    Zustimmungen:
    90
    Mojn,

    An welcher Stelle in der .htaccess hattest du den Codeschnipsel denn eingefügt?
    Diese Codes müssen außerhalb des #begin wordpress / #end wordpress Bereich der htaccess eigefügt werden.

    Ich habe auf einer Seite gelesen, dass der von dir versuchte Code am Ende der .htaccess eingefügt werden muss, obwohl man normalerweise hingeht und diese am Anfang einfügt.

    Ansonsten hätte ich da noch zwei andere Codeschnipsel, die du mal versuchen könntest.
    Bei Codeschnipsel Eins muss du noch example mit indmarkt und das .com mit .de ersetzen. ;)

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
     
    #4 Marcus[IS], 9. Oktober 2016
    Zuletzt bearbeitet: 9. Oktober 2016
  5. Johannes108

    Johannes108 Well-Known Member

    Registriert seit:
    18. Januar 2016
    Beiträge:
    99
    Zustimmungen:
    0
    Servus Marcus ;)
    Also ich habe jetzt so verfahren wie Du meintest...aber leider funktioniert es immer noch nicht. Wahrscheinlich mache ich doch etwas falsch. PFA ein Screenshot von der modifizieriten .htaccess-Datei.
    Danke Dir für die Hilfe!!!
     

    Anhänge:

  6. Marcus[IS]

    Marcus[IS] Well-Known Member

    Registriert seit:
    23. August 2009
    Beiträge:
    5.573
    Zustimmungen:
    90
    Äh, da hast du mich etwas miss verstanden.

    Du sollst nicht alle Codeschnipsel in die .htaccess rein packen.
    Nur einen von den beiden. ;)

    Zumal da wohl vermutlich auch was nicht in Ordnung ist mit der Formatierung.
    Der WordPress Block darf nicht eine einzige Zeile sein.
    Das könnte durch den Windows Editor verursacht sein.
    Nimm besser das Freeware Programm Notepad++, das bietet zudem einen integrierten Code Highlight, der das bearbeiten von php wegen der Farbgebungen der Codeabschnitte bedeutend komfortabler macht.

    Versuche mal das;
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
     
  7. Johannes108

    Johannes108 Well-Known Member

    Registriert seit:
    18. Januar 2016
    Beiträge:
    99
    Zustimmungen:
    0
    Ich verstehe! Habe jetzt erst die gerade von Dir vorgeschlagene Version ausprobiert: PFA ...hat leider nicht funktioniert.
    Jedoch mit dem Schnipsel 1, läd die Seite jetzt.

    Vielen Dank für Deine Geduld!
     

    Anhänge:

  8. JABA-Hosting

    JABA-Hosting Well-Known Member

    Registriert seit:
    29. März 2016
    Beiträge:
    2.460
    Zustimmungen:
    98
    Ich sehe auf deiner Seite kein Impressum. Das solltest du ändern, ansonsten kann es teuer werden.
     
  9. Johannes108

    Johannes108 Well-Known Member

    Registriert seit:
    18. Januar 2016
    Beiträge:
    99
    Zustimmungen:
    0
    @JABA-Hosting. Auch dir danke für den Hinweis!
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden