1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

iframe wird nicht angezeigt

Dieses Thema im Forum "Konfiguration" wurde erstellt von playzoom, 14. Januar 2017.

  1. playzoom

    playzoom New Member

    Registriert seit:
    14. Januar 2017
    Beiträge:
    4
    Zustimmungen:
    0
    Hallo Leute,

    wenn ich von der Website "gametracker.com" einen servertracker iframe in einer meiner Seiten hinzufügen möchte, wird dieser leider nicht angezeigt.

    Hier ist es eingebaut, ich habe keine Ahnung was es können würde.

    Iframe Problem

    Wenn man alles markiert, sieht man, dass es schon eingebaut ist, aber es wird nichts angezeigt...
    Der link scheint auch nicht irgenddwie durch einen Fehler verändert worden zu sein, wenn ich im Quelltext schaue und die "src" direkt kopiere seh ich den Tracker.

    Wordpress Version:

    4.7.1 (Theme: Neongame, etwas angepasst)

    Plugins:

    FAQ
    iframe (auch ohne dieses gings nicht)
    Photo Gallery
    Spam Protection by Cleantalk
    Twitch Status
    Ultimate Category Excluder
    User Role Editor
    WP Categories Widget
    WP User Avatar
    Youtube

    Ich hoffe jemand kann helfen. :)

    Liebe Grüße.

    Sho
     
  2. SirEctor

    SirEctor Well-Known Member
    Ehrenmitglied

    Registriert seit:
    28. Oktober 2008
    Beiträge:
    12.343
    Zustimmungen:
    417
    Der Anbieter hat das anscheinend gesperrt "Refused to display http://........ in a frame because it set 'X-Frame-Options' to 'DENY'". Das ist dein Hauptproblem. Ein anderes Problem, welches du hast, ist, dass du "Mixed Content" nutzt, also Inhalte, die über http anstatt https aufgerufen werden.
     
  3. Edi

    Edi Well-Known Member

    Registriert seit:
    26. Juli 2006
    Beiträge:
    3.728
    Zustimmungen:
    1
    Und der iFrame-Code stimmt nicht: Du hast im iFrame-Container irgendwelche HTML-Artefakte.
     
  4. playzoom

    playzoom New Member

    Registriert seit:
    14. Januar 2017
    Beiträge:
    4
    Zustimmungen:
    0
    Aber die Seite gametracker biete mir ja dieses iframe an...Oder meinst du mit Anbieter...Seitenanbieter...In diesem Falle müsste ich bzgl x-frame-options mal nachhaken. Bzgl. Mixed Content habe ich nicht ganz verstanden was du meinst.

    Das ist 1:1 der iframe, der auf der Website gametracker generiert wurde. Ich habe da gar nichts verändert.
     
  5. Edi

    Edi Well-Known Member

    Registriert seit:
    26. Juli 2006
    Beiträge:
    3.728
    Zustimmungen:
    1
    Sehe ich dort nicht so. Das iFrame beginnt mit <iframe ... > und endet mit </iframe>, ohne <html> usw.
     
  6. playzoom

    playzoom New Member

    Registriert seit:
    14. Januar 2017
    Beiträge:
    4
    Zustimmungen:
    0
    Hier der Code:

    HTML:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Unverändert nada. So sieht ein iframe aus, mit dem wordpress plugin kann man es natürlich [iframe...] machen. Aber beides geht nicht.
     
  7. Edi

    Edi Well-Known Member

    Registriert seit:
    26. Juli 2006
    Beiträge:
    3.728
    Zustimmungen:
    1
    Mittlerweile hast Du das ja geändert...
     
  8. playzoom

    playzoom New Member

    Registriert seit:
    14. Januar 2017
    Beiträge:
    4
    Zustimmungen:
    0
    Nein, ich probiere gerade aus. Also Youtube einbetten geht problemlos mit iframe...und das was ihr da jetzt seht ist der andere "tracker" mit <a> also purer link...nur iframe version mit gametracker geht nicht...schau grad selbst, habe es wieder eingebaut.
     
  9. SirEctor

    SirEctor Well-Known Member
    Ehrenmitglied

    Registriert seit:
    28. Oktober 2008
    Beiträge:
    12.343
    Zustimmungen:
    417
    Ich mag Leute die die Initiative auch mal selbst ergreifen: https://goo.gl/PYjWuP
     
  10. danielgoehr

    danielgoehr Well-Known Member

    Registriert seit:
    13. Juli 2016
    Beiträge:
    2.545
    Zustimmungen:
    83
    Folgende Vermutung:

    Du nutzt SSL (als https). Du bettest einen iFrame ein, bei dem nutzt du folgerichtig auch https.
    Der Inhalt des iFrames unterstützt aber kein https, sondern nur http. Nutzt du aber http, blockt deine Seite den Content, weil unsicher.

    Im Moment sehe ich keine Möglichkeit, wie du den iFrame auf deiner Seite verwenden könntest...
     
  11. danielgoehr

    danielgoehr Well-Known Member

    Registriert seit:
    13. Juli 2016
    Beiträge:
    2.545
    Zustimmungen:
    83
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden