1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Kein Login möglich

Dieses Thema im Forum "Installation" wurde erstellt von schrulla_online, 26. Juni 2020.

  1. schrulla_online

    schrulla_online Well-Known Member

    Registriert seit:
    31. März 2011
    Beiträge:
    248
    Zustimmungen:
    0
    Hallo, ich betreue die Webseite eines kleinen Handwerkbetriebes (nur 3 Seiten) und komme plötzlich nicht mehr ins Dashboard. Die Seite läuft aber wenn ich wp-admin eingebe sehe ich eine leere Seite.

    Fehlermeldung:
    Deprecated: Function create_function() is deprecated in /mnt/web312/e1/06/54616406/htdocs/wp-includes/pomo/translations.php on line 208 Deprecated: Function create_function() is deprecated in /mnt/web312/e1/06/54616406/htdocs/wp-includes/pomo/translations.php on line 208

    Plugins: Classic Editor und tinymce-advanced

    Habt ihr einen Tipp für mich? Ansonsten muss ich die Seite neu aufsetzen, was eigentlich kein Problem ist.
    Danke!
     
  2. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.855
    Zustimmungen:
    3
    Die Wordpessversion ist vermutlich ziemlich alt und der Webhoster hat die PHP-Version auf 7.2 oder höher geändert.
    Du könntest im Strato-Kundenmenü die PHP-Version zeitweilig auf 7.1 setzen und Wordpress aktualisieren. Oder WP per FTP aktualisieren.

    Gruß
    Ingo
     
  3. schrulla_online

    schrulla_online Well-Known Member

    Registriert seit:
    31. März 2011
    Beiträge:
    248
    Zustimmungen:
    0
  4. schrulla_online

    schrulla_online Well-Known Member

    Registriert seit:
    31. März 2011
    Beiträge:
    248
    Zustimmungen:
    0
    Ich habe auf 7.2 gestellt, ohne Erfolg
     
  5. JABA-Hosting

    JABA-Hosting Well-Known Member

    Registriert seit:
    29. März 2016
    Beiträge:
    2.504
    Zustimmungen:
    102
    Wenn dann PHP 7.1 oder PHP 7.0.

    Ansonsten WordPress auf die neuste Version aktualisieren.
     
  6. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.855
    Zustimmungen:
    3
    Ok, 7.1 wird von Strato nicht mehr angeboten. Dann hilft nur noch das WP-Update per FTP.

    Gruß
    Ingo
     
  7. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.855
    Zustimmungen:
    3
    Was mich nur etwas wundert ist, daß die Warnung überhaupt angezeigt wird. Per Voreinstellung ist bei Strato display_errors=off.
    Ist möglicherweise das Debugging in der wp-config.php eingeschaltet oder gibt es eine lokale php.ini?
    Wenn man die Warnung abschaltet, sollte man sich auch wieder anmelden und das Update im WP-Admin-Bereich durchführen können.

    Gruß
    Ingo
     
  8. schrulla_online

    schrulla_online Well-Known Member

    Registriert seit:
    31. März 2011
    Beiträge:
    248
    Zustimmungen:
    0
    Ich hatte mir die Warnung anzeigen lassen: define('WP_DEBUG', true);
     
  9. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.855
    Zustimmungen:
    3
    Hmmm, eine Deprecated-Warnung führt normalerweise nicht zu einer weißen Seite, da müssen noch andere Fehler auftreten.

    Bei Strato gibt es bei "Statistik" -> "Logfiles" die Möglichkeit, eine Errorlogdatei runterzuladen. Vielleicht kommt man so dem Fehler auf die Spur.

    Welche WP-Version läuft denn da und wurde die eventuell mit dem AppWizard installiert?

    Gruß
    Ingo
     
  10. schrulla_online

    schrulla_online Well-Known Member

    Registriert seit:
    31. März 2011
    Beiträge:
    248
    Zustimmungen:
    0
    Ich werde die Seite neu aufsetzen mit allem Drum und Dran, vielen Dank fürs Mitdenken! :)
     
  11. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    7.363
    Zustimmungen:
    738
    Deine WordPress Installation befindet/befand sich vermutlich im 4.3.x Zweig.

    Der genannte Hinweis aus dem WordPress Core sollte mit einer manuellen Aktualisierung per FTP relativ einfach behebbar sein.

    Wenn ein Website so alt ist, kann es auch beim Theme und/oder Plugins zu ähnlichen Problemen kommen. Wann hast Du das letzte Mal Aktualisierungen eingespielt?
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden