1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

kein LogIn

Dieses Thema im Forum "Konfiguration" wurde erstellt von donrusso, 29. März 2020.

  1. donrusso

    donrusso New Member

    Registriert seit:
    29. März 2020
    Beiträge:
    1
    Zustimmungen:
    0
    Hallo Menschen,

    ich bin ein blutiger Anfänger, im Wordpressgeschäft und PHP. Ich soll auf einer ein paar Informationen anpassen, leider komme ich nicht mehr ins Config-Menü rein. Könnt ihr mir helfen?

    Das ist die Seite, und diese gibt eine Fehlermeldung aus:

    http://www.as-rechtsanwaelte.de/wp-login.php

    Warning: Illegal string offset 'remember' in /www/htdocs/w00b5f5c/altan-sahin-de/wp-includes/user.php on line 39

    Warning: Cannot assign an empty string to a string offset in /www/htdocs/w00b5f5c/altan-sahin-de/wp-includes/user.php on line 39

    Warning: Illegal string offset 'user_login' in /www/htdocs/w00b5f5c/altan-sahin-de/wp-includes/user.php on line 54

    Fatal error: Uncaught Error: Cannot create references to/from string offsets in /www/htdocs/w00b5f5c/altan-sahin-de/wp-includes/user.php:54 Stack trace: #0 /www/htdocs/w00b5f5c/altan-sahin-de/wp-login.php(775): wp_signon('', '') #1 {main} thrown in /www/htdocs/w00b5f5c/altan-sahin-de/wp-includes/user.php on line 54
     
  2. Marcus[IS]

    Marcus[IS] Well-Known Member

    Registriert seit:
    23. August 2009
    Beiträge:
    5.611
    Zustimmungen:
    93
    Mojn,

    die Erste Fehlermeldung gibt eigentlich schon einen Hinweis, dass es Probleme bei der verwendeten PHP Version gibt.

    Kann es sein, dass die PHP Version umgestellt wurde?
    Dann liegt es vermutlich daran, dass bei PHP 7 einige Sachen nun anders aufgerufen werden und die verwendete WordPress Version 4.9.21 kommt mit PHP 7 nicht zurande.

    Hier ein kleiner Workaround, wie jemand dieses Erste Problem gelöst hat.
    https://wpwunder.de/wordpress-warning-illegal-string-offset-remember/

    Kommst aber trotzdem nicht darum herum, das WordPress auf die neue Version upzudaten. Schon alleine aus dem Aspekt, dass zwischenzeitlich mit den Folgeversionen auch entdeckte Sicherheitslücken beseitigt wurden.
     
  3. SirEctor

    SirEctor Well-Known Member
    Ehrenmitglied

    Registriert seit:
    28. Oktober 2008
    Beiträge:
    12.302
    Zustimmungen:
    408
    Der TE verwendet noch WordPress 4.1 und das ist uralt, auch wenn das Update von Dez. 2019 ist. PHP-Version etc. passen garantiert nicht mehr.
     
  4. Marcus[IS]

    Marcus[IS] Well-Known Member

    Registriert seit:
    23. August 2009
    Beiträge:
    5.611
    Zustimmungen:
    93
    Ah okies. Dachte hätte im Quelltext beim Generator Tag die Version 4.9.21 gelesen, aber kann mich auch irren. Hat sich aber scheinbar erledigt, da jetzt 5.3.2 im Quelltext beim Generator Tag steht.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden