1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

WP 4.8 Keine Sitemap-Daten in robots.txt erzeugen --- wie ?

Dieses Thema im Forum "Konfiguration" wurde erstellt von weblogger, 19. September 2017.

  1. weblogger

    weblogger Member

    Registriert seit:
    19. September 2017
    Beiträge:
    10
    Zustimmungen:
    0
    Guten Tag!

    Ich habe eine WP-Multi Site mit Subdomains ohne Unterverzeichnisse.

    Für jede Domain (Haupt und Subs) will ich jeweils eine eigene sitemap.xml haben,
    z.B.
    h-t-t-p-s://my_subdomain1/sitemap.xml
    h-t-t-p-s://my_subdomain2/sitemap.xml
    usw.
    (Bindestriche nur als Link-Verhinderer in diesem Text).

    Die robots.txt erzeugt WP dynamisch in Anlehnung an https://florianbrinkmann.com/en/3364/modifying-robots-txt-for-individual-sites-of-a-multisite-install/ (Funktion eingestellt in die functions.php des Themes).

    Das funktioniert gut bei http.
    Das funktioniert nicht zufriedenstellend bei https (SSL), denn hier erzeugt WP als erste 2 Zeilen im robots.txt folgendes:
    Sitemap: h-t-t-p-s://my_subdomain/sitemap.xml
    Sitemap: h-t-t-p-s://my_subdomain/news-sitemap.xml
    Diese 2 Zeilen sind für alle Domains (Main, Subs) gleichlautend.

    Lösungsversuch:
    Alle Plugins deaktiviert und dynamisches Erzeugen des robots.txt umgestellt auf WP-Original --- “apply_filters( ‘robots_txt’, $output, $public )”.
    Der Lösungsversuch war keine Lösung, der robots.txt hatte unverändert die unerwünschten 2 Kopfzeilen.

    Ich will die dynamische robots.txt-Erzeugung für meine Multisite beibehalten, aber ohne die zwei führenden Sitemap-Zeilen.

    Gibt es eine Lösung?
    Bitte um / danke vorab für zielführende Hinweise.
    Josef alias weblogger
     
  2. weblogger

    weblogger Member

    Registriert seit:
    19. September 2017
    Beiträge:
    10
    Zustimmungen:
    0
    Es war doch ein Plugin die Ursache, und zwar Jetpack.
    In …../wp-content/plugins/jetpack/modules/sitemaps/sitemaps.php
    de-aktivierte ich folgende Zeilen:
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Problem somit gelöst.
    Josef alias weblogger
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden