1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Login-Problem bei Einrichtung von Domain-mapping/Multisite bei Strato

Dieses Thema im Forum "Installation" wurde erstellt von sedi, 16. Dezember 2018.

  1. sedi

    sedi New Member

    Registriert seit:
    15. Dezember 2018
    Beiträge:
    4
    Zustimmungen:
    1
    Hi,
    ich bin blutiger WP-Anfänger und möchte bei Strato eine Multisite-WP-Installation aufsetzen, über die ich mehrere Websites mit unterschiedlichen (bei Strato gehosteten) Domains betreiben kann.

    Edit: ich lese gerade, dass man den URL angeben soll. Der ist momentan erst einmal Stimmrecht.com. Die Adresse zeigt aber zurzeit auf ein leeres Verzeichnis.

    Ich gehe zurzeit nach dieser Anleitung vor:
    https://strato.de/blog/domain-mapping-wordpress-multisite/
    Diese erweitert / ändert auch diese Anleitung
    https://strato.de/blog/wordpress-multisite/

    Ich habe einen Ordner /wordpress angelegt, die Domain auf diesen Ordner gelegt und dort dann die manuelle Installation (V5.0.1) gestartet. Ich habe der wp-config.php dann zunächst
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    hinzugefügt, dann am Ende auch - hinter der später von WP geforderte Code-Ergänzung auch die Zeile
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    ergänzt. Frage: muss diese letzte Zeile evtl. vor oder nach dem Installieren eingetragen werden?

    Auch die .htaccess habe ich angepasst wie gefordert - innerhalb der if-Klammer.

    Leider bin ich nach dem Einrichten nicht mehr hineingekommen. Ich habe das richtige Login und Passwort probiert (kein Erfolg), mehrfach zurückgesetzt (das ging augenscheinlich, Anmelden mit dem neu vergebenen Passwort allerdings nicht). Gestern bin ich immer wieder (ohne Fehlermeldung) zum Anmeldefenster zurückgeschickt worden. Heute kam das Anmeldefenster gar nicht mehr - ich bekomme sowohl unter /wp-login.php als auch unter /wp-admin/index.php nur noch eine weiße Seite. Nach einer Google-Suche dazu habe ich dann sowohl Cookies/Cache gelöscht als auch .htaccess umbenannt, alles ohne Erfolg.

    Ich habe jetzt Datenbank und den Inhalt des wordpress-Verzeichnisses komplett gelöscht und will es erneut versuchen.

    Was kann ich tun, um das Problem bei einem Neuversuch zu vermeiden?

    Ist es ein Fehler oder best practice, die WP-Installation in einen Unterordner des Webspace und somit in den root-Ordner einer Domain zu legen?

    LG
    Sebastian
     
    #1 sedi, 16. Dezember 2018
    Zuletzt bearbeitet: 16. Dezember 2018
  2. sedi

    sedi New Member

    Registriert seit:
    15. Dezember 2018
    Beiträge:
    4
    Zustimmungen:
    1
    Ich habe es erneut versucht, mit demselben Ergebnis. Hier mein "Log":

    - Dateien entzipt
    - auf webspace/wordpress hochgeladen (das ist, für den Moment, stimmrecht.com)
    - frische Datenbank mit starkem Passwort erstellt
    - mit der Info die Installation gestartet
    - Installation lief durch
    - wp-config.php editiert ("define('WP_ALLOW_MULTISITE', true);" am vorgeschriebenen Ort zugefügt
    - (gespeichert & hochgeladen)
    - Mit der Option Unterverzeichnisse (nicht Subdomains) abgeschlossen
    - den angegebenen Code in wp-config.php eingefügt: "define('COOKIE_DOMAIN', '');"
    - den angegebenen Code in .htaccess (zwischen "<IfModule mod_rewrite.c>" and "</IfModule>") eingefügt
    - (beide gespeichert & hochgeladen)
    - "login" auf http://stimmrecht.com/wp-admin/network.php geklickt
    Login war nicht erfolgreich:
    http://stimmrecht.com/wp-login.php?redirect_to=http://stimmrecht.com/wp-admin/&reauth=1
    Ich fühle mich wirklich verloren... :(
     
    #2 sedi, 16. Dezember 2018
    Zuletzt bearbeitet: 16. Dezember 2018
  3. mensmaximus

    mensmaximus Well-Known Member

    Registriert seit:
    24. Juli 2014
    Beiträge:
    8.859
    Zustimmungen:
    433
    Die wp-config.php muss mit einem Texteditor bearbeitet werden (nicht Word oder Mac Equivalent) und im Format UTF-8 ohne Bom gespeichert werden. Die Übertragung per FTP muss dann im Binär Modus durchgeführt werden. Bitte prüfen.
     
    sedi gefällt das.
  4. sedi

    sedi New Member

    Registriert seit:
    15. Dezember 2018
    Beiträge:
    4
    Zustimmungen:
    1
    Danke für deine Antwort, mensmaximus!
    Ist genau so erfolgt. Werkzeuge waren Notepad++ und FileZilla. Ich habe auch in der Vergangenheit schon öfter an .htaccess- und php-Dateien herumgeschraubt, daher bin ich über diesen Fallstrick nicht gestolpert.

    Ich tendiere inzwischen dazu, aufzugeben und jeweils eine einzelne WP-Version mit je einer eigenen Datenbank zu verwenden. Ich glaube, meine Einschätzung, multisite zu brauchen ("besser für später") muss ich revidieren. Es geht um 2-4 voneinander unabhängige Domains. Speicherplatz ist genug vorhanden, mehr als 20 Datenbanken sind auch noch frei.

    Spricht viel dagegen, das einfach "dezentral" zu machen?

    (Ernsthafte Frage - ich bin wirklich unsicher.)
     
  5. sedi

    sedi New Member

    Registriert seit:
    15. Dezember 2018
    Beiträge:
    4
    Zustimmungen:
    1
    Ich habe von Multisite Abstand genommen. Ob das die richtige Entscheidung ist, wird dann wohl die Zeit zeigen müssen.
     
    JABA-Hosting gefällt das.
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden